Acceleration 3d RADEON 9600 disabled

Le
Gapy
--=-9FsqK1c0/9AXq4PSJ0a4
Content-Type: text/plain; charset=ISO-8859-15
Content-Transfer-Encoding: 8bit

Bonsoir,

J' ai installé les drivers ATI (téléchargés sur ATI). J' ai fais l'
installation par dpkg. Je voudrais utiliser l' accélération 3D mais cela
ne fonctionne pas.

fglrxinfo donne :
fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)

Voici les dernières lignes de Xorg.0.log :

(II) fglrx(0): driver needs X.org 6.8.x.y with x.y >= 99.8
(II) fglrx(0): detected X.org 7.0.0.0
(II) Loading extension ATIFGLRXDRI
(II) fglrx(0): doing DRIScreenInit
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: Open failed
[drm] failed to load kernel module "fglrx"
(II) fglrx(0): [drm] drmOpen failed
(EE) fglrx(0): DRIScreenInit failed!
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): ********************************************* *
(II) fglrx(0): FBADPhys: 0xd0000000 FBMappedSize: 0x08000000
(==) fglrx(0): Write-combining range (0xd0000000,0x8000000)
(II) fglrx(0): FBMM initialized for area (0,0)-(2560,8191)
(II) fglrx(0): FBMM auto alloc for area (0,0)-(2560,1024) (front color
buffer - assumption)
(==) fglrx(0): Backing store disabled
(==) fglrx(0): Silken mouse enabled
(==) fglrx(0): Using hardware cursor (scanline 1024)
(II) fglrx(0): Largest offscreen area available: 2560 x 7165
(II) fglrx(0): Initialized in-driver Xinerama extension
(WW) fglrx(0): Option "(null)" is not used
(II) fglrx(0): Using XFree86 Acceleration Architecture (XAA)
Screen to screen bit blits
Solid filled rectangles
Solid Horizontal and Vertical Lines
Offscreen Pixmaps
Setting up tile and stipple cache:
32 128x128 slots
32 256x256 slots
16 512x512 slots
(II) fglrx(0): Acceleration enabled
(II) fglrx(0): Direct rendering disabled
(II) Loading extension FGLRXEXTENSION
(II) Loading extension ATITVOUT


Pour les courageux, je joins mon fichier xorg.conf que j' ai généré
avec le binaire aticonfig.

Mille mercis pour votre aide.

A plus.

--=-9FsqK1c0/9AXq4PSJ0a4
Content-Disposition: attachment; filename=xorg.conf
Content-Type: text/plain; name=xorg.conf; charset=ISO-8859-15
Content-Transfer-Encoding: 7bit


# xorg.conf (Xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
# cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
# md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum
# dpkg-reconfigure xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "aticonfig Screen 0" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "Files"

# local font server
# if the local font server has problems, we can fall back on these
FontPath "unix/:7100"
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "evdev"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "L1730S"
Option "DPMS"
EndSection

Section "Monitor"
Identifier "aticonfig Monitor 0"
EndSection

Section "Monitor"
Identifier "aticonfig Monitor 1"
EndSection

Section "Device"
Identifier "ATI Technologies, Inc. RV350 AP [Radeon 9600]"
Driver "ati"
BusID "PCI:2:0:0"
EndSection

Section "Device"
Identifier "ATI Graphics Adapter 0"
Driver "fglrx"
Option "(null)"
Option "DesktopSetup" "horizontal"
Option "OverlayOnCRTC2" "1"
BusID "PCI:2:0:0"
EndSection

Section "Device"
Identifier "ATI Graphics Adapter 1"
Driver "fglrx"
BusID "PCI:2:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. RV350 AP [Radeon 9600]"
Monitor "L1730S"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig Screen 0"
Device "ATI Graphics Adapter 0"
Monitor "aticonfig Monitor 0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig Screen 1"
Device "ATI Graphics Adapter 1"
Monitor "aticonfig Monitor 1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection


--=-9FsqK1c0/9AXq4PSJ0a4--


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
François Boisson
Le #9007461
Le Mon, 03 Apr 2006 21:51:45 +0200
Gapy
[drm] failed to load kernel module "fglrx"




Que donne un modprobe fglrx???


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Gapy
Le #9007451
Le lundi 03 avril 2006 à 22:05 +0200, François Boisson a écrit :
Le Mon, 03 Apr 2006 21:51:45 +0200
Gapy
> [drm] failed to load kernel module "fglrx"


Que donne un modprobe fglrx???





# modprobe fglrx
FATAL: Module fglrx not found.

# insmod fglrx
insmod: can't read 'fglrx': No such file or directory

J' avoue que de savoir que le module n' est pas loadé ne m' avance pas
énormement. Je pensais que l' installation s' occupait de tout. Et je
suis en short de newbie.

dpkg -l | grep fglrx
ii fglrx-control-qt3 8.23.7-1 Control
panel for the ATI graphics accelerat
ii fglrx-driver 8.23.7-1 Video
driver for the ATI graphics accelerato
ii fglrx-driver-dev 8.23.7-1 Video
driver for the ATI graphics accelerato
ii fglrx-kernel-src 8.23.7-1 Kernel
module source for the ATI graphics ac
ii fglrx-sources 8.23.7-1 Source
code for the ATI graphics accelerator



--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
François Boisson
Le #9007441
Le Mon, 03 Apr 2006 22:15:14 +0200
Gapy
Le lundi 03 avril 2006 à 22:05 +0200, François Boisson a écrit :
> Le Mon, 03 Apr 2006 21:51:45 +0200
> Gapy >
> > [drm] failed to load kernel module "fglrx"
>
>
> Que donne un modprobe fglrx???
>
>

# modprobe fglrx
FATAL: Module fglrx not found.

# insmod fglrx
insmod: can't read 'fglrx': No such file or directory

J' avoue que de savoir que le module n' est pas loadé ne m' avance pas
énormement. Je pensais que l' installation s' occupait de tout. Et je
suis en short de newbie.




http://xoomer.virgilio.it/flavio.stanchina/debian/fglrx-installer.html

Doc très bien faite...


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Gapy
Le #9007411
Le lundi 03 avril 2006 à 22:55 +0200, François Boisson a écrit :
Le Mon, 03 Apr 2006 22:15:14 +0200
Gapy
> Le lundi 03 avril 2006 à 22:05 +0200, François Boisson a écrit :
> > Le Mon, 03 Apr 2006 21:51:45 +0200
> > Gapy > >
> > > [drm] failed to load kernel module "fglrx"
> >
> >
> > Que donne un modprobe fglrx???
> >
> >
>
> # modprobe fglrx
> FATAL: Module fglrx not found.
>
> # insmod fglrx
> insmod: can't read 'fglrx': No such file or directory
>
> J' avoue que de savoir que le module n' est pas loadé ne m' avance pas
> énormement. Je pensais que l' installation s' occupait de tout. Et je
> suis en short de newbie.


http://xoomer.virgilio.it/flavio.stanchina/debian/fglrx-installer.html

Doc très bien faite...




Oui merci ca y est ca fonctionne, je l' avais zappée pensant qu'il
fallait recompiler le kernel (je m' entraine à lire en diagonale mais je
suis pas encore au point)..;)
Un coup de

module-assistant a-i fglrx
modprobe -v fglrx

aura suffit.


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Damien ULRICH
Le #9007151
Le Lundi 03 Avril 2006 22:55, François Boisson a écrit :
Le Mon, 03 Apr 2006 22:15:14 +0200

Gapy > Le lundi 03 avril 2006 à 22:05 +0200, François Boisson a écrit :
> > Le Mon, 03 Apr 2006 21:51:45 +0200
> >
> > Gapy > > > [drm] failed to load kernel module "fglrx"
> >
> > Que donne un modprobe fglrx???
>
> # modprobe fglrx
> FATAL: Module fglrx not found.
>
> # insmod fglrx
> insmod: can't read 'fglrx': No such file or directory
>
> J' avoue que de savoir que le module n' est pas loadé ne m' avance pas
> énormement. Je pensais que l' installation s' occupait de tout. Et je
> suis en short de newbie.

http://xoomer.virgilio.it/flavio.stanchina/debian/fglrx-installer.html


Une traduction :
http://ustilago.free.fr/radeon.html

Mais perso, je cherche encore à faire fonctionner tout ça ! :P

Doc très bien faite...


Damien ULRICH
Le #9005381
Le Mardi 04 Avril 2006 17:58, Toto Capuccino a écrit :
Tu coinces où?


Argh, j'avais pas vu ta réponse ...
J'ai pas trop le temps en ce moment, je relancerai ... :$
Merci !
@+
Publicité
Poster une réponse
Anonyme