Access 2002 SP3 : pb de filtre

Le
pat
Bonjour à toutes et tous

sur un champ d'un formulaire continu, un double clic permet d'ouvrir un
autre formulaire
sur l'enregistrement choisi (code VBA de ce style)

Private Sub MONCHAMP_DblClick(Cancel As Integer)
DoCmd.OpenForm ("MONFORM"), , , "MON_NO_AUTO= " & Me.NO_AUTO
End Sub

Or le formulaire s'ouvre en mode ajout de données. ?????
alors que dans ces propriétés, onglet données, le filtre est présent, et
autoriser le filtrage est à oui

un clic droit et "appliquer le filtre/tri" m'affiche bien l'enregistrement
choisi

ce phénomène est aléatoire qui plus est

si quelqu'un(e) a une idée ?
elle sera la bienvenue

merci

et à bientôt
Patrick
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Raymond [mvp]
Le #5053891
Bonjour.

je ne connais pas l'incidence des ( ) mais je pense que la ) doit semer la
panique sur la ligne.
DoCmd.OpenForm "MONFORM",

--
@+
Raymond Access MVP
http://access.seneque.free.fr/
http://access2003.free.fr/
http://users.skynet.be/mpfa/ pour débuter sur le forum


"pat" news:
Bonjour à toutes et tous

sur un champ d'un formulaire continu, un double clic permet d'ouvrir un
autre formulaire
sur l'enregistrement choisi (code VBA de ce style)

Private Sub MONCHAMP_DblClick(Cancel As Integer)
DoCmd.OpenForm ("MONFORM"), , , "MON_NO_AUTO= " & Me.NO_AUTO
End Sub

Or le formulaire s'ouvre en mode ajout de données.... ?????
alors que dans ces propriétés, onglet données, le filtre est présent, et
autoriser le filtrage est à oui

un clic droit et "appliquer le filtre/tri" m'affiche bien l'enregistrement
choisi

ce phénomène est aléatoire qui plus est

si quelqu'un(e) a une idée ?
elle sera la bienvenue

merci

et à bientôt
Patrick




pat
Le #5053741
Merci Raymond de ta diligence

je ne connais pas l'incidence des ( ) mais je pense que la ) doit semer la
panique sur la ligne.
DoCmd.OpenForm "MONFORM",


euh.... moment d'égarement de ma part en fait les ( ) sont une réminiscence
d'une vieille voire très vieille habitude à vasouiller entre les 2 outils
que je pratique
à savoir Access et Windev

effectivement les ( ) ne servent à rien dans access, mais dans windev oui

bien merci de m'avoir remis sur les rails

Patrick

Publicité
Poster une réponse
Anonyme