Acpid dysfonctionne à la sortie d'une mise en veille.

Le
Benoit B
Bonjour,

Sur mon ordi portable, j’utilise l'ACPI pour programmer les touches=
de
fonction (volume sonore, mute et rétroéclairage).

J'ai installé : acpid qui installe acpi-support-base en dépendenc=
e.

Quand on presse la touche de fonction pour augmenter le
rétro-éclairage, acpi_listen doit afficher un truc du genre :

video/brightnessup BRTUP 00000086 000000

"video/brightnessup" est le nom de l'évènement à intercepter=
et qui
appelle un script qui incrémente :
/sys/class/backlight/intel_backlight/brightness

D'un minimum (pour ne pas avoir un écran noir) à un maximum indiq=
ué dans :
/sys/class/backlight/intel_backlight/max_brightness

Dans /etc/acpi/events/ je place les fichiers brightness-down et
brightness-up qui appellent le script (brightness.sh) ainsi :

# /etc/acpi/events/brightness-up

event=video[ /]brightnessup
action=/etc/acpi/actions/brightness.sh up

Ca a toujours bien fonctionné sur deux portables (celui d’avan=
t et
d’encore avant).

Mais sur celui-ci, les évènements brightness(up et down) cessent =
de
fonctionner à la sortie d’une mise en veille (alors que volume=
(up et
down) continuent à fonctionner).

Le script de rétroéclairage n’est donc pas appelé, (=
mais si je
l’appelle en ligne de commande, ça fonctionne).

J’ai beau redémarrer acpid :
systemctl restart acpid.socket
systemctl restart acpid.path
systemctl restart acpid.service

J’ai essayé de redémarrer tout ce que je trouve pour =
tre sûr…

Ca ne fonctionne pas (sauf si je reboot et seulement jusqu’à l=
a
prochaine mise en veille).

Quelqu’un a une idée ?

Merci d’avance


Benoit
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Haricophile
Le #26515380
Le samedi 27 avril 2019 à 20:04 +0200, Benoit B a écrit :
Quelqu’un a une idée ?

Une histoire d'ordre dans la séquence de démarrage de systemD ?
Publicité
Poster une réponse
Anonyme