Affichage application DOS

Le
Freetime
Bonjour,

J'ai une application hôtelière (GHM Nova 2000) qui s'exécute sous DOS en
plein écran sur quelques postes du réseau.

Sur certains PC, l'affichage est correct, et sur certains, les textes sont
des hiéroglyphes. Tous les pilotes sont installés, et la configuration est
quasi similaire, voire même, si je ne me trompe pas, identique pour certains
cas.

C'est très aléatoire d'autant plus que le logiciel est strictement identique
sur les pc, ainsi que les sécurités.

Je ne trouve aucune solution. Les stations sont tous sous 2000 mis à jour.

Merci de votre aide

--
J'utilise la version gratuite de SPAMfighter pour utilisateurs privés.
312 e-mails spam ont été bloqués jusqu'à maintenant.
Les utilisateurs payant n'ont pas ce message dans leurs e-mails.
Essayez SPAMfighter gratuitement maintenant!
Vos réponses
Trier par : date / pertinence
Glenn Gagné
Le #1082302
J'ai déjà eu ce genre de problème... mais malheureusement je ne me rappel
plus comment j'ai résolu cela.

Si ma mémoire est bonne c'était du à la carte graphique (et ou le pilote)
utilisé.

Si je faisais lancer l'application en mode fenêtré et qu'ensuite,
l'utilisateur faisait ALT+ENTER pour basculer en mode graphique c'était
correct ... ou bien il devait rester en mode fenêtré et le mode plein écran
ne fonctionnait pas.

Je sais qu'on avait tenté de travailler sur les paramètres du raccourci PIF
afin de changer l'allocation de la mémoire, des polices et taille de l'écran
aussi.

Je sais que ma solution est très vague, mais c'était autour de ça :o) Ça
remont à plus de 5 ans ce problème pour moi et on n'utilise plus ce logiciel
MS-DOS (Sigec) depuis 3 ans.

Glenn Gagné
Technicien MCP/TI


"Freetime" news:45b714f2$0$25922$
Bonjour,

J'ai une application hôtelière (GHM Nova 2000) qui s'exécute sous DOS en
plein écran sur quelques postes du réseau.

Sur certains PC, l'affichage est correct, et sur certains, les textes sont
des hiéroglyphes. Tous les pilotes sont installés, et la configuration est
quasi similaire, voire même, si je ne me trompe pas, identique pour
certains

cas.

C'est très aléatoire d'autant plus que le logiciel est strictement
identique

sur les pc, ainsi que les sécurités.

Je ne trouve aucune solution. Les stations sont tous sous 2000 mis à jour.

Merci de votre aide

--------------------------------------------------------------------------
------

J'utilise la version gratuite de SPAMfighter pour utilisateurs privés.
312 e-mails spam ont été bloqués jusqu'à maintenant.
Les utilisateurs payant n'ont pas ce message dans leurs e-mails.
Essayez SPAMfighter gratuitement maintenant!




Freetime
Le #1082300
"Glenn Gagné" %23%23NBS2$
J'ai déjà eu ce genre de problème... mais malheureusement je ne me rappel
plus comment j'ai résolu cela.

Si ma mémoire est bonne c'était du à la carte graphique (et ou le pilote)
utilisé.


J'ai supposé également cela

Si je faisais lancer l'application en mode fenêtré et qu'ensuite,
l'utilisateur faisait ALT+ENTER pour basculer en mode graphique c'était
correct ... ou bien il devait rester en mode fenêtré et le mode plein
écran
ne fonctionnait pas.


Je ferais un test en mode fenetré pour voir, j'avoue ne pas avoir essayé car
je ne voyais pas comment cela aurait pu changé l'affichage.

Je sais qu'on avait tenté de travailler sur les paramètres du raccourci
PIF
afin de changer l'allocation de la mémoire, des polices et taille de
l'écran
aussi.


J'ai modifier également le raccourci à plusieurs reprises, mais sans succès.
Je tenterai de nouvelles options.

Je sais que ma solution est très vague, mais c'était autour de ça :o) Ça
remont à plus de 5 ans ce problème pour moi et on n'utilise plus ce
logiciel
MS-DOS (Sigec) depuis 3 ans.


Quelle chance !

Merci pour ta réponse,
Cordialement.

--------------------------------------------------------------------------------
J'utilise la version gratuite de SPAMfighter pour utilisateurs privés.
325 e-mails spam ont été bloqués jusqu'à maintenant.
Les utilisateurs payant n'ont pas ce message dans leurs e-mails.
Essayez SPAMfighter gratuitement maintenant!

Eric Giffard
Le #1068837
"Freetime" a écrit dans le message de news:
Bonjour,
J'ai une application hôtelière (GHM Nova 2000) qui s'exécute sous DOS en
plein écran sur quelques postes du réseau.
Sur certains PC, l'affichage est correct, et sur certains, les textes sont
des hiéroglyphes. Tous les pilotes sont installés, et la configuration est
quasi similaire, voire même, si je ne me trompe pas, identique pour
certains cas.
C'est très aléatoire d'autant plus que le logiciel est strictement
identique sur les pc, ainsi que les sécurités.
Je ne trouve aucune solution. Les stations sont tous sous 2000 mis à jour.
Merci de votre aide


Bonjour
Les fichiers Autoexec.nt et Config.nt sont les mêmes sur toutes les stations
et les propriétés des raccourcis (PIF) sont les mêmes aussi ?

A bientôt

Eric Giffard
MCSE Windows 2003
MCT Windows 2000/2003/XP

Enlever les ~ pour une réponse
eric.giffard@~laposte.net (perso)
eric.g@~nextmedia.fr (boulot)

Freetime
Le #1068674
"Eric Giffard"
"Freetime" a écrit dans le message de news:
Bonjour,
J'ai une application hôtelière (GHM Nova 2000) qui s'exécute sous DOS en
plein écran sur quelques postes du réseau.
Sur certains PC, l'affichage est correct, et sur certains, les textes
sont des hiéroglyphes. Tous les pilotes sont installés, et la
configuration est quasi similaire, voire même, si je ne me trompe pas,
identique pour certains cas.
C'est très aléatoire d'autant plus que le logiciel est strictement
identique sur les pc, ainsi que les sécurités.
Je ne trouve aucune solution. Les stations sont tous sous 2000 mis à
jour.
Merci de votre aide


Bonjour
Les fichiers Autoexec.nt et Config.nt sont les mêmes sur toutes les
stations et les propriétés des raccourcis (PIF) sont les mêmes aussi ?

A bientôt

Eric Giffard
MCSE Windows 2003
MCT Windows 2000/2003/XP

Enlever les ~ pour une réponse
eric.giffard@~laposte.net (perso)
eric.g@~nextmedia.fr (boulot)

Autoexec et config, je n'ai pas regardé, je ferais ça dès lundi.


Merci de te pencher sur mon soucis.

Cordialement


Th.A.C
Le #1068672


Autoexec et config, je n'ai pas regardé, je ferais ça dès lundi.


Merci de te pencher sur mon soucis.

Cordialement


Regarde en particulier s'il n'y a pas une ligne avec 'ANSI.SYS' dans le
config.nt des postes qui marchent bien.


Freetime
Le #1068496
"Th.A.C" %


Autoexec et config, je n'ai pas regardé, je ferais ça dès lundi.


Merci de te pencher sur mon soucis.

Cordialement


Regarde en particulier s'il n'y a pas une ligne avec 'ANSI.SYS' dans le
config.nt des postes qui marchent bien.


J'en prends bonne note, je regarde tout cela dès demain matin. Merci à tous
de votre aide :)



Freetime
Le #1068326
"Th.A.C" %


Autoexec et config, je n'ai pas regardé, je ferais ça dès lundi.


Merci de te pencher sur mon soucis.

Cordialement


Regarde en particulier s'il n'y a pas une ligne avec 'ANSI.SYS' dans le
config.nt des postes qui marchent bien.


Tous les postes ont strictement les même fichiers .nt, tout en REM
d'ailleurs.



Freetime
Le #1068322
"Freetime" 45b714f2$0$25922$
Bonjour,

J'ai une application hôtelière (GHM Nova 2000) qui s'exécute sous DOS en
plein écran sur quelques postes du réseau.

Sur certains PC, l'affichage est correct, et sur certains, les textes sont
des hiéroglyphes. Tous les pilotes sont installés, et la configuration est
quasi similaire, voire même, si je ne me trompe pas, identique pour
certains cas.

C'est très aléatoire d'autant plus que le logiciel est strictement
identique sur les pc, ainsi que les sécurités.

Je ne trouve aucune solution. Les stations sont tous sous 2000 mis à jour.

Merci de votre aide



Bon j'ai trouvé la solution. Certaines cartes graphiques ne savent pas gérer
correctement l'affichage DOS en 8x14 notamment. Il suffit de charger en
mémoire fiw8x14
(http://www.bttr-software.de/products/fix8x14/download.php?file=fix8x14b.zip)
et le tour est joué !

Publicité
Poster une réponse
Anonyme