aide avec nb.si

Le
Souris
Bonjour,

j'aimerais avoir votre opinion j'ai une colonne avec des # de téléphone
en format (xxx) xxx-xxxx. J'ai besoin de savoir j'ai combien d'entrées ayant
le même code régional et les 3 premiers chiffres.

(418) 239-0000
(418) 545-0000
(418) 239-0001

J'ai 2 entrées ayant (418) 239

Merci de votre aide!
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #1241685
Bonjour souris,

Tu peux utiliser ceci :

Les données en A1:A3
Le numéro de téléphone à comparer en A1
=SOMMEPROD((GAUCHE(A1:A3;9)=GAUCHE(A1;9))*1)

Ou ceci

=SOMME(SI(GAUCHE(A1:A3;9)=GAUCHE(A1;9);1))

Validation matricielle Ctrl + Maj + Enter


Salutations!



"Souris" Bonjour,

j'aimerais avoir votre opinion... j'ai une colonne avec des # de téléphone
en format (xxx) xxx-xxxx. J'ai besoin de savoir j'ai combien d'entrées ayant
le même code régional et les 3 premiers chiffres.

(418) 239-0000
(418) 545-0000
(418) 239-0001

J'ai 2 entrées ayant (418) 239

Merci de votre aide!
AV
Le #1241444
Exemple avec ta liste de numéros en A1:A20 (à adapter) - plage nommées "Numéros"
Pour extraire les "numéros" uniques :
Sélection préalable de B1:B20 -->
=SI(ESTNUM(PETITE.VALEUR(SI(EQUIV(GAUCHE(Numéros;9);GAUCHE(Numéros;9);0)=LIGNE(I
NDIRECT("1:"&LIGNES(GAUCHE(Numéros;9))));EQUIV(GAUCHE(Numéros;9);GAUCHE(Numéros;
9);0);"");LIGNE(INDIRECT("1:"&LIGNES(GAUCHE(Numéros;9))))));INDEX(GAUCHE(Numéros
;9);PETITE.VALEUR(SI(EQUIV(GAUCHE(Numéros;9);GAUCHE(Numéros;9);0)=LIGNE(INDIRECT
("1:"&LIGNES(GAUCHE(Numéros;9))));EQUIV(GAUCHE(Numéros;9);GAUCHE(Numéros;9);0);"
");LIGNE(INDIRECT("1:"&LIGNES(GAUCHE(Numéros;9))))));"")
--> validation matricielle (ctrl+maj+entrée)
Pour compter :
En C1 et recopie >> C20 :
=SI(B1="";"";SOMMEPROD((GAUCHE(Numéros;9)±)*1))


PS : si ta liste de numéros est longue, m'est avis qu'il sera préférable de
passer par une macro pour réduire les temps de recalcul
AV

"Souris"
Bonjour,

j'aimerais avoir votre opinion... j'ai une colonne avec des # de téléphone
en format (xxx) xxx-xxxx. J'ai besoin de savoir j'ai combien d'entrées ayant
le même code régional et les 3 premiers chiffres.

(418) 239-0000
(418) 545-0000
(418) 239-0001

J'ai 2 entrées ayant (418) 239

Merci de votre aide!




Souris
Le #1241443
Bonjour Michel, ça pourrait marcher... le seul problème est que (selon ton
exemple) dans ma case A1 je n'ai que les 3 premiers chiffres du numéros de
téléphone... comment dois-je m'y prendre alors???
Merci encore!

"michdenis" news:
Bonjour souris,

Tu peux utiliser ceci :

Les données en A1:A3
Le numéro de téléphone à comparer en A1
=SOMMEPROD((GAUCHE(A1:A3;9)=GAUCHE(A1;9))*1)

Ou ceci

=SOMME(SI(GAUCHE(A1:A3;9)=GAUCHE(A1;9);1))

Validation matricielle Ctrl + Maj + Enter


Salutations!



"Souris" news:

Bonjour,

j'aimerais avoir votre opinion... j'ai une colonne avec des # de téléphone
en format (xxx) xxx-xxxx. J'ai besoin de savoir j'ai combien d'entrées
ayant

le même code régional et les 3 premiers chiffres.

(418) 239-0000
(418) 545-0000
(418) 239-0001

J'ai 2 entrées ayant (418) 239

Merci de votre aide!





Souris
Le #1241442
très longue... aux alentours de 5000 entrées...

"AV" news:
Exemple avec ta liste de numéros en A1:A20 (à adapter) - plage nommées
"Numéros"

Pour extraire les "numéros" uniques :
Sélection préalable de B1:B20 -->

=SI(ESTNUM(PETITE.VALEUR(SI(EQUIV(GAUCHE(Numéros;9);GAUCHE(Numéros;9);0)=LIG

NE(I

NDIRECT("1:"&LIGNES(GAUCHE(Numéros;9))));EQUIV(GAUCHE(Numéros;9);GAUCHE(Numé

ros;

9);0);"");LIGNE(INDIRECT("1:"&LIGNES(GAUCHE(Numéros;9))))));INDEX(GAUCHE(Num

éros

;9);PETITE.VALEUR(SI(EQUIV(GAUCHE(Numéros;9);GAUCHE(Numéros;9);0)=LIGNE(INDI

RECT

("1:"&LIGNES(GAUCHE(Numéros;9))));EQUIV(GAUCHE(Numéros;9);GAUCHE(Numéros;9);

0);"
");LIGNE(INDIRECT("1:"&LIGNES(GAUCHE(Numéros;9))))));"")
--> validation matricielle (ctrl+maj+entrée)
Pour compter :
En C1 et recopie >> C20 :
=SI(B1="";"";SOMMEPROD((GAUCHE(Numéros;9)±)*1))


PS : si ta liste de numéros est longue, m'est avis qu'il sera préférable
de

passer par une macro pour réduire les temps de recalcul
AV

"Souris"
Bonjour,

j'aimerais avoir votre opinion... j'ai une colonne avec des # de
téléphone


en format (xxx) xxx-xxxx. J'ai besoin de savoir j'ai combien d'entrées
ayant


le même code régional et les 3 premiers chiffres.

(418) 239-0000
(418) 545-0000
(418) 239-0001

J'ai 2 entrées ayant (418) 239

Merci de votre aide!








Souris
Le #1241438
Merci... j'ai trouvé ma solution! merci beaucoup! :-)

"Souris" news:
Bonjour,

j'aimerais avoir votre opinion... j'ai une colonne avec des # de téléphone
en format (xxx) xxx-xxxx. J'ai besoin de savoir j'ai combien d'entrées
ayant

le même code régional et les 3 premiers chiffres.

(418) 239-0000
(418) 545-0000
(418) 239-0001

J'ai 2 entrées ayant (418) 239

Merci de votre aide!




AV
Le #1241436
Merci... j'ai trouvé ma solution!


On est content !
AV

Publicité
Poster une réponse
Anonyme