Aide sur formule

Le
Marc Dayde
La formule suivante fonctionne pas( xp me dit qu'il y a une erreur, mais
sait pas la ou les trouver
:=SI(E21="MS";RECHERCHEV(E24;J65:L109;3;0));SI(ET(E20>0;E23="E";RECHERCHEV(E
24;N31:R47;3;0);(E20>0;E23="X";RECHERCHEV(E24;N31:R47;4;0)))). J'essaie
d'expliquer : la 1ere partie fonctionne bien seule; dés que j'embraye la
2eme partie avec le deuxieme SI (et = ploufff!!! Ce que je
voudrais faire: Soit je travaille avec E21 (un seul choix "MS"), soit je
travaille avec E20 ( plusieurs selections dans la cellule) et E23 ( avec
deux choix obligatoires : "E" ou "X" , qui renvoient bien entendu à une
colonne differente de la matrice. Si quelqu'un peut me dépatouiller la
formule, qu'il en soit d'avance remercié!
Résumé : calcul avec : soit E21=MS : soit E20 et E23( deux choix
possibles : E ou X)
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #1236707
bonjour Marc,

il y a une parenthèse au mauvait endroit,
il faut fermer la parenthèse du "Et" avant de mettre les conditions
"vrai" et "faux"
=SI(ET(A1=1;A2=1);1;0)

isabelle


La formule suivante fonctionne pas( xp me dit qu'il y a une erreur, mais
sait pas la ou les trouver
:=SI(E21="MS";RECHERCHEV(E24;J65:L109;3;0));SI(ET(E20>0;E23="E";RECHERCHEV(E
24;N31:R47;3;0);(E20>0;E23="X";RECHERCHEV(E24;N31:R47;4;0)))). J'essaie
d'expliquer : la 1ere partie fonctionne bien seule; dés que j'embraye la
2eme partie avec le deuxieme SI (et...... = ploufff!!! Ce que je
voudrais faire: Soit je travaille avec E21 (un seul choix "MS"), soit je
travaille avec E20 ( plusieurs selections dans la cellule) et E23 ( avec
deux choix obligatoires : "E" ou "X" , qui renvoient bien entendu à une
colonne differente de la matrice. Si quelqu'un peut me dépatouiller la
formule, qu'il en soit d'avance remercié!
Résumé : calcul avec : soit E21=MS : soit E20 et E23( deux choix
possibles : E ou X)


Marc Dayde
Le #1236459
Salut Isa ,
Ok sur les parentheses, mais peut tu etre plus explicite dans la formule,
parce que A1=1 et A2=1, y comme qui dirait un peu de brume...... :-))
"isabelle" news:
bonjour Marc,

il y a une parenthèse au mauvait endroit,
il faut fermer la parenthèse du "Et" avant de mettre les conditions
"vrai" et "faux"
=SI(ET(A1=1;A2=1);1;0)

isabelle


La formule suivante fonctionne pas( xp me dit qu'il y a une erreur, mais
sait pas la ou les trouver

:=SI(E21="MS";RECHERCHEV(E24;J65:L109;3;0));SI(ET(E20>0;E23="E";RECHERCHEV(E


24;N31:R47;3;0);(E20>0;E23="X";RECHERCHEV(E24;N31:R47;4;0)))).
J'essaie


d'expliquer : la 1ere partie fonctionne bien seule; dés que j'embraye la
2eme partie avec le deuxieme SI (et...... = ploufff!!! Ce que je
voudrais faire: Soit je travaille avec E21 (un seul choix "MS"), soit je
travaille avec E20 ( plusieurs selections dans la cellule) et E23 ( avec
deux choix obligatoires : "E" ou "X" , qui renvoient bien entendu à une
colonne differente de la matrice. Si quelqu'un peut me dépatouiller la
formule, qu'il en soit d'avance remercié!
Résumé : calcul avec : soit E21=MS : soit E20 et E23( deux
choix


possibles : E ou X)




isabelle
Le #1236455
;-) ce n'était qu'un exemple, voici la table des valeurs de la formule
=SI(ET(A1=1;A2=1);1;0):

A1 A2 résultat
0 0 0
0 1 0
1 0 0
1 1 1


isabelle


Salut Isa ,
Ok sur les parentheses, mais peut tu etre plus explicite dans la formule,
parce que A1=1 et A2=1, y comme qui dirait un peu de brume...... :-))
"isabelle" news:
bonjour Marc,

il y a une parenthèse au mauvait endroit,
il faut fermer la parenthèse du "Et" avant de mettre les conditions
"vrai" et "faux"
=SI(ET(A1=1;A2=1);1;0)

isabelle


La formule suivante fonctionne pas( xp me dit qu'il y a une erreur, mais
sait pas la ou les trouver

:=SI(E21="MS";RECHERCHEV(E24;J65:L109;3;0));SI(ET(E20>0;E23="E";RECHERCHEV(E


24;N31:R47;3;0);(E20>0;E23="X";RECHERCHEV(E24;N31:R47;4;0)))).
J'essaie


d'expliquer : la 1ere partie fonctionne bien seule; dés que j'embraye la
2eme partie avec le deuxieme SI (et...... = ploufff!!! Ce que je
voudrais faire: Soit je travaille avec E21 (un seul choix "MS"), soit je
travaille avec E20 ( plusieurs selections dans la cellule) et E23 ( avec
deux choix obligatoires : "E" ou "X" , qui renvoient bien entendu à une
colonne differente de la matrice. Si quelqu'un peut me dépatouiller la
formule, qu'il en soit d'avance remercié!
Résumé : calcul avec : soit E21=MS : soit E20 et E23( deux
choix


possibles : E ou X)






Marc Daydé
Le #1282575
:-))) !! Comprends rien! :-) Désolé Isa, mais je débute et je
n'ai pas la moindre formation sur les formules. Donc quand tu me montre des
exemples, ça veut pas dire grand chose pour moi! Merci de ton infinie
patience!
Ricky [MVP]
Le #1282570
Bonjour *Marc Daydé* (et tous les lecteurs)
| :-))) !! Comprends rien! :-) Désolé Isa, mais je
| débute et je n'ai pas la moindre formation sur les formules. Donc
| quand tu me montre des exemples, ça veut pas dire grand chose pour
| moi! Merci de ton infinie patience!

:=SI(E21="MS";RECHERCHEV(E24;J65:L109;3;0);SI(ET(E20>0;E23="E");RECHERCHEV(E
24;N31:R47;3;0);SI(ET(E20>0;E23="X");RECHERCHEV(E24;N31:R47;4;0);"manque le Sinon"))).

Ca devrait plutôt ressembler à ceci

--
Ricky [MVP] Visitez les faq....
http://www.faqoe.com http://faq.ms.word.free.fr
http://dj.joss.free.fr/faq.htm http://www.excelabo.net
http://support.microsoft.com/directory/worldwide/fr/newsgroup/regles.htm
Ricky [MVP]
Le #1282567
Bonjour *Ricky [MVP]* (et tous les lecteurs)
Explication

| :=SI(E21="MS";RECHERCHEV(E24;J65:L109;3;0);SI(ET(E20>0;E23="E");RECHERCHEV(E
| 24;N31:R47;3;0);SI(ET(E20>0;E23="X");RECHERCHEV(E24;N31:R47;4;0);"manque
| le Sinon"))).

=SI(
condition ;
sioui ;
sinon)

On remplace sinon par

SI(
condition ;
sioui ;
sinon)

Et ainsi de suite mais on conserve toutes les parenthèses

Si on utilise ET on aura

=SI(
ET(condition1;condition2;conditionx) ;
remplace condition du premier exemple ;

sioui ;
sinon)

Compter les parenthèses ouvertes et fermées (le même nombre
Vérifier qu'elles sont placées au bon endroit. Excel corrige parfois un manque de parenthèses à sa manière qui n'est pas nécessairement correcte.

--
Ricky [MVP] Visitez les faq....
http://www.faqoe.com http://faq.ms.word.free.fr
http://dj.joss.free.fr/faq.htm http://www.excelabo.net
http://support.microsoft.com/directory/worldwide/fr/newsgroup/regles.htm
Publicité
Poster une réponse
Anonyme