Aide pour remplissage ligne couleur

Le
mauop Hors ligne
Bonjour,
Je me permet de vous solliciter car je n'arrive pas à le faire toute seule!!
Je souhaite faire un fichier Excel ou lorsque toutes les colonnes ont une croix, la ligne soit verte. Je n'y arrive pas avec la mise en forme conditionnelle, la ligne est verte alors que certaines colonnes sont vides! Et la première colonne qui comporte le titre n'est pas verte non plus alors que j'aimerais que ça soit toute la ligne.
J'espère être assez claire dans mon besoin, je suis assez novice dans tout ça!
Merci d'avance pour votre aide :)
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichD
Le #26541334
Le 26/03/20 à 09:12, mauop a écrit :
Bonjour,
Je me permet de vous solliciter car je n'arrive pas à le faire toute seule!!
Je souhaite faire un fichier Excel ou lorsque toutes les colonnes ont une croix,
la ligne soit verte. Je n'y arrive pas avec la mise en forme conditionnelle, la
ligne est verte alors que certaines colonnes sont vides! Et la première colonne
qui comporte le titre n'est pas verte non plus alors que j'aimerais que ça soit
toute la ligne.
J'espère être assez claire dans mon besoin, je suis assez novice dans tout ça!
Merci d'avance pour votre aide :)


Bonjour,
Pour les besoins de l'exemple :
soit la ligne : A1:G1
Mise en forme conditionnelle :
Tu sélectionnes la plage A1:G1
Tu appelles la mise en forme conditionnelle
Tu utilises cette formule :
=ET(A1="x";NB.SI($A$1:$G$1;"X")=7)
Et tu choisis la couleur que tu désires comme format.
MichD
mauop Hors ligne
Le #26541457
Le jeudi 26 Mars 2020 à 15:21 par MichD :
Le 26/03/20 à 09:12, mauop a écrit :
Bonjour,
Je me permet de vous solliciter car je n'arrive pas à le faire toute
seule!!
Je souhaite faire un fichier Excel ou lorsque toutes les colonnes ont une
croix,
la ligne soit verte. Je n'y arrive pas avec la mise en forme conditionnelle,
la
ligne est verte alors que certaines colonnes sont vides! Et la première
colonne
qui comporte le titre n'est pas verte non plus alors que j'aimerais que
ça soit
toute la ligne.
J'espère être assez claire dans mon besoin, je suis assez novice
dans tout ça!
Merci d'avance pour votre aide :)

Bonjour,

Pour les besoins de l'exemple :

soit la ligne : A1:G1

Mise en forme conditionnelle :

Tu sélectionnes la plage A1:G1
Tu appelles la mise en forme conditionnelle

Tu utilises cette formule :
=ET(A1="x";NB.SI($A$1:$G$1;"X")=7)

Et tu choisis la couleur que tu désires comme format.

MichD


Bonjour,
Merci beaucoup ;)
Je dois mal faire quelques choses car pas de couleur.

Dans mon fichier j'ai 10 colonnes. Les colonnes D à I contiennent des croix. Pour les autres, c'est du texte.

J’ai sélectionné « mise en forme conditionnelle », « nouvelle règle », « utiliser une formule pour déterminer pour quelles cellules le format sera appliqué », dans « appliquer une mise en forme aux valeurs pour lesquelles cette formule est vrai » j’ai mis ta formule. J’ais également mis la couleur de mon choix.
J’ai mis dans le champ « s’applique à » j’ai sélectionné la plage de données !
Je ne sais pas ce que je ne fais pas correctement !
MichD
Le #26541466
Dans mon fichier j'ai 10 colonnes. Les colonnes D à I contiennent des croix.
Pour les autres, c'est du texte.
J’ai sélectionné « mise en forme conditionnelle », « nouvelle règle », «
utiliser une formule pour déterminer pour quelles cellules le format sera
appliqué », dans « appliquer une mise en forme aux valeurs pour lesquelles cette
formule est vrai » j’ai mis ta formule. J’ais également mis la couleur de mon
choix.
J’ai mis dans le champ « s’applique à » j’ai sélectionné la plage de données !
Je ne sais pas ce que je ne fais pas correctement !


Dans ce cas précis : Ligne = de la colonne D à i
Tu remplaces D1:i1 pour la ligne où doit débuter la ligne où doit
s'appliquer la mise en forme conditionnelle
Sélectionne la plage de cellule D1:i1
Appelle la commande "Mise en forme conditionnelle /
Gérer les règles... / Nouvelle règle / Utiliser une formule pour
déterminer pour quelles cellules le format sera appliqué
Les cellules doivent contenir un X, si les 6 cellules de la ligne
contiennent la lettre X, la mise en forme conditionnelle s'applique
Tape la formule suivante : =NB.SI($D1:$I1;"x")=6
Le 6 de la formule = nombre de cellules dans la ligne D1:i1
Choisis le format de cellule que tu veux appliquer, et tu fermes par OK,
OK, Appliquer, OK.
À l'aide du bouton "reproduire la mise en forme" du ruban, tu peux
recopier le format de la ligne $D1:$I1 sur l'ensemble des lignes en
dessous de celle-ci.
MichD
mauop Hors ligne
Le #26541478
Le vendredi 27 Mars 2020 à 12:36 par MichD :
Dans mon fichier j'ai 10 colonnes. Les colonnes D à I contiennent des
croix.
Pour les autres, c'est du texte.

J’ai sélectionné « mise en forme conditionnelle
», « nouvelle règle », «
utiliser une formule pour déterminer pour quelles cellules le format
sera
appliqué », dans « appliquer une mise en forme aux valeurs
pour lesquelles cette
formule est vrai » j’ai mis ta formule. J’ais
également mis la couleur de mon
choix.
J’ai mis dans le champ « s’applique à »
j’ai sélectionné la plage de données !
Je ne sais pas ce que je ne fais pas correctement !

Dans ce cas précis : Ligne = de la colonne D à i

Tu remplaces D1:i1 pour la ligne où doit débuter la ligne
où doit
s'appliquer la mise en forme conditionnelle

Sélectionne la plage de cellule D1:i1

Appelle la commande "Mise en forme conditionnelle /
Gérer les règles... / Nouvelle règle / Utiliser une
formule pour
déterminer pour quelles cellules le format sera appliqué

Les cellules doivent contenir un X, si les 6 cellules de la ligne
contiennent la lettre X, la mise en forme conditionnelle s'applique
Tape la formule suivante : =NB.SI($D1:$I1;"x")=6

Le 6 de la formule = nombre de cellules dans la ligne D1:i1

Choisis le format de cellule que tu veux appliquer, et tu fermes par OK,
OK, Appliquer, OK.

À l'aide du bouton "reproduire la mise en forme" du ruban, tu
peux
recopier le format de la ligne $D1:$I1 sur l'ensemble des lignes en
dessous de celle-ci.

MichD


Super merci beaucoup pour ton aide :)
Publicité
Poster une réponse
Anonyme