Un @ ajouté par Excel dans la formule

Le
Roland Miller
Bonjour,

Je cherche à savoir si cela est normal qu'Excel ait ajouté un @ d=
ans certaines formules.

Aupaavant … il n'y avait pas de @ dans la formule ci-dessous soit a=
près le ESTERREUR(.

Cela s'est aussi produit dans d'autres formules dans d'autres feuilles.

Aussi … il semble que si la version de l'usager est par exemple 201=
0 … le @ est converti en fn_ quelque chose qui crée des erreur=
s … des messages #Nom. Mais ce n'est pas moi qui ait ajouté ce=
@.

Auriez-vous déjà vu cela et avoir une idée du pourquoi? J'ai=
fais des recherches mais sans trouver que d'autres ait eu cela. Merci =
l'avance.


SI(ESTERREUR(@INDEX(CN_ChifNotes;EQUIV($B14;CN_ChifCpteZone;0);0));"";INDEX=
(CN_ChifNotes;EQUIV($B14;CN_ChifCpteZone;0);0)))
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
benoit
Le #26539430
Roland Miller
Bonjour,
Je cherche à savoir si cela est normal qu'Excel ait ajouté un @ dans
certaines formules.
Aupaavant … il n'y avait pas de @ dans la formule ci-dessous soit après le
ESTERREUR(.
Cela s'est aussi produit dans d'autres formules dans d'autres feuilles.
Aussi … il semble que si la version de l'usager est par exemple 2010 … le
@ est converti en fn_ quelque chose qui crée des erreurs … des messages
#Nom. Mais ce n'est pas moi qui ait ajouté ce @.
Auriez-vous déjà vu cela et avoir une idée du pourquoi? J'ai fais des
recherches mais sans trouver que d'autres ait eu cela. Merci à l'avance.
SI(ESTERREUR(@INDEX(CN_ChifNotes;EQUIV($B14;CN_ChifCpteZone;0);0));"";INDE
X(CN_ChifNotes;EQUIV($B14;CN_ChifCpteZone;0);0)))

Si je ne me trompe pas, tu as 6 parenthèses ouvrantes et sept fermantes.
Est-ce la raison ?
SI() ok
ESTERREUR() ok
INDEX<(CN_ChifNotes;EQUIV<($B14;CN_ChifCpteZone;0)>;0)> !!); Une de trop
""; ok
INDEX<(CN_ChifNotes;EQUIV<($B14;CN_ChifCpteZone;0)>;0)> ok
--
Vie : n.f. maladie mortelle sexuellement transmissible
Benoît chez leraillez.com
MichD
Le #26539457
Le 02/03/20 à 11:33, Roland Miller a écrit :
Bonjour,
Je cherche à savoir si cela est normal qu'Excel ait ajouté un @ dans certaines formules.
Aupaavant … il n'y avait pas de @ dans la formule ci-dessous soit après le ESTERREUR(.
Cela s'est aussi produit dans d'autres formules dans d'autres feuilles.
Aussi … il semble que si la version de l'usager est par exemple 2010 … le @ est converti en fn_ quelque chose qui crée des erreurs … des messages #Nom. Mais ce n'est pas moi qui ait ajouté ce @.
Auriez-vous déjà vu cela et avoir une idée du pourquoi? J'ai fais des recherches mais sans trouver que d'autres ait eu cela. Merci à l'avance.
SI(ESTERREUR(@INDEX(CN_ChifNotes;EQUIV($B14;CN_ChifCpteZone;0);0));"";INDEX(CN_ChifNotes;EQUIV($B14;CN_ChifCpteZone;0);0)))


Bonjour,
| si cela est normal qu'Excel ait ajouté un @ dans certaines formules
**** La seule fonction que je connaisse qui sait utiliser le symbole #
est la fonction texte. À titre d'exemple : =TEXTE(A1;"# ### ##0,00"),
utilise pour formater le nombre dans la cellule A1.
MichD
Roland Miller
Le #26539870
Merci.
Mais ce qui est curieux … ces formules y sont depuis longtemps et i l n'y avait pas ces @ dans celles-ci.
MichD
Le #26539915
Le 10/03/20 à 19:19, Roland Miller a écrit :
Bonjour,
Je viens de valider un élément très important. Il faut … que ce soit … un paramètre quelconque. Je vous invite à bien lire ce qui suit. Je suis estomaqué.
- Dans mon fichier je n'ai jamais ajouté ces @ à ces formules.
- Je prend exactement le même fichier et le transfère chez un autre usager … à un autre emplacement physique …. dans une autre ville. Donc pas de réseau pu quoi que ce soit.
- On ouvre ce fichier … et pas de @ dans les formules. ???
- En étant connecté à distance … je saisi … un @ … pour reproduire la formule sur l'autre ordi … dans le même fichier … et lorsque je tape Enter au clavier … le @ … disparait … il n'est plus dans la formule.
- À certains endroits … dans le fichier cela semble causer des problèmes. … la formule se change en #Valeur. Et il semble aussi que le @ se change en _Fn quelque chose.
Il me faudrait vraiment trouver la solution. Merci de votre aide.


Bonjour,
C'est la première fois que je lis quelque chose comme tu décris. Je n'ai
pas de solution pour cela.
As=tu regardé si le format de tes cellules contenant ce type de formule
est au format "Standard".
Regarde avec le programme "Malwarebytes" que tu peux télécharger et
utiliser gratuitement si tu n’étais pas victime d'un intrus sur ton
ordinateur.
Moi, je n'ai pas une solution pour ce que tu décris.
MichD
MichD
Le #26539986
Le 11/03/20 à 12:56, Roland Miller a écrit :
Je comprend bien merci.
Je ne sais si cela pourrait être utile ou si vous auriez déjà vu ceci.
Lorsque j'enlève les @ qui se sont placés dans certaines formules sans mon intervention suite à une MAJ de Office … ces mêmes formules deviennent des formules matricielles.
Mais à mon avis … elles n'avaient pas besoin d'être matricielles.


C'est une question trop avancée pour moi! Si ce que tu observes est
présent seulement sur ton ordinateur, j'aurais plutôt tendance à croire
qu'il y a un problème particulier avec cet observateur. Moi,
personnellement, je n'ai jamais vu cela.
En supposant que ton ordinateur n'est pas victime d'un intrus
indésirable, as-tu essayé de désinstaller Microsoft Office complètement
et de l'installer à nouveau?
La vérité, c'est que je n'ai pas une réponse à ta question.
MichD
MichD
Le #26540102
Le 12/03/20 à 12:31, Roland Miller a écrit :
Merci.
Non cela s'est produit chez tous les usagers qui ont … Office 365 16.0 … et … suite à une MAJ dont je ne suis pas certain du numéro.
C'est que seulement pour les usagers de Office 365 il y a eu des nouveautés dont entres autres des nouvelles fonctions "puissantes" disent-ils. Et c'est à ce moment que cela se produit.
J'ai 2 ordis et sur un tout était OK dû à une version antérieure de O365 16.0. J'ai installé les mises à jour et le problème est survenu. Je n'ai malheureusement pas vérifier avec précision qu'elle était la version précisément.
Que ça ajoute des @ dans des formules c'est une chose mais seulement dans certaines … une fois qu'on enregistre le fichier … et qu'on l'ouvre à nouveau il y a #Valeur … et la formule a été effacée.
Si cela pouvait être utile à certains voici un lien à cet effet. Encore merci. https://support.office.com/fr-fr/article/nouveaut%C3%A9s-d-excel-pour-office-365-5fdb9208-ff33-45b6-9e08-1f5cdb3a6c73


Désolé, je ne connais pas Office 365 ou Microsoft Office 2019.
MichD
MichD
Le #26541271
Le 25/03/20 à 20:12, Roland Miller a écrit :
Bonjour,
Voici ce que j'expérimente … si cela peut aider quelqu'un.
J'ai un fichier en format .xls qui contient des formules matricielles, COLONNE, INDEX etc.
Je me suis aperçu que dans ces formules un @ avait été ajouté depuis une mise à jour. Je ne m'en était pas rendu compte. Je crois que cela est relié à cette mise à jour qui semble t'il concernait les usagers de Office 365. . https://support.office.com/fr-fr/article/nouveaut%C3%A9s-d-excel-pour-office-365-5fdb9208-ff33-45b6-9e08-1f5cdb3a6c73
Le problème est que si le fichier a été ouvert avec un Office 365 et que donc les @ ont été ajouté à ces formules … et que … ensuite … le fichier est ouvert avec une autre version d'Excel … des formules se transforment en #Valeur ou contiennent #Nom car le @ n'est pas reconnu dans ces versions.
J'ai alors dû convertir les fichiers dans un autre format (.xlsb dans mon cas) et cela corrige la situation. En tant en .xlsb … même ouvert dans une version antérieure ou pas dans Office 365 … c'est OK.
C'est comme si les fichiers .xls ne supporte plus certaines formules … si … pas dans Office 365.


Merci du retour.
MichD
Publicité
Poster une réponse
Anonyme