Appli qui refuse de se lancer sous Big Sur

Le
Benoͮt L.
Bonjour,


Mes deux applis fonctionnant correctement, j'aimerai les partager et
j'ai un problème avec Big Sur (que j'ai enfin pu installer sur un disque
externe).

11.0 est choisi comme OS minimum (un peu partout dans les préférences du
projet). Je n'ai aucune alerte dans le code ou la compilation, mais sous
big Sur les applis ne se lancent pas, elles ont un ∅ sur l'icʹne.

De plus, lorsque Big Sur est lancé, lui, il m'affiche dans une alerte en
haut ͠ droite :
«Â Incompatible Disk
  This disk uses features that are not
  supported on this version of MacOS »

Sur le même disque, sur une autre partition, Catalina tourne sans
soucis. Auriez-vous une idée pour que :
— Je réussisse Í  faire tourner mes applis sous Big Sur (au moins)
— Je résolve ce problème d'alerte avec Big Sur.


D'avance merci,

Codes: <https://www.cjoint.com/data/LFemHcafbpC_Archive-code.zip>
Applis : <https://www.cjoint.com/data/LFemFU5yOgC_Archive-applis.zip>

-
Le disque :
Samsung Portable SSD APFS
Volume SSD Catalina APFS
SSD Catalina APFS
SSD Catalina - Données APFS
Volume SSD Big Sur APFS
Volume SSD TM APFS

-
Compilation : Xcode 13 sur Monterey


--
Un généraliste sait rien sur tout,
Un spécialiste, lui, sait tout sur rien.
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Gilbert OLIVIER
Le #26590162
le 4 juin 2022, BenoÍ®t L. a attiré mon attention sur :
11.0 est choisi comme OS minimum (un peu partout dans les préférences du
projet). Je n'ai aucune alerte dans le code ou la compilation, mais sous
big Sur les applis ne se lancent pas, elles ont un ∅ sur l'icʹne.


Sauf erreur, c'est la clé <key>LSMinimumSystemVersion</key> dans le
fichier info.plist de l'application qui indique le système minimum
requis. Je pense que c'est elle qui est utilisée pour indiquer que
l'appli n'est pas compatible avec le système trop ancien (ce qu'indique
ce symbole sur l'icone).
Regarde ce qu'elle raconte.
Pour les autres problèmes, je n'ai aucune idée.
--
Gilbert
Fleuger
Le #26590165
Le 4 juin 2022 Í  17:23, Gilbert OLIVIER a écrit ceci :
Sauf erreur, c'est la clé <key>LSMinimumSystemVersion</key> dans le
fichier info.plist de l'application qui indique le système minimum
requis. Je pense que c'est elle qui est utilisée pour indiquer que
l'appli n'est pas compatible avec le système trop ancien (ce qu'indique
ce symbole sur l'icone).
Regarde ce qu'elle raconte.

C'est ce que je pensais aussi.
J'ai récupéré les apps sous Monterey, remplacé 11 par 10.14.0 envoyé les
apps sur l'iMac. il y a le stationnement interdit sur les apps et en
essayant de les ouvrir, j'ai le message qui m'indique que le système
minimum est le 10.14.0 et qu'elle ne peut pas s'ouvrir parce que je suis
en 10.14.6.
C'est donc juste une indication, mais pas une limitation.
(Même avec le stationnement interdit, il est possible d'afficher le
contenu du paquet et de faire la modif).
Pour l'autre problème, j'ai un SSD qui est un clone du Volume qui
contient Monterey sur le MBA.
Si je le monte sur l'iMac Mojave, jai :
Mais je peux accéder au disque en passant par /Volumes (Menu Aller)
J'utilise ce disque aussi pour transférer des gros fichiers entre les
deux machines (Beaucoup plus rapide que de passer par AirDrop)
--
Gérard FLEUROT
Benoͮt L.
Le #26590169
Avec enthousiasme, le 4 juin 2022 Í  17:23, Gilbert OLIVIER écrivit :
le 4 juin 2022, BenoÍ®t L. a attiré mon attention sur :
11.0 est choisi comme OS minimum (un peu partout dans les préférences du
projet). Je n'ai aucune alerte dans le code ou la compilation, mais sous
big Sur les applis ne se lancent pas, elles ont un ∅ sur l'icʹne.

Sauf erreur, c'est la clé <key>LSMinimumSystemVersion</key> dans le
fichier info.plist de l'application qui indique le système minimum
requis. Je pense que c'est elle qui est utilisée pour indiquer que
l'appli n'est pas compatible avec le système trop ancien (ce qu'indique
ce symbole sur l'icone).
Regarde ce qu'elle raconte.


<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN"
"http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<dict>
[…]
<key>LSMinimumSystemVersion</key>
[…]
</dict>
</plist>
Ça Í  l'air correct. Je crois que j'ai un item d'interface incompatible
puisque je viens de découvrir en bas de contentView.swift :
struct ContentView_Previews: PreviewProvider {
static var previews: some View {
if #available(macOS 12.0, *) {
ContentView()
.padding(10.0)
.frame(width: nil)
}
else {
// Fallback on earlier versions
}
}
}
Si c'est le cas, j'aimerai savoir qui est le «Â fautif »…
J'ai trouvé un problème, manifestement de liste, qui demande 11.1
minimum. Je vais corriger ça dans SignAuPif, par contre le CorvoPhraseur
n'a pas de pb.
ld: warning: object file
(/Users/benoit/Library/Developer/Xcode/DerivedData/SignAuPif-emmcmgcinsbbtjeprremhlurqygv/Build/Intermediates.noindex/SignAuPif.build/Debug/SignAuPif.build/Objects-normal/x86_64/ListeSignatures
Guitry.o) was built for newer macOS version (11.1) than being linked
(11.0)
Pour les autres problèmes, je n'ai aucune idée.

Merci pour cette première partie.
--
1á´¿á´± Loi de Newton : Tant que tu fous rien, t'es pas prêt de finir.
2á´°á´± Loi de Newton : Si tu bosses de travers, tu avanceras moins vite.
3ᴱ Loi de Newton : Plus c'est simple, moins c'est dur ; alors complique pas.
-+- B. Leraillez dans «Â Y'a que le résultat qui compte » -+-
Benoͮt L.
Le #26590175
Ni vu ni connu, le 4 juin 2022 Í  20:54, Fleuger osa écrire :
J'ai récupéré les apps sous Monterey, remplacé 11 par 10.14.0 envoyé les
apps sur l'iMac. il y a le stationnement interdit sur les apps et en
essayant de les ouvrir, j'ai le message qui m'indique que le système
minimum est le 10.14.0 et qu'elle ne peut pas s'ouvrir parce que je suis
en 10.14.6.
C'est donc juste une indication, mais pas une limitation.

C'est intéressant parce que mon Big Sur installé tout neuf via cmd-alt-R
met des stationnements interdits sur iTunes & Co.
--
Dictature : ferme ta gueule. Démocratie : cause toujours.
-+- Melmoth dans «Â Au carrefour, Í  droite ou Í  gauche ? » -+-
Poster une réponse
Anonyme