apt-get bloqué a cause d'un paquet mal installé

Le
Jean-Baptiste DIOGON
Bonjour

j'ai voulu installer un pilote pour mon "linmodem" : ltmodem-2.6.8-1-686

l'installation n'a pas marché (unable to find the way your distribution automatically load modules)

mais maintenant : impossible d'enlever le paquet :
j'ai essayé dpkg purge, remove,
apt-get
aptitude
dselect

rien n'y fait

"le paquet est dans un état incohérent, vous devriez le réinstaller avant d'essayer de le supprimer"

quelqu'un saurait-il comment je peux faire pour me débarasser de ce paquet, ou pour l'enlever de la liste de apt-get, car à chaque fois que je veux installer ou désinstaller d'autres paquets, celui-ci me bloque tout.

merci de votre aide
Vos réponses
Trier par : date / pertinence
Pascal BOYER
Le #9417741
Jean-Baptiste DIOGON wrote:

Bonjour




Salut,

j'ai voulu installer un pilote pour mon "linmodem" : ltmodem-2.6.8-1-686

l'installation n'a pas marché (unable to find the way your distribution automatically load modules)

mais maintenant : impossible d'enlever le paquet :
j'ai essayé dpkg purge, remove,
apt-get
aptitude
dselect

rien n'y fait...

"le paquet est dans un état incohérent, vous devriez le réinstaller avant d'essayer de le supprimer"

quelqu'un saurait-il comment je peux faire pour me débarasser de ce paquet, ou pour l'enlever de la liste de apt-get, car à chaque fois que je veux installer ou désinstaller d'autres paquets, celui-ci me bloque tout.

merci de votre aide




Voilà ce que je fais quand j'ai ce problème, ce qui est rare heureusement:

vi /var/lib/dpkg/status

et j'efface toutes les lignes (la première commençant par Package: )
concernant le package cassé ou mal installé.

et je relance apt ou dpkg

Dans ton cas, si chaque fois que tu installes ce package, tu as le même
problème et bien tu effaces et les lignes dans /var/lib/dpkg/status et
les fichiers installés par le package (suppression à la main bien sûr)

Pascal


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Raphaël 'SurcouF' Bordet
Le #9417711
Le lundi 01 novembre 2004 à 13:32 +0100, Jean-Baptiste DIOGON a écrit :

j'ai voulu installer un pilote pour mon "linmodem" : ltmodem-2.6.8-1-686



D'où vient-il ce paquet ? Il n'apparaît pas dans la liste des paquets
officiels...

l'installation n'a pas marché (unable to find the way your distribution automatically load modules)

mais maintenant : impossible d'enlever le paquet :
j'ai essayé dpkg purge, remove,
apt-get
aptitude
dselect

rien n'y fait...

"le paquet est dans un état incohérent, vous devriez le réinstaller avant d'essayer de le supprimer"



dpkg -l <paquet> ?

quelqu'un saurait-il comment je peux faire pour me débarasser de ce paq uet, ou pour l'enlever de la liste de apt-get, car à chaque fois que je v eux installer ou désinstaller d'autres paquets, celui-ci me bloque tout.



Il nous faudrait un peu plus de détails...

--
Raphaël 'SurcouF' Bordet
surcouf at debianfr dot net
# | http://www.debianfr.net
Publicité
Poster une réponse
Anonyme