apt-get install libsqlite3-dev échoue

Le
Olivier
--94eb2c057ec4f0353e054d75f62e
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Bonjour,

J'ai une nouvelle machine virtuelle sous Jessie.
Pour différentes raisons, j'y ai ajouté le dépôt jessie=
-backports.


J'ai:
apt-get update
apt-get upgrade

apt-get install libsqlite3-dev
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances
Lecture des informations d'état Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation=
:

Les paquets suivants contiennent des dépendances non satisfaites :
libsqlite3-dev : Dépend: libsqlite3-0 (= 3.8.7.1-1+deb8u2) mais
3.16.2-3~bpo8+1 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux s=
ont en
mode « garder en l'état ».


Par ailleurs:
# apt-get -t jessie-backports install libsqlite3-dev
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances
Lecture des informations d'état Fait
Les paquets supplémentaires suivants seront installés :
libc-dev-bin libc6-dev linux-libc-dev manpages-dev
Paquets suggérés :
glibc-doc sqlite3-doc
Les NOUVEAUX paquets suivants seront installés :
libc-dev-bin libc6-dev libsqlite3-dev linux-libc-dev manpages-dev
0 mis à jour, 5 nouvellement installés, 0 à enlever et 25 no=
n mis à jour.
Il est nécessaire de prendre 7 413 ko dans les archives.
Après cette opération, 29,4 Mo d'espace disque supplémentair=
es seront
utilisés.
Souhaitez-vous continuer ? [O/n]



Je pourrai installer la version de libsqlite3-dev extraite du dép=
t
jessie-backports mais j'aimeria comprendre ce qui se passe avant de le
faire.
Qui pourrait m'expliquer ?

Par avance, merci.
Slts

--94eb2c057ec4f0353e054d75f62e
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

<div dir="ltr"><div><div><div>Bonjour,<br><br></div>J&#39;ai une nouvelle=
machine virtuelle sous Jessie.<br></div>Pour différentes raisons, j&#=
39;y ai ajouté le dépôt jessie-backports.<br><br><br></div><=
div>J&#39;ai:<br></div><div>apt-get update<br></div><div>apt-get upgrade<br=
><br></div><div>apt-get install libsqlite3-dev<br>Lecture des listes de =
paquets Fait<br>Construction de l&#39;arbre des dépendances =
      <br>Lecture des informations d&#39;état=
Fait<br>Certains paquets ne peuvent être installés. Ceci peut=
signifier<br>que vous avez demandé l&#39;impossible, ou bien, si vous=
utilisez<br>la distribution unstable, que certains paquets n&#39;ont pas e=
ncore<br>été créés ou ne sont pas sortis d&#39;Incoming=
.<br>L&#39;information suivante devrait vous aider à résoudre la =
situation : <br><br>Les paquets suivants contiennent des dépendan=
ces non satisfaites :<br> libsqlite3-dev : Dépend: libsqlite=
3-0 (= 3.8.7.1-1+deb8u2) mais 3.16.2-3~bpo8+1 devra être install=
<br>E: Impossible de corriger les problèmes, des paquets défec=
tueux sont en mode « garder en l&#39;état ».<br><b=
r><br></div><div>Par ailleurs:<br># apt-get -t jessie-backports install lib=
sqlite3-dev<br>Lecture des listes de paquets Fait<br>Construction de l&#=
39;arbre des dépendances       <br>Lectu=
re des informations d&#39;état Fait<br>Les paquets supplémenta=
ires suivants seront installés : <br>  libc-dev-bin libc6-de=
v linux-libc-dev manpages-dev<br>Paquets suggérés :<br>=
glibc-doc sqlite3-doc<br>Les NOUVEAUX paquets suivants seront install=
és :<br>  libc-dev-bin libc6-dev libsqlite3-dev linux-libc-d=
ev manpages-dev<br>0 mis à jour, 5 nouvellement installés, 0 =
enlever et 25 non mis à jour.<br>Il est nécessaire de prendre=
7 413 ko dans les archives.<br>Après cette opération, 29,4 Mo d&=
#39;espace disque supplémentaires seront utilisés.<br>Souhaitez-v=
ous continuer ? [O/n]<br><br><br><br></div><div>Je pourrai installer la =
version de libsqlite3-dev extraite du dépôt jessie-backports mais=
j&#39;aimeria comprendre ce qui se passe avant de le faire.<br></div><div>=
Qui pourrait m&#39;expliquer ?<br><br></div><div>Par avance, merci.<br></di=
v><div>Slts<br></div></div>

--94eb2c057ec4f0353e054d75f62e--
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
S
Le #26432292
Bonjour,
Le mardi 18 avril 2017 à 21:32, Olivier a écrit :
Je pourrai installer la version de libsqlite3-dev extraite du dépôt
jessie-backports mais j'aimeria comprendre ce qui se passe avant de le
faire.
Qui pourrait m'expliquer ?

Visiblement, tu as le paquet « libsqlite3-0 » de la branche « jessie-backports »
d’installé.
Ensuite tu demandes à installer « libsqlite3-dev » de la branche « jessie ».
Or ces deux paquets doivent être dans la même version. Tu ne peux pas mixer les
branches.
Donc, soit tu installes les deux depuis « jessie », soit les deux depuis
« jessie-backports ».
Sébastien
Publicité
Poster une réponse
Anonyme