argument non valide

Le
rodrigue
Salut à tous,

Mon formulaire de départ, basé sur une table A, contient un sous-formulaire
basé lui sur une table B.
Ma collègue me renvoie l'application car , je suppose à la suite d'une
fausse manoeuvre, le message "Argument non Valide" empêche l'application de
fonctionner, et cela dès son ouverture.

Examinant les tables, effectivement, toutes les données des 3 premiers
enregistrements de la table B sont remplacées par ######## et ce, quel que
soit le type de données dans chaun des champs. J'imagine donc que cela
empêche l'ouverture correcte du sous-formulaire.

CE QUE JE NE COMPRENDS PAS : J'ai supprimé les 3 enregistrements corrompus.
Mais en essayant n'importe quelle requête qui filtre les données de cette
table, que ce soit en mode requête ou via le menu contextuel "Filtrer par /
hors sélection" ou "Filtrer pour " le même message "ARGUMENT NON
VALIDE" se représente et rend illisibles tous les enregistrements de la
table . (Fermer la table puis la rouvrir permet à nouveau la consultation)

PS l'explication fournie dans l'aide Access (Paramètres régionaux) est
nulle et non avenue dans le cas présent.

Merci pour votre aide précieuse à cette question URGENTE (travail d'encodage
rendu impossible)

ROD
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel Carollo
Le #5069931
Bonjour Rodrigue!

Qu'appelez-vous "premiers enregistrements" d'une table? A priori, il n'y a
pas d'ordre de classement dans une table...
Quelle relation ont ces 3 enregistrements avec ceux de la table principale?
Comment sont definies les relations entre les deux tables? Avez-vous mis en
place l'integrite referencielle?
Avez-vous essaye de baser le formulaire sur une requete definissant les
liens entre ces deux tables?

J'espere que ca vous donne des pistes...

--
Daniel :-)

P.S. L'urgence est toute relative...

Computing Technologies International - www.computing-tech.com - We
provide solutions...

"rodrigue" news:u$
Salut à tous,

Mon formulaire de départ, basé sur une table A, contient un
sous-formulaire

basé lui sur une table B.
Ma collègue me renvoie l'application car , je suppose à la suite d'une
fausse manoeuvre, le message "Argument non Valide" empêche l'application
de

fonctionner, et cela dès son ouverture.

Examinant les tables, effectivement, toutes les données des 3 premiers
enregistrements de la table B sont remplacées par ######## et ce, quel que
soit le type de données dans chaun des champs. J'imagine donc que cela
empêche l'ouverture correcte du sous-formulaire.

CE QUE JE NE COMPRENDS PAS : J'ai supprimé les 3 enregistrements
corrompus.

Mais en essayant n'importe quelle requête qui filtre les données de cette
table, que ce soit en mode requête ou via le menu contextuel "Filtrer par
/

hors sélection" ou "Filtrer pour ..." le même message "ARGUMENT NON
VALIDE" se représente et rend illisibles tous les enregistrements de la
table . (Fermer la table puis la rouvrir permet à nouveau la consultation)

PS l'explication fournie dans l'aide Access (Paramètres régionaux) est
nulle et non avenue dans le cas présent.

Merci pour votre aide précieuse à cette question URGENTE (travail
d'encodage

rendu impossible)

ROD




Publicité
Poster une réponse
Anonyme