Autorisation sur port USB.

Le
dominique
Bonsoir,
J'ai un gros trou de mémoire et un appareil photos numérique, les 2
ensemble.
Je suis passé de la V 10 d'Aurox à la V 10.1.
Sous la précédente version, j'avais bricolé un script qui, avec un
cliquodrome et gphoto2, déchargeait mon appareil via le port USB.
Avec la nouvelle version d'Aurox, les utilisateurs n'ont visiblement
plus les autorisations pour utiliser le port USB. Tout fonctionne en
revanche normalement en root. Je suppose que je rencontrerai sans doute
les mêmes difficultés avec mon scanner.
Mon APN est bien dans la liste des APN connus. Le logiciel usbcam
«devrait» normalement se lancer mais il ne se lance visiblement pas.
Comment puis-je contrôler s'il se lance ou pas, du fait que son action
est très fugitive : changer les autorisations du port USB si le device
branché est connu ? J'y avais caché un timide « echo 'je tourne' » mais
mon shell est resté bien silencieux.
Si quelqu'un a une solution, je suis preneur.
Merci et bonne soirée,
Dominique
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
jip
Le #1247036
Je suis passé de la V 10 d'Aurox à la V 10.1.
Sous la précédente version, j'avais bricolé un script qui, avec un
cliquodrome et gphoto2, déchargeait mon appareil via le port USB.
Avec la nouvelle version d'Aurox, les utilisateurs n'ont visiblement
plus les autorisations pour utiliser le port USB. Tout fonctionne en
revanche normalement en root. Je suppose que je rencontrerai sans doute
les mêmes difficultés avec mon scanner.
Mon APN est bien dans la liste des APN connus. Le logiciel usbcam
«devrait» normalement se lancer... mais il ne se lance visiblement pas.
Comment puis-je contrôler s'il se lance ou pas, du fait que son action
est très fugitive : changer les autorisations du port USB si le device
branché est connu ? J'y avais caché un timide « echo 'je tourne' » mais
mon shell est resté bien silencieux.


Sous Aurox 10.1 j'utilise kwikdisk pour 'mounter' mon APN... Ca se passe
très bien dans /media/NO_NAME
Puis je l'utilise comme un (mini)disque dur: copier/coller de mes photos
vers mon /home
En fait mon APN (Olympus 220) n'est pas reconnu correctement (bug connu),
avec cette méthode, je n'ai pas de problème.

jip

dominique
Le #1246641

Sous Aurox 10.1 j'utilise kwikdisk pour 'mounter' mon APN... Ca se passe
très bien dans /media/NO_NAME
Puis je l'utilise comme un (mini)disque dur: copier/coller de mes photos
vers mon /home
En fait mon APN (Olympus 220) n'est pas reconnu correctement (bug connu),
avec cette méthode, je n'ai pas de problème.


Je ne connaissais pas kwikdisk. Je regarderai le man. Ceci étant, j'ai
une crainte. J'ai un Canon 300D qui est un « faux » USB mass storage. Il
n'est pas reconnu du tout par le système.
Pour le décharger, il me faut passer par gphoto2 ou par un lecteur de
carte flash.
Je ne peux pas le « mounter ».
Je lirai le man demain.
Merci et bonne fin de soirée,
Dominique

Poster une réponse
Anonyme