Besoin d'aide pour me corriger une formule

Le
Nadia.b
Hello,

Dans ma colonne H, j'ai des résultats, ne devant pas différer de trois
chiffres différents. Soit:

- CHF 0.00 dénommé par Excel "CHF - "
- CHF 11.50
- CHF 19.00

Par là, je désire faire un calcul qui me donnera 3 résultats différents et
j'utilise cette formule.
=NB.SI(H34:H171;11.5)
=NB.SI(H34:H171;19)

Mais ou mon résultat ne fonctionne pas c'est lorsque je calcule le nombre de
fois que les
zéros sont sortis. (plusieurs essais non concluants)
=NB.SI(H34:H171;0)
=NB.SI(H34:H171;0.00)
=NB.SI(H34:H171;"-")
=NB.SI(H34:H171;"CHF -")

etc. et d'autres essais supplémentaires suivants, je n'arrive pas à
trouver une solution
convenable.

Qui peut m'aider et m'expliquer ou mon erreur se trouve?

Salutations

Nadia
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Patrick
Le #1935273
Bonjour
Il suffit de mettre des "" soit =NB.SI(H34:H171;"0"). Ça marche
Bonne fête
Patrick

"Nadia.b"
Hello,

Dans ma colonne H, j'ai des résultats, ne devant pas différer de trois
chiffres différents. Soit:

- CHF 0.00 dénommé par Excel "CHF - "
- CHF 11.50
- CHF 19.00

Par là, je désire faire un calcul qui me donnera 3 résultats différents et
j'utilise cette formule.
=NB.SI(H34:H171;11.5)
=NB.SI(H34:H171;19)

Mais ou mon résultat ne fonctionne pas c'est lorsque je calcule le nombre
de
fois que les
zéros sont sortis. (plusieurs essais non concluants)
=NB.SI(H34:H171;0)
=NB.SI(H34:H171;0.00)
=NB.SI(H34:H171;"-")
=NB.SI(H34:H171;"CHF -")

etc.... et d'autres essais supplémentaires suivants, je n'arrive pas à
trouver une solution
convenable.

Qui peut m'aider et m'expliquer ou mon erreur se trouve?

Salutations

Nadia






Nadia.b
Le #1935264
Hello Patrick,

effectivement, cela me donne un résultat (55 nombres)
mais pas le bon. car dans la feuille, il n'y a actuellement pas
de chiffres fournit de zéro.

Seul les chiffres 11.50 et 19.00 sont mentionnés.
Le total de ces chiffres sont de 83 nombres et non de
55 comme mentionné dessus

Merci à toi et salutations

Nadia


"Patrick" news:
Bonjour
Il suffit de mettre des "" soit =NB.SI(H34:H171;"0"). Ça marche
Bonne fête
Patrick

"Nadia.b"
Hello,

Dans ma colonne H, j'ai des résultats, ne devant pas différer de trois
chiffres différents. Soit:

- CHF 0.00 dénommé par Excel "CHF - "
- CHF 11.50
- CHF 19.00

Par là, je désire faire un calcul qui me donnera 3 résultats différents
et


j'utilise cette formule.
=NB.SI(H34:H171;11.5)
=NB.SI(H34:H171;19)

Mais ou mon résultat ne fonctionne pas c'est lorsque je calcule le
nombre


de
fois que les
zéros sont sortis. (plusieurs essais non concluants)
=NB.SI(H34:H171;0)
=NB.SI(H34:H171;0.00)
=NB.SI(H34:H171;"-")
=NB.SI(H34:H171;"CHF -")

etc.... et d'autres essais supplémentaires suivants, je n'arrive pas à
trouver une solution
convenable.

Qui peut m'aider et m'expliquer ou mon erreur se trouve?

Salutations

Nadia










j
Le #1935250
les valeurs de la colonne H ne proviendraient-elles pas de calculs
susceptibles de donner 0.00000000001 au lieu de 0.00 (excel ne calcule pas
toujours très très juste ) ?
Dans ce cas, tu peux essayer quelque chose comme =NB.SI(H35:H172;"<0.0001"),
en suposant que la valeur reste positive

http://jacxl.free.fr


"Nadia.b"
Hello,

Dans ma colonne H, j'ai des résultats, ne devant pas différer de trois
chiffres différents. Soit:

- CHF 0.00 dénommé par Excel "CHF - "
- CHF 11.50
- CHF 19.00

Par là, je désire faire un calcul qui me donnera 3 résultats différents et
j'utilise cette formule.
=NB.SI(H34:H171;11.5)
=NB.SI(H34:H171;19)

Mais ou mon résultat ne fonctionne pas c'est lorsque je calcule le nombre
de

fois que les
zéros sont sortis. (plusieurs essais non concluants)
=NB.SI(H34:H171;0)
=NB.SI(H34:H171;0.00)
=NB.SI(H34:H171;"-")
=NB.SI(H34:H171;"CHF -")

etc.... et d'autres essais supplémentaires suivants, je n'arrive pas à
trouver une solution
convenable.

Qui peut m'aider et m'expliquer ou mon erreur se trouve?

Salutations

Nadia






Nadia.b
Le #1935214
Hello ,

le résultat de la formule que tu m'as donnée, ne correspond pas à la réalité
de mon calcul.

Je m'explique:

Dans ma colonne H, il s'agit de résultat selon une formule aimablement reçu
par Alain (AV)
pour déterminer si un résultat se trouve dans une plage horaire ou non.
La formule est:
=SI(G34<"5:"*1;0;SI(ET(G34>="5:"*1;G34<="8:"*1);11.5;19))
(recopiée jusqu'en bas du tableau H171)

Pour ce calcul, il s'agit de sommes données selon un total de travail
journalier effectué.
Il est donné que si les heures de travail sont entre 0 et 5 h. le résultat
est de 0 dans la colonne H, et si ces heures de travail sont de 5 à 8h,
le résultat dans la colonne H est de 11.50, et si les heures de travail sont
de plus de 8h c'est 19 qui s'inscrit dans cette colonne.

Par conséquent, je devrais me retrouver avec un résultat total du
NBSI de 83.
Ma feuille test, comporte déjà actuellement pour :
5 à 8 = 17
Plus de 8 = 66

Donc, pour le moins de 5 h, le résultat devrait aussi donner = 0
mais ce n'est pas le cas. Il me donne entre 55 et 56 (ou autres...)
selon mes changements dans le tableau.

Alors si j'ai un total global de 83, la subdivision des trois rubriques ne
peut être
de 139 ,
à moins que mes notions en mathématiques ont bien changées depuis que j'ai
quitté
l'école il y a plus de vingt ans. ;-)))

Salutations et merci de ton aide.

Nadia







"" news:41c910a2$0$3776$
les valeurs de la colonne H ne proviendraient-elles pas de calculs
susceptibles de donner 0.00000000001 au lieu de 0.00 (excel ne calcule pas
toujours très très juste ) ?
Dans ce cas, tu peux essayer quelque chose comme
=NB.SI(H35:H172;"<0.0001"),

en suposant que la valeur reste positive

http://jacxl.free.fr


"Nadia.b"
Hello,

Dans ma colonne H, j'ai des résultats, ne devant pas différer de trois
chiffres différents. Soit:

- CHF 0.00 dénommé par Excel "CHF - "
- CHF 11.50
- CHF 19.00

Par là, je désire faire un calcul qui me donnera 3 résultats différents
et


j'utilise cette formule.
=NB.SI(H34:H171;11.5)
=NB.SI(H34:H171;19)

Mais ou mon résultat ne fonctionne pas c'est lorsque je calcule le
nombre


de
fois que les
zéros sont sortis. (plusieurs essais non concluants)
=NB.SI(H34:H171;0)
=NB.SI(H34:H171;0.00)
=NB.SI(H34:H171;"-")
=NB.SI(H34:H171;"CHF -")

etc.... et d'autres essais supplémentaires suivants, je n'arrive pas à
trouver une solution
convenable.

Qui peut m'aider et m'expliquer ou mon erreur se trouve?

Salutations

Nadia










j
Le #1935142
ahhh !

es-tu sure que tes heures ne contiennent que des heures (et pas des
jours+heures) ?

si G34= 01:00:00,
la formule =SI(G34<"5:"*1;0;SI(ET(G34>="5:"*1;G34<="8:"*1);11.5;19))
renvoie bien 0
mais si G34 = 01/01/1900 01:00:00 (ce que tu peux obtenir si tu ajoutes 2
heures à 23:00:00,
la formule renvoie 19

par sécurité, tu peux utiliser un truc moins élégant mais plus rustique :
=SI(HEURE(G34)<5;0;SI(HEURE(G34)<=8;11.5;19))
(ou alors j'a pas tout compris...)





"Nadia.b"
Hello ,

le résultat de la formule que tu m'as donnée, ne correspond pas à la
réalité

de mon calcul.

Je m'explique:

Dans ma colonne H, il s'agit de résultat selon une formule aimablement
reçu

par Alain (AV)
pour déterminer si un résultat se trouve dans une plage horaire ou non.
La formule est:
=SI(G34<"5:"*1;0;SI(ET(G34>="5:"*1;G34<="8:"*1);11.5;19))
(recopiée jusqu'en bas du tableau H171)

Pour ce calcul, il s'agit de sommes données selon un total de travail
journalier effectué.
Il est donné que si les heures de travail sont entre 0 et 5 h. le résultat
est de 0 dans la colonne H, et si ces heures de travail sont de 5 à 8h,
le résultat dans la colonne H est de 11.50, et si les heures de travail
sont

de plus de 8h c'est 19 qui s'inscrit dans cette colonne.

Par conséquent, je devrais me retrouver avec un résultat total du
NBSI de 83.
Ma feuille test, comporte déjà actuellement pour :
5 à 8 = 17
Plus de 8 = 66

Donc, pour le moins de 5 h, le résultat devrait aussi donner = 0
mais ce n'est pas le cas. Il me donne entre 55 et 56 (ou autres...)
selon mes changements dans le tableau.

Alors si j'ai un total global de 83, la subdivision des trois rubriques ne
peut être
de 139 ,
à moins que mes notions en mathématiques ont bien changées depuis que j'ai
quitté
l'école il y a plus de vingt ans. ;-)))

Salutations et merci de ton aide.

Nadia







"" news:41c910a2$0$3776$
les valeurs de la colonne H ne proviendraient-elles pas de calculs
susceptibles de donner 0.00000000001 au lieu de 0.00 (excel ne calcule
pas


toujours très très juste ) ?
Dans ce cas, tu peux essayer quelque chose comme
=NB.SI(H35:H172;"<0.0001"),

en suposant que la valeur reste positive

http://jacxl.free.fr


"Nadia.b"
Hello,

Dans ma colonne H, j'ai des résultats, ne devant pas différer de trois
chiffres différents. Soit:

- CHF 0.00 dénommé par Excel "CHF - "
- CHF 11.50
- CHF 19.00

Par là, je désire faire un calcul qui me donnera 3 résultats
différents



et
j'utilise cette formule.
=NB.SI(H34:H171;11.5)
=NB.SI(H34:H171;19)

Mais ou mon résultat ne fonctionne pas c'est lorsque je calcule le
nombre


de
fois que les
zéros sont sortis. (plusieurs essais non concluants)
=NB.SI(H34:H171;0)
=NB.SI(H34:H171;0.00)
=NB.SI(H34:H171;"-")
=NB.SI(H34:H171;"CHF -")

etc.... et d'autres essais supplémentaires suivants, je n'arrive pas à
trouver une solution
convenable.

Qui peut m'aider et m'expliquer ou mon erreur se trouve?

Salutations

Nadia














Nadia.b
Le #1935106
,

j'utilise bien le format 08:15 pour rentrer 8h 15.

les 0.00, sont des CHF
les 11.5, sont des CHF
les 19.00 sont des CHF

(CHF= francs suisses donné sous Format/cellule/...)

Je vais essayer la formule que tu me donnes, et voir si cela fonctionne avec
mes calculs
du nombres de zéros francs comptabilisés par jours.

Jusqu'à présent, ce n'est que le calcul du nombre de fois que les zéros
francs sont calculés qui
pose problème. En soit, la formule qu'Alain a fournit fonctionne
parfaitement (jusqu'à présent).

Pour ce qui est de ta formule que je viens d'essayer.
Elle ne donne pas satisfactions, car elle ne donne que le résultat de CHF
11.50

J'ai même essayé de la tripatouillé (avec mes maigres connaissances) et cela
ne me donne
qu'un seul et unique résultat (chaque fois différent) mais sur tout le
tableau, un seul.

A B C D
E F G H
10.01.2005 Lundi 07:45 08:30 15:40 16:20 08:35 CHF 19.00


Je te mets une copie du tableau qui permet de calculer les heures de
présences et aussi les indemnités à restituer.
A= date
B= jour de semaine
C= Début des déplacements
D= début des travaux
E= Fin des travaux
F= Déplacement retour
G= Total des déplacements [ó4-C34]
H= Total des indemnités
[=SI(G34<"5:"*1;0;SI(ET(G34>="5:"*1;G34<="8:"*1);11.5;19))]


En fin de tableau, c'est à cet endroit que nous calculons le nombres de
jours par rapport aux
différents CHF. Dont le total de ces nombres doit faire 68.

NB de jours de moins de 5 heures 55

NB de jours de moins de 8 heures 17

NB de jours de plus de 8 heures 66


Ouarrrfffff, je me rends compte d'une chose. Je suis toujours partie sur
l'idée d'avoir un total
de 68 jours max. et non de 138. J'ai oublié les lignes masquées dans le
tableau selon les vacances
et jours fériés. Que de bêtises de ma part.
Mea Culpa,
Milles excuses à toi et tous les autres.

Mais maintenant,
Comment faire alors pour que ce total soit uniquement calculer sur les jours
de travail et non sur
la totalité des jours du tableau. On supprime, les lignes ou existe-t'il un
moyen de le contourner???

Encore merci de ton aide.

Salutations et comme Noël approche, je te souhaite de bonnes choses pour.

Nadia


"" news:41c9d010$0$4685$
ahhh !

es-tu sure que tes heures ne contiennent que des heures (et pas des
jours+heures) ?

si G34= 01:00:00,
la formule =SI(G34<"5:"*1;0;SI(ET(G34>="5:"*1;G34<="8:"*1);11.5;19))
renvoie bien 0
mais si G34 = 01/01/1900 01:00:00 (ce que tu peux obtenir si tu ajoutes 2
heures à 23:00:00,
la formule renvoie 19

par sécurité, tu peux utiliser un truc moins élégant mais plus rustique :
=SI(HEURE(G34)<5;0;SI(HEURE(G34)<=8;11.5;19))
(ou alors j'a pas tout compris...)





"Nadia.b"
Hello ,

le résultat de la formule que tu m'as donnée, ne correspond pas à la
réalité

de mon calcul.

Je m'explique:

Dans ma colonne H, il s'agit de résultat selon une formule aimablement
reçu

par Alain (AV)
pour déterminer si un résultat se trouve dans une plage horaire ou non.
La formule est:
=SI(G34<"5:"*1;0;SI(ET(G34>="5:"*1;G34<="8:"*1);11.5;19))
(recopiée jusqu'en bas du tableau H171)

Pour ce calcul, il s'agit de sommes données selon un total de travail
journalier effectué.
Il est donné que si les heures de travail sont entre 0 et 5 h. le
résultat


est de 0 dans la colonne H, et si ces heures de travail sont de 5 à 8h,
le résultat dans la colonne H est de 11.50, et si les heures de travail
sont

de plus de 8h c'est 19 qui s'inscrit dans cette colonne.

Par conséquent, je devrais me retrouver avec un résultat total du
NBSI de 83.
Ma feuille test, comporte déjà actuellement pour :
5 à 8 = 17
Plus de 8 = 66

Donc, pour le moins de 5 h, le résultat devrait aussi donner = 0
mais ce n'est pas le cas. Il me donne entre 55 et 56 (ou autres...)
selon mes changements dans le tableau.

Alors si j'ai un total global de 83, la subdivision des trois rubriques
ne


peut être
de 139 ,
à moins que mes notions en mathématiques ont bien changées depuis que
j'ai


quitté
l'école il y a plus de vingt ans. ;-)))

Salutations et merci de ton aide.

Nadia







"" news:41c910a2$0$3776$
les valeurs de la colonne H ne proviendraient-elles pas de calculs
susceptibles de donner 0.00000000001 au lieu de 0.00 (excel ne calcule
pas


toujours très très juste ) ?
Dans ce cas, tu peux essayer quelque chose comme
=NB.SI(H35:H172;"<0.0001"),

en suposant que la valeur reste positive

http://jacxl.free.fr


"Nadia.b"
Hello,

Dans ma colonne H, j'ai des résultats, ne devant pas différer de
trois




chiffres différents. Soit:

- CHF 0.00 dénommé par Excel "CHF - "
- CHF 11.50
- CHF 19.00

Par là, je désire faire un calcul qui me donnera 3 résultats
différents



et
j'utilise cette formule.
=NB.SI(H34:H171;11.5)
=NB.SI(H34:H171;19)

Mais ou mon résultat ne fonctionne pas c'est lorsque je calcule le
nombre


de
fois que les
zéros sont sortis. (plusieurs essais non concluants)
=NB.SI(H34:H171;0)
=NB.SI(H34:H171;0.00)
=NB.SI(H34:H171;"-")
=NB.SI(H34:H171;"CHF -")

etc.... et d'autres essais supplémentaires suivants, je n'arrive pas
à




trouver une solution
convenable.

Qui peut m'aider et m'expliquer ou mon erreur se trouve?

Salutations

Nadia


















Publicité
Poster une réponse
Anonyme