Bis Repetita encore le son

Le
Jo Engo
Bon voila ce coup-ci c'est sur le Lenovo (debian sid/experimental (*))qui
n'a de nouveau pas de son. Enfin presque, parce que j'ai du son en BT
quand j'allume mon casque BT.

Résultat des commandes :

_ bruit blanc _
aplay -D hw:0 -f S16_LE -c 2 -r 48000 /dev/urandom

silence. Mais quand pulseaudio appréhende la carte, toujours
silence mais aplay dit
aplay: main:828: erreur à l'ouverture audio: Périphérique ou
ressource occupé00:1f.3 Audio device: Intel Corporation Sunrise Point-LP
HD Audio (rev 21)


- volume alsa-mixer OK
- volume pavu OK

lspci
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)

lspci -k -s 00:1f.3
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
Subsystem: Lenovo Sunrise Point-LP HD Audio
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel, snd_soc_skl

(je note le retour du module snd_soc_skl qui posait problème et qui
n'était pas recquis par le noyau que j'avais installé mais là je n'ai pas
vu de gros caca dans demsg comme la première fois, il va peut-être
«simplement» que je revoie de nouveau ma version du noyau)

Il parait que c'est pas bien de faire des 'grep' néanmoins en grépant sur
'fail' j'obtiens ceci :

sudo dmesg|grep fail
[ 0.137450] platform MSFT0101:00: failed to claim resource 1: [mem
0xfed40000-0xfed40fff]
[ 0.137476] acpi MSFT0101:00: platform device creation failed: -16
[ 15.127767] i915 0000:00:02.0: firmware: failed to load i915/
skl_dmc_ver1_27.bin (-2)
[ 15.127771] i915 0000:00:02.0: Direct firmware load for i915/
skl_dmc_ver1_27.bin failed with error -2
[ 16.203040] thermal thermal_zone4: failed to read out thermal zone
(-61)
a priori rien à voir avec le son, mais…

(*) en gros le passage à "experimental" a aidé pour résoudre mon
précédent problème (pilote/kernel)

--

17:54 euh php sur QNX RTP c'est possible
17:55 17:54 Tiens, le retour des CBistes !
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jo Engo
Le #26474118
Je précise, parce que ce n'était pas très clair : ce n'est ni à la suite
d'une mise à jour, ni d'un redémarrage. ça c'est fait « brutalement »
Le Mon, 07 May 2018 06:55:34 +0000, Jo Engo a écrit :
Bon voila ce coup-ci c'est sur le Lenovo (debian sid/experimental
(*))qui n'a de nouveau pas de son. Enfin presque, parce que j'ai du son
en BT quand j'allume mon casque BT.
Résultat des commandes :
_ bruit blanc _
aplay -D hw:0 -f S16_LE -c 2 -r 48000 /dev/urandom
silence. Mais quand pulseaudio appréhende la carte, toujours
silence mais aplay dit
aplay: main:828: erreur à l'ouverture audio: Périphérique ou
ressource occupé00:1f.3 Audio device: Intel Corporation Sunrise Point-LP
HD Audio (rev 21)
- volume alsa-mixer OK - volume pavu OK
lspci 00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio
(rev 21)
lspci -k -s 00:1f.3 00:1f.3 Audio device: Intel Corporation Sunrise
Point-LP HD Audio (rev 21)
Subsystem: Lenovo Sunrise Point-LP HD Audio Kernel driver in use:
snd_hda_intel Kernel modules: snd_hda_intel, snd_soc_skl
(je note le retour du module snd_soc_skl qui posait problème et qui
n'était pas recquis par le noyau que j'avais installé mais là je n'ai
pas vu de gros caca dans demsg comme la première fois, il va peut-être
«simplement» que je revoie de nouveau ma version du noyau)
Il parait que c'est pas bien de faire des 'grep' néanmoins en grépant
sur 'fail' j'obtiens ceci :
sudo dmesg|grep fail [ 0.137450] platform MSFT0101:00: failed to
claim resource 1: [mem 0xfed40000-0xfed40fff]
[ 0.137476] acpi MSFT0101:00: platform device creation failed: -16 [
15.127767] i915 0000:00:02.0: firmware: failed to load i915/
skl_dmc_ver1_27.bin (-2)
[ 15.127771] i915 0000:00:02.0: Direct firmware load for i915/
skl_dmc_ver1_27.bin failed with error -2 [ 16.203040] thermal
thermal_zone4: failed to read out thermal zone (-61)
a priori rien à voir avec le son, mais…
(*) en gros le passage à "experimental" a aidé pour résoudre mon
précédent problème (pilote/kernel)



--
Si vous vous plaignez d'avoir des problèmes en maths
que diriez-vous si vous aviez les miens ...
-+- Albert Einstein -+-
Jo Engo
Le #26474126
Le Mon, 07 May 2018 07:48:55 +0000, Jo Engo a écrit :
Il parait que c'est pas bien de faire des 'grep' néanmoins en grépant
sur 'fail' j'obtiens ceci :
sudo dmesg|grep fail


Toujours pour ceux que ça intéresse, et dans le but d'obtenir de l'aide,
voici la totalité de mon dmesg (j'utilise termbin.com, je trouve ça
pratique) :
sudo dmesg|nc termbin.com 9999
http://termbin.com/zbgq

--
Et relate leur ce gazage cruel, et ... alerte !
-- Schmitter, Frédéric
Ta liberte tu la mendies, pauvre acteur.
Le #26474189
Le 07/05/18 à 08:55, Jo Engo a écrit :
(*) en gros le passage à "experimental" a aidé pour résoudre mon
précédent problème (pilote/kernel)


mais vous ne pouvez plus maj avec les depots stable, ça va déconner si
vous mélangez; mes passages à des sid ont toujours fini dans le mur pour
cette raison. Sid : paix à son âme, n'oubliez pas qui il était, c'est
très métaphorique tout ça.
--
Jo Engo
Le #26474193
Le Tue, 08 May 2018 01:26:25 +0200, Ta liberte tu la mendies, pauvre
acteur. a écrit :
Sid : paix à son âme, n'oubliez pas qui il était, c'est
très métaphorique tout ça.

merci pour l'aide précieuse, c'est très utile, si si.
Publicité
Poster une réponse
Anonyme