[BIzarre] Quand surfer gele le systeme !

Le
sdeglin_no_masp
Salut tout le monde,

depuis quelque temps mon mac a un comportement bizarre. Je suis en train
de surfer et tout d'un coup la page ne se charge plus et toute la
machine ou presque se bloque :
- il n'est plus possible d'accéder au disque système
- il n'est plus possible de killer des applis
- il n'est plus possible de lancer d'applis

Les autres applis lancées à ce moment là ont tendance à se geler aussi,
mais c'est pas systématique. Je suppose qu'il y a un lien avec le fait
que l'on accède plus au disque système.

Seule solution un reboot hardware sauvage pour redémarrer la machine.

Je pensais d'abord que c'était Omniweb, récemment mis à jour, qui pétait
les plombs. Mais depuis j'ai le même problème avec Safari. Un bug dans
le moteur de rendu de safari ?
Ce n'est pas lié à un site web particulier non plus. Je peux aller sur
un site 10 fois dans la journée et c'est à la 11e que ça va merder. Et
bien sûr ce n'est pas toujours le même site.

J'ai fait une vérification du disque par utilitaire Disque : RAS.
Un passage d'antivirus par acquis de concience : RAS non plus.

Au niveau des logs du firewall je vois bien des tentatives de connexions
sur ma machine depuis des "serveur web" mais pas en nombre réellement
significatives. Je ne sais pas s'il y a un lien.

J'ai récemment fait la mise à jour de Tiger en 10.4.2, mais je ne
saurais pas dire si le problème date de là, ou est apparu bien après.

Quelqu'un a-t-il déjà rencontré ce genre de soucis, ou aurait-il une
idée miracle ?
En attendant je continue mes recherches.

--
|/
|arpok
http://karpok.free.fr
Vos réponses Page 1 / 2
Trier par : date / pertinence
fabien38
Le #1818316
Bienvenue sur Mac!!!

Moi c'est pareil avec un G4 bipro 2x1,25 de noel 2003, gel et KP...
Pour ma part, ça vient de la carte mère qui a un défaut au niveau de la
gestion de la mémoire.
Est ce que ton slot 4 fonctionne?
As tu rajouté de la ram???
Au fait, quoi tu as comme machine???

fabien38

Salut tout le monde,

depuis quelque temps mon mac a un comportement bizarre. Je suis en train
de surfer et tout d'un coup la page ne se charge plus et toute la
machine ou presque se bloque :
- il n'est plus possible d'accéder au disque système
- il n'est plus possible de killer des applis
- il n'est plus possible de lancer d'applis

Les autres applis lancées à ce moment là ont tendance à se geler aussi,
mais c'est pas systématique. Je suppose qu'il y a un lien avec le fait
que l'on accède plus au disque système.

Seule solution un reboot hardware sauvage pour redémarrer la machine.

Je pensais d'abord que c'était Omniweb, récemment mis à jour, qui pétait
les plombs. Mais depuis j'ai le même problème avec Safari. Un bug dans
le moteur de rendu de safari ?
Ce n'est pas lié à un site web particulier non plus. Je peux aller sur
un site 10 fois dans la journée et c'est à la 11e que ça va merder. Et
bien sûr ce n'est pas toujours le même site.

J'ai fait une vérification du disque par utilitaire Disque : RAS.
Un passage d'antivirus par acquis de concience : RAS non plus.

Au niveau des logs du firewall je vois bien des tentatives de connexions
sur ma machine depuis des "serveur web" mais pas en nombre réellement
significatives. Je ne sais pas s'il y a un lien.

J'ai récemment fait la mise à jour de Tiger en 10.4.2, mais je ne
saurais pas dire si le problème date de là, ou est apparu bien après.

Quelqu'un a-t-il déjà rencontré ce genre de soucis, ou aurait-il une
idée miracle ?
En attendant je continue mes recherches.



sdeglin_no_masp
Le #1818314
fabien38
Bienvenue sur Mac!!!

Moi c'est pareil avec un G4 bipro 2x1,25 de noel 2003, gel et KP...


Moi je n'arrive pas jusqu'au KP. Et tout ne gèle pas systématiquement.
Il est toujours possible de parcourir les autres partitions que la
particion système par exemple.

Pour ma part, ça vient de la carte mère qui a un défaut au niveau de la
gestion de la mémoire.
Est ce que ton slot 4 fonctionne?


Il est vide.

As tu rajouté de la ram???
Au fait, quoi tu as comme machine???


un G4 bi-pro 2x833 avec 768 Mo de RAM. J'ai bien rajouté une barette.
Mais ça commence à dater maintenant (au moins 2 ans) et le problème a
tout au plus une semaine.
En plus surfer n'est certainement pas l'activité la plus consommatrice
de mémoire que je fasse en ce moment.
Quand je fais du montage vidéo par exemple aucun soucis.

--
|/
|arpok
http://karpok.free.fr

patpro ~ Patrick Proniewski
Le #1818313
In article (Stéphane Deglin) wrote:

Quelqu'un a-t-il déjà rencontré ce genre de soucis, ou aurait-il une
idée miracle ?


oui, j'ai le même problème, mais chez moi c'est un bug du firewall
(ipfw2).
C'est causé dans des cas très précis, et si tu n'as pas une machine
bi-processeur avec des rêgles de firewall personnalisées à la main tu ne
seras pas dans ce cas de figure.
Le bug est déclaré chez apple depuis la 10.4.0 et n'est pas corrigé à
cette date.

patpro

dominiquelang
Le #1818312
Stéphane Deglin
J'ai fait une vérification du disque par utilitaire Disque : RAS.


C'est déjà ça.

Un passage d'antivirus par acquis de concience : RAS non plus.


Pas de virus connu sous OSX qui fasse ça (pas de virus connu tout court,
d'ailleurs).

Quel âge a ce disque? Vérification du matériel avec un outil genre
TechTool Pro? Vérification du SMART si réalisable?

Passque ça pourrait bien être des signes d'agonie du disque...
--
Ghupt esch ghupt! Zeruckhupe git's net!
Remplacez FromMyTrailer.invalid par wanadoo.fr pour répondre en privé!
Dominique Lang
Gériatrie:
dominiquelang
Le #1818311
Stéphane Deglin
En plus surfer n'est certainement pas l'activité la plus consommatrice
de mémoire que je fasse en ce moment.


Certes.

Quand je fais du montage vidéo par exemple aucun soucis.


Tes fichiers vidéo, tu les enregistres sur le disque qui merdoie, ou sur
un autre, externe?
--
Ghupt esch ghupt! Zeruckhupe git's net!
Remplacez FromMyTrailer.invalid par wanadoo.fr pour répondre en privé!
Dominique Lang
Gériatrie:
sdeglin_no_masp
Le #1818310
patpro ~ Patrick Proniewski
In article (Stéphane Deglin) wrote:

Quelqu'un a-t-il déjà rencontré ce genre de soucis, ou aurait-il une
idée miracle ?


oui, j'ai le même problème, mais chez moi c'est un bug du firewall
(ipfw2).
C'est causé dans des cas très précis, et si tu n'as pas une machine
bi-processeur avec des rêgles de firewall personnalisées à la main tu ne
seras pas dans ce cas de figure.


Ca pourrait être ça dans ce cas.

Le bug est déclaré chez apple depuis la 10.4.0 et n'est pas corrigé à
cette date.


Tu as des infos sur ce bug. Un descriptif ou quelque chose ?
Si ça colle avec ce que tu me dis, ce pourrait être la mise à jour de
Brickhouse qui a déclanché le problème.

--
|/
|arpok
http://karpok.free.fr


sdeglin_no_masp
Le #1818309
Dominique Lang
Quel âge a ce disque? Vérification du matériel avec un outil genre
TechTool Pro? Vérification du SMART si réalisable?


Dans les 2-3 ans. Le SMART est bon

Passque ça pourrait bien être des signes d'agonie du disque...


L'hypothèse de Pat Pro pourrait bien être la bonne.

--
|/
|arpok
http://karpok.free.fr

Schmurtz
Le #1818306
fabien38
Moi c'est pareil avec un G4 bipro 2x1,25 de noel 2003, gel et KP...
Pour ma part, ça vient de la carte mère qui a un défaut au niveau de la
gestion de la mémoire.


C'est pas forcément pareil, d'autant plus que Stéphane n'a pas de kernel
panic. Il y a une mirade de raisons pour que le système plante.

Salut tout le monde,

depuis quelque temps mon mac a un comportement bizarre. Je suis en train
de surfer et tout d'un coup la page ne se charge plus et toute la
machine ou presque se bloque :
- il n'est plus possible d'accéder au disque système
- il n'est plus possible de killer des applis
- il n'est plus possible de lancer d'applis

Les autres applis lancées à ce moment là ont tendance à se geler aussi,
mais c'est pas systématique. Je suppose qu'il y a un lien avec le fait
que l'on accède plus au disque système.



J'ai aussi eu, et malheureusement j'ai toujours, ce genre de problème :
plus possible de quitter les applis bloquées (même en forçant, même avec
un kill -9), plus possible de lancer d'appli, pas possible de se loggué
(en fermant la session brutalement, ou en ouvrant une nouvelle fenêtre
de terminal). Par contre les applis déjà lancée et qui ne sont pas
atteinte de bloquage marche très bien.

Après quelques réflexions, j'ai l'impression que les applis qui se
bloquent sont toutes liées à internet (client IRC, Safari, iChat, Mail,
WMP lisant un radio sur internet).

Par ailleurs, j'avais découvert un bug au niveau de la fonction UNIX
"connect" donnant exactement le même résultat (bugreporté, mais toujours
pas corrigée).

(Si quelqu'un est volontaire pour tester ce bug, ça m'intéresserais,
histoire de savoir, si ça vient de moi, ou si c'est général :
http://maxao.free.fr/tmp/buginconnect.html)

Un des moyens de savoir si c'est le même bug, et de lancer la commande
"ps aux" dans le terminal, les programmes bloqués devrait avoir le flag
U dans la colonne STAT. J'ai pas encore pu tester cette commande, vu que
je n'avais aucune fenêtre de terminal ouverte, et que d'en ouvrir une
bloque le terminal... Depuis une semaine, je vis avec une fenêtre de
terminal ouverte et stockée dans le dock, au cas où, mais j'ai le bug ne
s'est pas remanifesté (un petit espoir que ça n'arrive plus...).

--
Schmurtz


patpro ~ Patrick Proniewski
Le #1818304
In article (Stéphane Deglin) wrote:

Le bug est déclaré chez apple depuis la 10.4.0 et n'est pas corrigé à
cette date.


Tu as des infos sur ce bug. Un descriptif ou quelque chose ?
Si ça colle avec ce que tu me dis, ce pourrait être la mise à jour de
Brickhouse qui a déclanché le problème.


un super thread de 90 messages :

http://discussions.info.apple.com/webx?@.68ae2787

et un copié-collé de la derniere mise a jour du rapport de bug chez
apple :

-----------------------------------------------------
28-May-2005 09:36 PM Patrick Proniewski:
edit : simplification of freezing conditions

We've been able to simplify again the ruleset involved in the freezing
of Tiger.

Steps to Reproduce:

0- Ethernet on static IP
PowerMac G5, 2 active processors
Tiger 10.4, 10.4.1 (according to someone, it freezes too in 8C21)

1- as root :

ipfw -f flush
ipfw add allow ip from any to any via lo0
ipfw add allow tcp from any to any out keep-state
ipfw add deny tcp from any to any

2- use the network. The more TCP sessions you open, the faster Tiger
will freeze.
nmap offers a good interface for creating lots of tcp sessions.

Expected result: no freeze

Actual result:
Network stalls and Tiger will progressively freeze, starting with
network-related applications : menu won't show, color ball cursor
appears, "quit" becomes "force quit" in the dock, and eventually all
applications will freeze. If I wait long enough, the clock itself freeze.
with one proc activated, the G5 will not freeze, even after 3 hours of
nmap against a full IP block. With 2 active processors, the exact same
system will freeze in about 2 to 7 minutes (running the same "nmap -P0
-sV -sT ....")

Regression:
The freeze won't occur if one processor is deactivated (with Processor
pref. panel from CHUD tool for example), or if this particular firewall
ruleset is not loaded.

-----------------------------------------------------


Je viens d'ailleurs de lire un nouveau commentaire à mon bug report en
provenance d'Apple, que je ne citerais pas parce que j'ai pas relu les
conditions de divulgation de ce genre de commentaires. Sachez juste que
ce "little" bug semble bloquer des projets chez la NASA, et qu'Apple
commence à prendre les boules de pas avoir cherché une solution plus tôt.

donc, on a toutes les chances d'avoir un correctif rapidement.

patpro


sdeglin_no_masp
Le #1818302
patpro ~ Patrick Proniewski
un super thread de 90 messages :

http://discussions.info.apple.com/webx?@.68ae2787

et un copié-collé de la derniere mise a jour du rapport de bug chez
apple :


Ca ressemble drôlement à mon problème.

0- Ethernet on static IP
PowerMac G5, 2 active processors
Tiger 10.4, 10.4.1 (according to someone, it freezes too in 8C21)


Chez moi ce sont des g4 et une 8C46


1- as root :

ipfw -f flush
ipfw add allow ip from any to any via lo0
ipfw add allow tcp from any to any out keep-state
ipfw add deny tcp from any to any


Les 3 règles y sont.

2- use the network. The more TCP sessions you open, the faster Tiger
will freeze.
nmap offers a good interface for creating lots of tcp sessions.


J'ai pas vérifié avec nmap mais effectivment plus il y a de traffic
réseau en parallèle c'est rapide. C'est pour ça que je l'ai vu en
premier avec Omniweb et sa fonctionnalité de workspace.

Expected result: no freeze

Actual result:
Network stalls and Tiger will progressively freeze, starting with
network-related applications : menu won't show, color ball cursor
appears, "quit" becomes "force quit" in the dock, and eventually all
applications will freeze. If I wait long enough, the clock itself freeze.
with one proc activated, the G5 will not freeze, even after 3 hours of
nmap against a full IP block. With 2 active processors, the exact same
system will freeze in about 2 to 7 minutes (running the same "nmap -P0
-sV -sT ....")


Intéressant mais du coup les bi-proc perdent beaucoup d'intérêt.

Regression:
The freeze won't occur if one processor is deactivated (with Processor
pref. panel from CHUD tool for example), or if this particular firewall
ruleset is not loaded.


Je veux pas paramètre médisant mais il a rien d'extraordinaire le
ruleset utilisé. Je dirais même que c'est la conf de base d'une grande
majorité de firewall, quelqu'en soit le type d'ailleurs.

donc, on a toutes les chances d'avoir un correctif rapidement.


Espérons parce que c'est tout sauf pratique.

En tout cas merci pour ces infos. Ca résoud par le problème mais je me
sens moins seul

--
|/
|arpok
http://karpok.free.fr

Publicité
Poster une réponse
Anonyme