Bricolage d'un pictogramme

Le
garnote
Bonjour le monde,

J'ai bricolé un pictogramme sous Excel 2000 .
Voici mon exemple :
1. J'ai sélectionné A1:A20, entré cette formule:
=ENT(ALEA()*6) et validé par Ctrl+Entrée,
2. En B1 : =NB.SI($A$1:A1;A1)+0,5
recopiée jusqu'à A20,
3. Graphique «Nuage de points» avec A1:B20,
4. Échelle OX: 0,1,2,3,4,5
5. Échelle OY: 0,1,2,3,4,,14,15
6. Marques personnalisées: Ronds rouges de taille 8,
7. Suppression de l'axe des Y.

J'aimerais savoir si Excel 2002 ou 2003 permet d'obtenir
ce type de graphique plus simplement ?

Serge
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Modeste
Le #1264857
Bonjour Serge,
j'vous l'avais dit qu'il était allumé l'Serge
;-)))
chez moi ça marche trés bien comme ça
Windows XP EXCEL 2002

Plus simple ????
Sub Macro1()
Range("A1:A20").Select
Selection.FormulaArray = "=INT(RAND()*6)"
Range("B1").Select
ActiveCell.FormulaR1C1 = "=COUNTIF(R1C1:RC[-1],RC[-1])
+0.5"
Range("B1").Select
Selection.AutoFill Destination:=Range("B1:B20"),
Type:=xlFillDefault
Range("B1:B20").Select
Range("A1:B20").Select
Charts.Add
ActiveChart.ChartType = xlXYScatter
ActiveChart.SetSourceData Source:=Sheets
("Feuil1").Range("A1:B20"), PlotBy _
:=xlColumns
ActiveChart.Location Where:=xlLocationAsObject,
Name:="Feuil1"
ActiveChart.SeriesCollection(1).Select
With Selection.Border
.Weight = xlHairline
.LineStyle = xlNone
End With
With Selection
.MarkerBackgroundColorIndex = 3
.MarkerForegroundColorIndex = xlAutomatic
.MarkerStyle = xlCircle
.Smooth = False
.MarkerSize = 10
.Shadow = False
End With
ActiveChart.Legend.Select
Selection.Delete
ActiveChart.Axes(xlValue).Select
Selection.Delete
ActiveChart.Axes(xlCategory).Select
Selection.Delete
ActiveChart.PlotArea.Select
With Selection.Border
.Weight = xlThin
.LineStyle = xlNone
End With
Selection.Interior.ColorIndex = xlNone
ActiveChart.Axes(xlValue).MajorGridlines.Select
Selection.Delete

ActiveSheet.Shapes(1).ScaleHeight 0.3, msoFalse, _
msoScaleFromTopLeft
ActiveSheet.Shapes(1).ScaleWidth 0.3, msoFalse, _
msoScaleFromTopLeft
End Sub


nb: tu n'as pas précisé la taille du pictograme
ni s'il faut laisser les traits entre les points

mais sans les points cela me donne une idée pour générer
une signature....
;-)))
-----Message d'origine-----
Bonjour le monde,

J'ai bricolé un pictogramme sous Excel 2000 .
Voici mon exemple :
1. J'ai sélectionné A1:A20, entré cette formule:
=ENT(ALEA()*6) et validé par Ctrl+Entrée,
2. En B1 : =NB.SI($A$1:A1;A1)+0,5
recopiée jusqu'à A20,
3. Graphique «Nuage de points» avec A1:B20,
4. Échelle OX: 0,1,2,3,4,5
5. Échelle OY: 0,1,2,3,4,...,14,15
6. Marques personnalisées: Ronds rouges de taille 8,
7. Suppression de l'axe des Y.

J'aimerais savoir si Excel 2002 ou 2003 permet d'obtenir
ce type de graphique plus simplement ?

Serge






.



Modeste
Le #1261132
;-)))
de toute beauté
http://www.fractalus.com/cgi-bin/theway?
ring=fractals;id4;random
garnote
Le #1261092
Merci pour le tuyau.
De toute beauté, ça c'est sûr.

Serge


"Modeste" news: 2afe01c42871$73a47630$
;-)))
de toute beauté
http://www.fractalus.com/cgi-bin/theway?
ring=fractals;id4;random
Publicité
Poster une réponse
Anonyme