[bruit] serveur web et php en local mais pas par le net.

Le
titou44
bonjour

je viens d'installer un serveur web sur un pc derrière un routeur.
le port 80 est bien mappé dans le routeur.

le pb : sur le lan derrière le routeur, les pages php s'éxécutent bien
sur les pc du lan.
par contre quand on les appelle de l'extérieur par le net, on a un beau
messsage d'erreur :
"impossible d'afficher la page".
par contre les pages html fonctionnent sans pb à partir du net.

pour quoi le php en local et pas en externe ?

merci pour piste.

titou44 chez freesurf.fr

--
Ceci est une signature automatique de MesNews.
Site : http://mesnews.no-ip.com
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
R&B
Le #14060971
titou44 a écrit :
bonjour

je viens d'installer un serveur web sur un pc derrière un routeur.
le port 80 est bien mappé dans le routeur.

le pb : sur le lan derrière le routeur, les pages php s'éxécutent bien
sur les pc du lan.
par contre quand on les appelle de l'extérieur par le net, on a un beau
messsage d'erreur :
"impossible d'afficher la page".
par contre les pages html fonctionnent sans pb à partir du net.

pour quoi le php en local et pas en externe ?

merci pour piste.

titou44 chez freesurf.fr




Bonjour
Pas spécialiste mais une voie : depuis l'extérieur on entre dans ton
routeur selon un domaine... IP:80
Le 80 du routeur pointe-il t-on serveur http ? machine LAN:80
Si oui : Quid de ton httpd.conf et de son interprétation de ton nom de
domaine ? en effet, il ne doit ps foncitonner uniquement en 127.0.0.1

Espérant avoir aiguillé un peu...

++R&B
http://www.WDForge.org
titou44
Le #14060891
R&B vient de nous annoncer :
titou44 a écrit :
bonjour

je viens d'installer un serveur web sur un pc derrière un routeur.
le port 80 est bien mappé dans le routeur.

le pb : sur le lan derrière le routeur, les pages php s'éxécutent bien sur
les pc du lan.
par contre quand on les appelle de l'extérieur par le net, on a un beau
messsage d'erreur :
"impossible d'afficher la page".
par contre les pages html fonctionnent sans pb à partir du net.

pour quoi le php en local et pas en externe ?

merci pour piste.

titou44 chez freesurf.fr




Bonjour
Pas spécialiste mais une voie : depuis l'extérieur on entre dans ton routeur
selon un domaine... IP:80
Le 80 du routeur pointe-il t-on serveur http ? machine LAN:80
Si oui : Quid de ton httpd.conf et de son interprétation de ton nom de
domaine ? en effet, il ne doit ps foncitonner uniquement en 127.0.0.1

Espérant avoir aiguillé un peu...

++R&B
http://www.WDForge.org



bonjour

pour information, j'ai changé de serveur web.
je suis tombé sur un petit 'bijou'.
http://www.aprelium.com/abyssws/

ils proposent une version gratuite impressionnante.
et d'une facilité à mettre en place pour un néophyte !
j'ai le php qui fonctionne également.
mon seul pb est que je domine plus WD que le php.

produit à tester et à utiliser sur de vielles bécanes sans pb (celeron
500 avec W2000).
la version pro n'est pas chère en plus.

à voir


titou44 chez freesurf.fr

--
Ceci est une signature automatique de MesNews.
Site : http://mesnews.no-ip.com
Romuald.besset
Le #14060851
titou44 a écrit :
R&B vient de nous annoncer :

titou44 a écrit :

bonjour

je viens d'installer un serveur web sur un pc derrière un routeur.
le port 80 est bien mappé dans le routeur.

le pb : sur le lan derrière le routeur, les pages php s'éxécutent
bien sur les pc du lan.
par contre quand on les appelle de l'extérieur par le net, on a un
beau messsage d'erreur :
"impossible d'afficher la page".
par contre les pages html fonctionnent sans pb à partir du net.

pour quoi le php en local et pas en externe ?

merci pour piste.

titou44 chez freesurf.fr




Bonjour
Pas spécialiste mais une voie : depuis l'extérieur on entre dans ton
routeur selon un domaine... IP:80
Le 80 du routeur pointe-il t-on serveur http ? machine LAN:80
Si oui : Quid de ton httpd.conf et de son interprétation de ton nom de
domaine ? en effet, il ne doit ps foncitonner uniquement en 127.0.0.1

Espérant avoir aiguillé un peu...

++R&B
http://www.WDForge.org




bonjour

pour information, j'ai changé de serveur web.
je suis tombé sur un petit 'bijou'.
http://www.aprelium.com/abyssws/

ils proposent une version gratuite impressionnante.
et d'une facilité à mettre en place pour un néophyte !
j'ai le php qui fonctionne également.
mon seul pb est que je domine plus WD que le php.

produit à tester et à utiliser sur de vielles bécanes sans pb (celeron
500 avec W2000).
la version pro n'est pas chère en plus.

à voir


titou44 chez freesurf.fr




Merci pour le lien ! Effectivement il comporte nativement des
fonctionnalités fort interessantes (pourrait remplacer mon serveur local
actuel).

++ R&B
http://www.WDFoege.org
Poster une réponse
Anonyme