[BUG] Recherche dans Safari

Le
benoit
Bonjour,


Après mon bug avec le clic sur le trackpad en voici un second qui me les
casse :

- Faire une recherche depuis la barre de saisie d'adresse web dans
Safari ;
- Une page Google apparaît :
- Cliquer sur un lien ;
- Revenir à la page précédente, la page Google ;
- Page vide, le lien est bien la requête sur Google, si on demande de
réafficher la page (clique sur le flèche circulaire dans le côté droit
de la zone de saisie d'adresse) elle s'affiche !

C'est quoi ce Bronx ?



--
"La théorie, c'est quand on sait tout et que rien ne fonctionne. La
pratique, c'est quand tout fonctionne et que personne ne sait pourquoi.
Ici, nous avons réuni théorie et pratique : Rien ne fonctionne et
personne ne sait pourquoi !" [ Albert Einstein ]
Vos réponses Page 2 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
benoit
Le #26364319
Pierre-Alain Dorange
Mais au vu de ta description initiale, tu indiques avoir une page google
de résultat qui s'affiche (donc a priori tu as validé la requête).
Le problème pourrais être un pb de suivi des cookies par google.



Je ne sais pas mais je viens de voir un truc pire : si je lance ma
requête par une saisie dans la barre d'adresse depuis une page
existante, la requête n'apparait pas dans l'historique.

J'essaye de reproduire l'exemple pour vous donner les étapes pas à
pas... tout fonctionne !

As-tu essayer un autre navigateur, un autre moteur de recherche ?



Comme c'est aléatoire. Sinon, non. Je n'utilise que Safari sauf certains
sites qui exigent Firefox ou Chrome.

--
"La théorie, c'est quand on sait tout et que rien ne fonctionne. La
pratique, c'est quand tout fonctionne et que personne ne sait pourquoi.
Ici, nous avons réuni théorie et pratique : Rien ne fonctionne... et
personne ne sait pourquoi !" [ Albert Einstein ]
pdorange
Le #26364321
Benoit
> Mais au vu de ta description initiale, tu indiques avoir une page google
> de résultat qui s'affiche (donc a priori tu as validé la requête).
> Le problème pourrais être un pb de suivi des cookies par google.

Je ne sais pas mais je viens de voir un truc pire : si je lance ma
requête par une saisie dans la barre d'adresse depuis une page
existante, la requête n'apparait pas dans l'historique.



Tu n'es pas en mode "Navigation Privée" à tout hazard ?

--
Pierre-Alain Dorange Moof
Ce message est sous licence Creative Commons "by-nc-sa-2.0"
michel.vauquois
Le #26364320
Fleuger
Idem : je l'ai mis par défaut dans la barre d'adresse, et j'ai mis un
signet Google dans le dock pour Google.
Pour les autres, j'ai des signets recherche.



On peut basculer d'un moteur à l'autre en cliquant sur l'icône de
DuckDuckGo à gauche de la barre d'adresse.
--
Michel Vauquois
Que Dieu vous garde... Moi j'ai pas le temps (RD)
MàJ 2015 : http://michelvauquois.free-h.fr/
g4fleurot
Le #26364325
M.V.
On peut basculer d'un moteur à l'autre en cliquant sur l'icône de
DuckDuckGo à gauche de la barre d'adresse.



À gauche de la barre d'adresse, j'ai une loupe et si je clique, j'ai un
menu déroulant avec Google, Yahoo, Bing, Duckduckgo, mais, quel que soit
le moteur sélecté, c'est toujours Duckduckgo qui répond.
C'est pour ça que j'ai mis Google dans le dock.
Dans les préférences Safari > Recherche, j'ai pourtant mis Google.

Bon, après farfouillage dans les réglages Safari, je viens de comprendre
que dans Préférences Safari > Extensions > DuckDockGo, il faut décocher
la case DuckDockGo as default (in Smart Search Field).
De la discussion jaillit la lumière. :-)

Je viens d'installer l'extension Qwant. Il y a aussi une case pour la
recherche par défaut.
Mais le moteur n'apparait pas dans le menu déroulant sous la loupe de
recherche.

--
Gérard FLEUROT
DV
Le #26364328
Fleuger a écrit ceci :

Je viens d'installer l'extension Qwant. Il y a aussi une case pour la
recherche par défaut.
Mais le moteur n'apparait pas dans le menu déroulant sous la loupe de
recherche.



Il y a une incompatibilité avec Safari (avec Opera aussi), si j'en crois
cette page :


Une fois l'extension Qwant installée, pour accéder au moteur de
recherche Qwant, il faut faire "Personnaliser la barre d'outils". Tu
trouveras une icône intitulée "Qwant for Safari" à placer sur la barre
d'outils.

J'ai l'impression que Safari n'accepte pas non plus le moteur Searx
(alias Framabee). Globalement, je trouve que la gestion des moteurs de
recherche est beaucoup plus pratique dans Firefox...

--
DV
g4fleurot
Le #26364332
DV
Une fois l'extension Qwant installée, pour accéder au moteur de
recherche Qwant, il faut faire "Personnaliser la barre d'outils". Tu
trouveras une icône intitulée "Qwant for Safari" à placer sur la barre
d'outils.



S'est installée toute seule.
En cliquant dessus, ily a une case "Define Qwant as search engine"
équivaut à la case Preférence > Extensions > Qwant for Safari.

Si cochée, plus moyen d'obtenir les autres.
Donc ne pas cocher et appeler ce moteur par l'icône dont l'ouverture
présente un champ de recherche.


--
Gérard FLEUROT
benoit
Le #26364334
Pierre-Alain Dorange
Benoit
> > Mais au vu de ta description initiale, tu indiques avoir une page google
> > de résultat qui s'affiche (donc a priori tu as validé la requête).
> > Le problème pourrais être un pb de suivi des cookies par google.
>
> Je ne sais pas mais je viens de voir un truc pire : si je lance ma
> requête par une saisie dans la barre d'adresse depuis une page
> existante, la requête n'apparait pas dans l'historique.

Tu n'es pas en mode "Navigation Privée" à tout hazard ?



Non, et puis pourquoi cela ne fonctionnerait pas, puis à nouveau tout
roule, dans la même fenêtre, sur le même onglet ?

--
"La théorie, c'est quand on sait tout et que rien ne fonctionne. La
pratique, c'est quand tout fonctionne et que personne ne sait pourquoi.
Ici, nous avons réuni théorie et pratique : Rien ne fonctionne... et
personne ne sait pourquoi !" [ Albert Einstein ]
DV
Le #26364337
Fleuger a écrit ceci :

Si cochée, plus moyen d'obtenir les autres.
Donc ne pas cocher et appeler ce moteur par l'icône dont l'ouverture
présente un champ de recherche.



À propos d'obtenir les autres, je ne trouve pas comment accéder
directement à un moteur de recherche donné dans Safari. Quand je saisis
une recherche dans Firefox, je peux dérouler un menu qui me permet de
choisir le moteur à interroger. Safari ne me propose que le moteur
défini par défaut. J'ai loupé quelque chose ?

--
DV
g4fleurot
Le #26364341
DV
À propos d'obtenir les autres, je ne trouve pas comment accéder
directement à un moteur de recherche donné dans Safari. Quand je saisis
une recherche dans Firefox, je peux dérouler un menu qui me permet de
choisir le moteur à interroger. Safari ne me propose que le moteur
défini par défaut. J'ai loupé quelque chose ?



Dans Firefox, en cliquant sur la loupe dans le champ de recherche, on
obtient une palette avec les icônes des moteurs de recherche.

Dans Safari, à gauche du champ de saisie d'adresse quand on y a mis le
curseur et avant d'avoir entré un caractère au clavier, il y a une loupe
qui, en cliquant dessus, présente un menu déroulant qui correspond aux
moteurs de recherches (ceux par défaut et ceux ajoutés par extension).

--
Gérard FLEUROT
DV
Le #26364340
Fleuger a écrit ceci :

Dans Safari, à gauche du champ de saisie d'adresse quand on y a mis le
curseur et avant d'avoir entré un caractère au clavier, il y a une loupe
qui, en cliquant dessus, présente un menu déroulant qui correspond aux
moteurs de recherches (ceux par défaut et ceux ajoutés par extension).



Ah oui, c'est le "avant d'avoir entré un caractère au clavier" que
j'avais loupé. Merci !

--
DV
Publicité
Poster une réponse
Anonyme