Calcul étonnant

Le
Brat'ac
Bonjour,

Dans la colonne A j'ai des données au format monétaire si dans la
colonne B en 1 je mets la formule suivante =SOMME(A1: A85) le résultat
donne un total farfelu.
Une idée du pourquoi ?
Merci
Voir le fichier ci-joint
https://www.cjoint.com/c/KEfm0tXtcq1
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
MichD
Le #26573044
Le 05/05/21 Í  08:53, Brat'ac a écrit :
Bonjour,
Dans la colonne A j'ai des données au format monétaire si dans la
colonne B en 1 je mets la formule suivante =SOMME(A1: A85) le résultat
donne un total farfelu.
Une idée du pourquoi ?
Merci
Voir le fichier ci-joint
https://www.cjoint.com/c/KEfm0tXtcq1

Bonjour,
Les cellules contiennent un caractère invisible qui ressemble au
caractère ayant comme code 32 "Espace de la barre d'espacement".
Cependant, celui que tu as dans tes cellules est le caractère 160
(espace insécable).
Pour régler ton problème :
Sélectionne la plage de cellules :
Onglet Accueil / Recherche et Sélectionner / sous-menu : "Remplacer"
Dans le textbox Remplacer : Maintient enfoncé la touche "Alt" Í  gauche
de la barre d'espacement et au clavier numérique tu tapes 0160 lorsque
tu rel͢ches la touche Alt, tu va voir apparaitre "l'espace", un dernier
clic sur "remplacer tout".
P.S. Lorsque tu cliques dans une cellule et que tu vois le symbole
"Euro", tu peux conclure Í  coup sÍ»r que tu as un problème de format de
cellules. Dans ton cas, c'est le caractère 160 qui jouait le
trouble-fête et transformait le format des cellules en "Texte".
MichD
Geo
Le #26573049
Bonjour
Une autre explication ?
En fait il n'y a que 4 case qui sont en format numérique, le reste
c'est du texte donc pris comme 0
Brat'ac
Le #26573048
MichD avait écrit le 05/05/2021 :
Le 05/05/21 Í  08:53, Brat'ac a écrit :
Bonjour,
Dans la colonne A j'ai des données au format monétaire si dans la colonne B
en 1 je mets la formule suivante =SOMME(A1: A85) le résultat donne un total
farfelu.
Une idée du pourquoi ?
Merci
Voir le fichier ci-joint
https://www.cjoint.com/c/KEfm0tXtcq1

Bonjour,
Les cellules contiennent un caractère invisible qui ressemble au caractère
ayant comme code 32 "Espace de la barre d'espacement".
Cependant, celui que tu as dans tes cellules est le caractère 160
(espace insécable).
Pour régler ton problème :
Sélectionne la plage de cellules :
Onglet Accueil / Recherche et Sélectionner / sous-menu : "Remplacer"
Dans le textbox Remplacer : Maintient enfoncé la touche "Alt" Í  gauche
de la barre d'espacement et au clavier numérique tu tapes 0160 lorsque tu
rel͢ches la touche Alt, tu va voir apparaitre "l'espace", un dernier clic sur
"remplacer tout".
P.S. Lorsque tu cliques dans une cellule et que tu vois le symbole
"Euro", tu peux conclure Í  coup sÍ»r que tu as un problème de format de
cellules. Dans ton cas, c'est le caractère 160 qui jouait le
trouble-fête et transformait le format des cellules en "Texte".
MichD

Merci c'est OK
MichD
Le #26573106
Correction, ce paragraphe était imprécis!
P.S. Lorsque tu cliques dans une cellule et que tu vois le symbole
"Euro" dans la barre des formules et que la donnée doit représenter
une valeur numérique, tu peux conclure Í  coup sÍ»r que tu as un problème
de format de cellules. La barre de formule affiche seulement la valeur
numérique d'une cellule et non les éléments appartenant au formatage.
Dans ton cas, c'est le caractère 160 qui jouait le trouble-fête et
transformait le format des cellules en "Texte". C'est sͻrement suite
Í  une importation de données d'une autre application.
MichD
Brat'ac
Le #26573109
MichD a couché sur son écran :
format des cellules en "Texte". C'est sͻrement suite
Í  une importation de données d'une autre application.

Effectivement c'est une importation d'un fichier CSV
Poster une réponse
Anonyme