calcul itératif

Le
jveuxsavoir
Bonjour tous,

On m'a pos une colle travail et je ne sais pas y
rpondre : quoi sert le calcul itratif ?
merci d'avance
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Benead
Le #1343229
Salut Jveuxsavoir,

Le calcul avec itération autorise les cellules contenant des formules faisant référence à elle même.
L'itération est très peu utilisée, mais voici un exemple (débile...) :

Admettons que tu veuilles savoir uniquement la durée maximale journalière passée sur le forum mpfe, il suffit que tu mettes tous les jours dans une
cellule (A1 par exemple) le temps passé dans la journée sur le forum, si dans Outils/Options/Onglet calcul, tu as Itération de cochée et nb
d'itérations ="1", dans la cellule B1 tu mets =SI(A1>B1;A1;B1) ; Excel ne récupérera la durée saisie en A1 que si elle est supérieure à la durée de B1.

Un autre exemple (un peu moins idiot) serait de connaitre le nombre de fois le recalcul automatique s'est effectué dans un classeur. Dans ce cas il
suffit de mettre dans une cellule (C1 dans l'exemple) Á+1

L'itération pourrait également être utilisée dans le cas de calcul de type Solveur, pour essayer de trouver une valeur proche du résultat que l'on
veut obtenir.

--
A+
Benead
Bretagne
Xl97
-------- ;-)

jveuxsavoir a écrit:
Bonjour à tous,

On m'a posé une colle travail et je ne sais pas y
répondre : à quoi sert le calcul itératif ?
merci d'avance



Le #1328487
Merci de tes explications,
Je vais essayer de les mettre en pratique
-----Message d'origine-----
Salut Jveuxsavoir,

Le calcul avec itération autorise les cellules contenant
des formules faisant référence à elle même.

L'itération est très peu utilisée, mais voici un exemple
(débile...) :


Admettons que tu veuilles savoir uniquement la durée
maximale journalière passée sur le forum mpfe, il suffit

que tu mettes tous les jours dans une
cellule (A1 par exemple) le temps passé dans la journée
sur le forum, si dans Outils/Options/Onglet calcul, tu as

Itération de cochée et nb
d'itérations ="1", dans la cellule B1 tu mets =SI
(A1>B1;A1;B1) ; Excel ne récupérera la durée saisie en A1

que si elle est supérieure à la durée de B1.

Un autre exemple (un peu moins idiot) serait de connaitre
le nombre de fois le recalcul automatique s'est effectué

dans un classeur. Dans ce cas il
suffit de mettre dans une cellule (C1 dans l'exemple)
+1


L'itération pourrait également être utilisée dans le cas
de calcul de type Solveur, pour essayer de trouver une

valeur proche du résultat que l'on
veut obtenir.

--
A+
Benead
Bretagne
Xl97
-------- ;-)

jveuxsavoir a écrit:
Bonjour à tous,

On m'a posé une colle travail et je ne sais pas y
répondre : à quoi sert le calcul itératif ?
merci d'avance



.




Publicité
Poster une réponse
Anonyme