Calcul nb de ligne, tri du nb de date par trimestre...

Le
Vincent J.
Bonjour,

J'ai un classeur excel dans lequel il y a 3 feuilles.
Les données des deux premières feuilles sont importées à partir d'un fichier
txt. J'ai donc plusieurs colonnes et plusieurs lignes par feuilles.

1) Ma première question:
Sur la deuxieme feuille, j'ai une des colonnes dans laquelle j'ai soit le
chiffre 0, soit le chiffre 1 soit le chiffre 2
J'aimerai savoir comment faire pour compter le Nb de 0, de 1, de 2 et de
renvoyer pour chaque chiffre le résultat dans une cellule distincte sur la
feuille 3.

2) Ma deuxième question:
Le tableau généré par l'importation d'un fichier txt comprend un nombre de
ligne qui varie en fonction des données qui sont dans le fichier importée.
J'aimerai savoir comment mettre en place un espece de compteur qui me donne
pour chaque feuille le nombre ligne utilisée ?

3) Ma troisieme question:
J'ai une colonne où il y a que des dates de la forme: 01/01/2007
J'aimerai savoir comment faire pour connaitre le nb de date qui concerne le
premier trimestre, le deuxieme trimestre et le 3° trimestre ?

Merci pour vos conseils

Vincent
Vos réponses
Trier par : date / pertinence
FdeCourt
Le #4407731
Bonjour,

Alors par ordre :

1)
Dans ta troisième feuille, dans les cellules A1, A2, et A3 tu mets 0,
1 puis 2, puis dans les cellules B1 tu peux mettre cette formule
=NB.SI(Feuil2!$A$1:$A$1000;A1) que tu étend jusqu'à la cellule B3 (et
que tu adapte en fonction de tes nom de feuille et plage)

2) Cette formule compte le nombre de cellule qui ne sont pas vide :
=NBVAL(Feuil2!A1:A1000)

3) Une autre formule pour les trimestres :

=CHOISIR(MOIS(A1);"Trimestre 1";"Trimestre 1";"Trimestre 1";"Trimestre
2";"Trimestre 2";"Trimestre 2";"Trimestre 3";"Trimestre 3";"Trimestre
3";"Trimestre 4";"Trimestre 4";"Trimestre 4")


On 2 fév, 10:30, "Vincent J."
Bonjour,

J'ai un classeur excel dans lequel il y a 3 feuilles.
Les données des deux premières feuilles sont importées à partir d 'un fichier
txt. J'ai donc plusieurs colonnes et plusieurs lignes par feuilles.

1) Ma première question:
Sur la deuxieme feuille, j'ai une des colonnes dans laquelle j'ai soit le
chiffre 0, soit le chiffre 1 soit le chiffre 2
J'aimerai savoir comment faire pour compter le Nb de 0, de 1, de 2 et de
renvoyer pour chaque chiffre le résultat dans une cellule distincte sur la
feuille 3.

2) Ma deuxième question:
Le tableau généré par l'importation d'un fichier txt comprend un no mbre de
ligne qui varie en fonction des données qui sont dans le fichier import ée.
J'aimerai savoir comment mettre en place un espece de compteur qui me don ne
pour chaque feuille le nombre ligne utilisée ?

3) Ma troisieme question:
J'ai une colonne où il y a que des dates de la forme: 01/01/2007
J'aimerai savoir comment faire pour connaitre le nb de date qui concerne le
premier trimestre, le deuxieme trimestre et le 3° trimestre ?

Merci pour vos conseils

Vincent


Elliac
Le #4407701
Bonjour,

1) =Nb.si(A:A;0), =Nb.si(B:B;1), =Nb.si(C:C;2),
2) =Nbval(B:B)
3) Pour le T1 :
=SOMMEPROD((A1:A5000>ÚTE(2007;1;1))*(A1:A5000<ÚTE(2007;3;31)))

Camille

"Vincent J." wrote:

Bonjour,

J'ai un classeur excel dans lequel il y a 3 feuilles.
Les données des deux premières feuilles sont importées à partir d'un fichier
txt. J'ai donc plusieurs colonnes et plusieurs lignes par feuilles.

1) Ma première question:
Sur la deuxieme feuille, j'ai une des colonnes dans laquelle j'ai soit le
chiffre 0, soit le chiffre 1 soit le chiffre 2
J'aimerai savoir comment faire pour compter le Nb de 0, de 1, de 2 et de
renvoyer pour chaque chiffre le résultat dans une cellule distincte sur la
feuille 3.

2) Ma deuxième question:
Le tableau généré par l'importation d'un fichier txt comprend un nombre de
ligne qui varie en fonction des données qui sont dans le fichier importée.
J'aimerai savoir comment mettre en place un espece de compteur qui me donne
pour chaque feuille le nombre ligne utilisée ?

3) Ma troisieme question:
J'ai une colonne où il y a que des dates de la forme: 01/01/2007
J'aimerai savoir comment faire pour connaitre le nb de date qui concerne le
premier trimestre, le deuxieme trimestre et le 3° trimestre ?

Merci pour vos conseils

Vincent





Manu
Le #4407691
1 - =NB.SI(plage;0) puis idem pour 1 puis pour 2

2 - =NBVAL(plage de la colonne)

3 - (pour 1er trim) =NB.SI(plage;">/01/2007")-NB.SI(plage;">1/03/2007")
puis idem pour les autres trimestres

Manu

"Vincent J." %
Bonjour,

J'ai un classeur excel dans lequel il y a 3 feuilles.
Les données des deux premières feuilles sont importées à partir d'un
fichier txt. J'ai donc plusieurs colonnes et plusieurs lignes par
feuilles.

1) Ma première question:
Sur la deuxieme feuille, j'ai une des colonnes dans laquelle j'ai soit le
chiffre 0, soit le chiffre 1 soit le chiffre 2
J'aimerai savoir comment faire pour compter le Nb de 0, de 1, de 2 et de
renvoyer pour chaque chiffre le résultat dans une cellule distincte sur la
feuille 3.

2) Ma deuxième question:
Le tableau généré par l'importation d'un fichier txt comprend un nombre de
ligne qui varie en fonction des données qui sont dans le fichier importée.
J'aimerai savoir comment mettre en place un espece de compteur qui me
donne pour chaque feuille le nombre ligne utilisée ?

3) Ma troisieme question:
J'ai une colonne où il y a que des dates de la forme: 01/01/2007
J'aimerai savoir comment faire pour connaitre le nb de date qui concerne
le premier trimestre, le deuxieme trimestre et le 3° trimestre ?

Merci pour vos conseils

Vincent



Manu
Le #4407661
Oups il fallait pour la reponse 3 faire
(pour 1er trim) =NB.SI(plage;">/01/2007")-NB.SI(plage;">31/03/2007")
"Manu"
1 - =NB.SI(plage;0) puis idem pour 1 puis pour 2

2 - =NBVAL(plage de la colonne)

3 - (pour 1er trim)
=NB.SI(plage;">/01/2007")-NB.SI(plage;">1/03/2007") puis idem pour
les autres trimestres

Manu

"Vincent J." %
Bonjour,

J'ai un classeur excel dans lequel il y a 3 feuilles.
Les données des deux premières feuilles sont importées à partir d'un
fichier txt. J'ai donc plusieurs colonnes et plusieurs lignes par
feuilles.

1) Ma première question:
Sur la deuxieme feuille, j'ai une des colonnes dans laquelle j'ai soit le
chiffre 0, soit le chiffre 1 soit le chiffre 2
J'aimerai savoir comment faire pour compter le Nb de 0, de 1, de 2 et de
renvoyer pour chaque chiffre le résultat dans une cellule distincte sur
la feuille 3.

2) Ma deuxième question:
Le tableau généré par l'importation d'un fichier txt comprend un nombre
de ligne qui varie en fonction des données qui sont dans le fichier
importée.
J'aimerai savoir comment mettre en place un espece de compteur qui me
donne pour chaque feuille le nombre ligne utilisée ?

3) Ma troisieme question:
J'ai une colonne où il y a que des dates de la forme: 01/01/2007
J'aimerai savoir comment faire pour connaitre le nb de date qui concerne
le premier trimestre, le deuxieme trimestre et le 3° trimestre ?

Merci pour vos conseils

Vincent







Vincent J.
Le #4407591
Merci à tous pour vos réponses.
Cela fonctionne très bien.
Merci !

Vincent
Publicité
Poster une réponse
Anonyme