calculer la durée entre 2dates&heures

Le
Aline
bonjour,

j'espere qu'il y'a qq parmi vous qui pourra me donner un coup de main, mon
prob est le suivant :
1- quand je calcule la difference entre deux dates&heures j'ai un résultat
en heures alors que je le voudrais en heures et minutes.
2- en calculant je voudrais pouvoir prendre en considération des heures
ouvrables

grand merci à tous et bonne année.
Aline
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.M
Le #319362
Bonjour Aline,

1- quand je calcule la difference entre deux dates&heures j'ai un résultat
en heures alors que je le voudrais en heures et minutes.


Une question de format, il me semble:
[h]:mm
devrait convenir.


2- en calculant je voudrais pouvoir prendre en considération des heures
ouvrables


Donne une couple d'exemple (avec les heures ouvrable début et fin) et les
résultats attendus.

Salutations,

Daniel M.

Aline
Le #319944
non ca ne marche pas voici l'exemple :

A1= 18/12/2003 14:00
B1/12/03 16:56
C1=(B1-A1)*24
résultat C1&,93 alors que je l'aurais voulu en hh:mm
si j'utilise le format que vous m'avez indiqué j'ai un résultat bizare de
646:24
*************************************************************
2ieme probleme entre le 18/12/2003 14h et 19/12/2003 16:56 je ne voudrais
compter que les horaires de bureau à savoir 8h_12h et 14h-18h.
ce qui devrait me donner comme résultat C1h56mn
Merci

"Daniel.M" news:
Bonjour Aline,

1- quand je calcule la difference entre deux dates&heures j'ai un
résultat


en heures alors que je le voudrais en heures et minutes.


Une question de format, il me semble:
[h]:mm
devrait convenir.


2- en calculant je voudrais pouvoir prendre en considération des heures
ouvrables


Donne une couple d'exemple (avec les heures ouvrable début et fin) et les
résultats attendus.

Salutations,

Daniel M.





Daniel.M
Le #319901
Salut Aline,

non ca ne marche pas voici l'exemple :
A1= 18/12/2003 14:00
B1/12/03 16:56
C1=(B1-A1)*24



Enlève le *24 (qui te donne des entiers au lieu des fractions de jour). En
Excel, le temps est exprimé en fractions de jour (1 heure = 1/24 de jour).

C1±-A1
et formatte en [h]:mm


2ieme probleme entre le 18/12/2003 14h et 19/12/2003 16:56 je ne voudrais
compter que les horaires de bureau à savoir 8h_12h et 14h-18h.
ce qui devrait me donner comme résultat C1h56mn
Merci


La formule MATRICIELLE suivante (saisir avec Ctrl-Maj-Entrée):

=SOMME((FREQUENCE(MOD(((LIGNE(INDIRECT("1:"&ARRONDI((B1-A1)*1440;0
)))-1)+1440*MOD(A1;1));1440);{8;12;14;18}*60-1)/1440)*{0;1;0;1;0})

Salutations,

Daniel M.

Publicité
Poster une réponse
Anonyme