calculs dans excel

Le
minution
Bonjour,
1.J'ai créé une liste de prix avec 150 items dans excel (liste qui pourrait
doubler), avec un prix unitaire dans leur cellule voisine respective.
2.J'ai créé un formulaire de soumission avec des colonnes comme QUANTITÉ,
DESCRIPTION, PRIX UNITAIRE et TOTAL
3. Dans ma colonne DESCRIPTION, j'ai créé une liste déroulante avec les 150
items
4. Comment puis-je faire pour qu'en choissant n'importe quels items dans ma
liste déroulante (colonne DESCRIPTION), le bon prix correspondant à cet item
apparaisse dans la colonne PRIX UNITAIRE ?

Dernière question, comment-ça coûte pour faire monter la formule ?

Merci !
Vos réponses
Trier par : date / pertinence
Garette
Le #4430431
Bonsoir,

Si la liste deroulante renvoie la valeur saisie en A2 (A1 contient
"DESCRIPTION" et B1 "PRIX UNITAIRE")
Et les données DESCRIPTION et PRIX UNITAIRE sont dans les cellules F1:Gx (x
= ligne fin du tableau)

En B2 saisir :
=RECHERCHEV(A2;$F$1:$G$x;2;FAUX) (où x = ligne fin du tableau)


"minution" news:
Bonjour,
1.J'ai créé une liste de prix avec 150 items dans excel (liste qui
pourrait
doubler...), avec un prix unitaire dans leur cellule voisine respective.
2.J'ai créé un formulaire de soumission avec des colonnes comme QUANTITÉ,
DESCRIPTION, PRIX UNITAIRE et TOTAL
3. Dans ma colonne DESCRIPTION, j'ai créé une liste déroulante avec les
150
items
4. Comment puis-je faire pour qu'en choissant n'importe quels items dans
ma
liste déroulante (colonne DESCRIPTION), le bon prix correspondant à cet
item
apparaisse dans la colonne PRIX UNITAIRE ?

Dernière question, comment-ça coûte pour faire monter la formule ?

Merci !



JB
Le #4430391
Bonsoir,

http://cjoint.com/?bmvZMzi33M

Private Sub UserForm_Initialize()
Me.ComboBox1.List =
Application.Transpose(Application.Transpose([ListeBd]))
End Sub

Private Sub ComboBox1_Change()
Me.Prix = Me.ComboBox1.Column(1)
Me.Description = Me.ComboBox1.Column(2)
End Sub

JB

Bonjour,
1.J'ai créé une liste de prix avec 150 items dans excel (liste qui po urrait
doubler...), avec un prix unitaire dans leur cellule voisine respective.
2.J'ai créé un formulaire de soumission avec des colonnes comme QUANT ITÉ,
DESCRIPTION, PRIX UNITAIRE et TOTAL
3. Dans ma colonne DESCRIPTION, j'ai créé une liste déroulante avec les 150
items
4. Comment puis-je faire pour qu'en choissant n'importe quels items dans ma
liste déroulante (colonne DESCRIPTION), le bon prix correspondant à c et item
apparaisse dans la colonne PRIX UNITAIRE ?

Dernière question, comment-ça coûte pour faire monter la formule ?

Merci !


Publicité
Poster une réponse
Anonyme