Caractères étrangers

Le
Jean-Philippe MENGUAL
Bonjour,

Vous avez une asutce pour saisir des caractères espagnols (accents et
tildes) facilement sous Libreoffice voire sous X en général? J'hésite
entre le setxkbcomp un peu moche et la macro, ou le raccourci ibus.
Qu'en pensez-vous?

Merci de vos retours

Amicalement,

--
Jean-Philippe MENGUAL
Debian Developer non uploading
Community team member
Accessibility team member
debian-l10n-french team member
President of Debian France non-profit organization
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
nicolas.patrois
Le #26566839
Le 01/02/2021 21:31:21, Jean-Philippe MENGUAL a écrit :
Bonjour,
Vous avez une asutce pour saisir des caractères espagnols (accents et
tildes) facilement sous Libreoffice voire sous X en général? J'hésite
entre le setxkbcomp un peu moche et la macro, ou le raccourci ibus.
Qu'en pensez-vous?
Merci de vos retours

Avec la touche compose (Windows Í  droite chez moi) ?
Compose ' o donne ͳ.
Compose n ~ donne ͱ.
C’est très intuitif.
nicolas patrois : pts noir asocial
--
RÉALISME
M : Qu'est-ce qu'il nous faudrait pour qu'on nous considère comme des humains ? Un cerveau plus gros ?
P : Non... Une carte bleue suffirait...
Jean-Philippe MENGUAL
Le #26566845
Jean-Philippe MENGUAL
Debian Developer non uploading
Community team member
Accessibility team member
debian-l10n-french team member
President of Debian France non-profit organization
Le 01/02/2021 Í  22:10, a écrit :
Le 01/02/2021 21:31:21, Jean-Philippe MENGUAL a écrit :
Bonjour,

Vous avez une asutce pour saisir des caractères espagnols (accents et
tildes) facilement sous Libreoffice voire sous X en général? J'hésite
entre le setxkbcomp un peu moche et la macro, ou le raccourci ibus.
Qu'en pensez-vous?

Merci de vos retours

Avec la touche compose (Windows Í  droite chez moi) ?
Compose ' o donne ͳ.
Compose n ~ donne ͱ.
C’est très intuitif.

Clairement, mais chez moi ca ne marche pas. Tu as une configuration
particulière dans tes paramètres clavier?
Merci
Amicalement,
nicolas patrois : pts noir asocial
Fran=c3=a7ois Patte
Le #26566861
This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--bvnpJPDoljmHPowUxRGamelALAXmT48lT
Content-Type: multipart/mixed; boundary="NIh3A1bzjiprKorGsxTgrHtvObgovA6HL";
protected-headers="v1"
From: =?UTF-8?Q?Fran̓§ois_Patte?= To:
Message-ID: Subject: =?UTF-8?Q?Re:_Caract̓¨res_̓©trangers?References: In-Reply-To: --NIh3A1bzjiprKorGsxTgrHtvObgovA6HL
Content-Type: text/plain; charset=utf-8
Content-Language: fr-MC
Content-Transfer-Encoding: quoted-printable
Le 01/02/2021 ̓  21:31, Jean-Philippe MENGUAL a ̓©crit͂ :
Bonjour,
Vous avez une asutce pour saisir des caract̓¨res espagnols (accents et
tildes) facilement sous Libreoffice voire sous X en g̓©n̓©ral? J'h̓©site
entre le setxkbcomp un peu moche et la macro, ou le raccourci ibus.
Qu'en pensez-vous?

Personnellement j'utilise ibus pour saisir les ̓©critures exotiques. m17n
offre une palanqu̓©e de "claviers" qui couvre une grande partie des
̓©critures du monde.
--
Fran̓§ois Patte
UFR de math̓©matiques et informatique
Laboratoire CNRS MAP5, UMR 8145
Universit̓© Paris Descartes
45, rue des Saints P̓¨res
F-75270 Paris Cedex 06
T̓©l. +33 (0)6 7892 5822
http://www.math-info.univ-paris5.fr/~patte
--NIh3A1bzjiprKorGsxTgrHtvObgovA6HL--
--bvnpJPDoljmHPowUxRGamelALAXmT48lT
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"
-----BEGIN PGP SIGNATURE-----
iF0EARECAB0WIQQ5itosDZMreh2Xgnx0ToLZ2FXYlQUCYBkdmAAKCRB0ToLZ2FXY
lYhRAKC0zjlDSpQUP0/Ghg5NXwmkhm62xQCfURXPVhdGLCNLX74225CJfoFgitoͿOf
-----END PGP SIGNATURE-----
--bvnpJPDoljmHPowUxRGamelALAXmT48lT--
Fran=c3=a7ois LE GAD
Le #26566870
Le 01/02/2021 Í  22:10, a écrit :
Avec la touche compose (Windows Í  droite chez moi) ?
Compose ' o donne ͳ.
Compose n ~ donne ͱ.
C’est très intuitif.

On appuie successivement (et pas simultanément) sur les touches compose,
lettre, et accent.
On obtient aussi æ, œ,
ou encore … (compose point point)
--
François
Fran=c3=a7ois LE GAD
Le #26566871
Le 02/02/2021 Í  01:43, Michel MOUNIER a écrit :
Tu choisis ta touche "compose" dans les paramètres claviers /clavier -
disposition - touche composée /puis ça roule.

Ou, en root ou sudo :
dpkg-reconfigure keyboard-configuration
et tu définis la touche compose parmi les choix proposés
--
François
Jean-Michel OLTRA
Le #26566889
Bonjour,
Le lundi 01 février 2021, Jean-Philippe MENGUAL a écrit...
Clairement, mais chez moi ca ne marche pas. Tu as une configuration
particulière dans tes paramètres clavier?

J'ai, chez moi, un fichier .xmodmaprc (dans mon /home), dans lequel j'ai la
seule ligne
keycode 135 = Multi_key
Ma touche compose c'est celle qui est Í  gauche du Ctrl de droite.
--
jm
nicolas.patrois
Le #26566888
Le 02/02/2021 15:14:47, Jean-Michel OLTRA a écrit :
J'ai, chez moi, un fichier .xmodmaprc (dans mon /home), dans lequel
j'ai la seule ligne
keycode 135 = Multi_key
Ma touche compose c'est celle qui est Í  gauche du Ctrl de droite.

Le mien contient plein de bazar, dont cette ligne :
keycode 134 = Multi_key Multi_key Multi_key Multi_key Multi_key Multi_key
C’est la touche Windows Í  droite, coincée entre AltGr et la touche Menu (qui ne me sert pas).
nicolas patrois : pts noir asocial
--
RÉALISME
M : Qu'est-ce qu'il nous faudrait pour qu'on nous considère comme des humains ? Un cerveau plus gros ?
P : Non... Une carte bleue suffirait...
Daniel Caillibaud
Le #26566928
Le 01/02/21 Í  21:31, Jean-Philippe MENGUAL
Bonjour,
Vous avez une asutce pour saisir des caractères espagnols (accents et
tildes) facilement sous Libreoffice voire sous X en général?

Outre la solution avec compose, tu as aussi la touche muette ` suivie d'une lettre pour les
accents graves, mais c'est pas très utile en espagnol.
(suivant le clavier que tu as choisi, ça marche en bépo et avec la plupart des dispositions
azerty).
Pour l'accent aigu, je sais pas si y'a une touche morte en azerty, mais tu peux l'ajouter Í  ton
clavier en allant modifier /usr/share/X11/xkb/symbols/fr (fais une sauvegarde avant)
Chercher dead_ pour voir tout ce qui existe (mais pour l'espagnol tu auras surtout besoin de
dead_tilde et dead_acute, dead_grave tu l'as probablement déjÍ  avec le backtick `).
Ça permet de gagner une touche en évitant compose.
Et si tu tapes souvent en espagnol, ajoute qq part les lettres fréquentes á Í­ ͳ ͺ en accès
direct (par ex Í  la place du altGr+voyelle qui donne le circonflexe en azerty, qu'on utilise
nettement moins souvent et qui reste faisable avec circonflexe+voyelle).
Tu peux aussi ajouter ¿ et ¡ si tu l'as pas dans ta disposition (en bépo c'est altGr+? et
altGr+!)
Il faudra probablement refaire ces modifs après une mise Í  jour du paquet xkb-data (qui
fournit /usr/share/X11/xkb/symbols/fr), d'ou l'intérêt de conserver le fichier original (tu
peux aussi générer un patch pour le réappliquer après une mise Í  jour), je sais pas si y'a une
méthode plus propre pour arriver au même résultat.
Sinon, pour personnaliser ce que permet la touche compose, tu peux ajouter des trucs dans un
~/Xcompose (man Compose), mais Í  priori la conf par défaut doit déjÍ  couvrir l'ensemble des
caractères espagnols.
--
Daniel
On tue un homme, on est un assassin.
On tue des millions d'hommes, on est un conquérant.
On les tue tous, on est un dieu.
Edmond Rostand
Francois Meyer
Le #26567083
Bonjour,
sur mon thinkpad sous buster, le wifi ne se met plus en place (après une
maj, semble-t-il).
- lspci voit bien la carte (realtek rtl 8188ce)
- lsmod voit bien les modules qui vont avec, firmware-realtek est bien
installé Í  jour
- iwlist voit bien les points d'accès Í  proximité
dans les logs, je ne vois que "wlp0s3 not ready" et "lost carrier". Wicd
affiche tous les messages habituels de mise en place de la connection Í 
mon point d'accès habituel, mais finalement, l'interface reste non
configurée.
Est-ce que le fait que iwlist affiche bien les points d'accès implique
que le problème ne vient pas du pilote, mais de wpa_supplicant ou
d'autre chose ? je suis un peu perdu.
François
Poster une réponse
Anonyme