champs text liés a une table

Le
pierref
Bonjour,

j'ai un formulaire comtenant trois zones de texte.
Je les ai relis a une table qui comporte 3 champs et un
seul et unique enregistrement. (cet enregistrement est
effac et recr et il n'y en aura toujours qu'un seul)

Malheureusement, les zones de textes affiche #nom? et pas
les valeurs de mon enregistrement.

Comment faire pour que ca marche? (pour chaque zone, j'ai
spcifi un champ de la table dans la proprit "source
controle")

De plus, si l'enregistrement est inexistant, comment
viter l'affichage du #nom? ?

Merci de m'aider

a+
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Raymond [mvp]
Le #5040171
Bonjour.

n'aurais-tu pas effacé par erreur le recordsource de ton formulaire ?
fenêtre propriétés / onglet donnés / source

--
@+
Raymond Access MVP
http://access.seneque.free.fr/
http://access2003.free.fr/
http://users.skynet.be/mpfa/ pour débuter sur le forum


"pierref" news:33bc01c42919$fa322cd0$
Bonjour,

j'ai un formulaire comtenant trois zones de texte.
Je les ai reliés a une table qui comporte 3 champs et un
seul et unique enregistrement. (cet enregistrement est
effacé et recréé et il n'y en aura toujours qu'un seul)

Malheureusement, les zones de textes affiche #nom? et pas
les valeurs de mon enregistrement.

Comment faire pour que ca marche? (pour chaque zone, j'ai
spécifié un champ de la table dans la propriété "source
controle")

De plus, si l'enregistrement est inexistant, comment
éviter l'affichage du #nom? ?

Merci de m'aider

a+
pierref
Le #5040071
je n'avais rien fait de ce coté la...
je viens de le faire mais ca ne marche pas
de plus, si la table ne contient pas d'enr. , le
formulaire apparait vierge.

merci


-----Message d'origine-----
Bonjour.

n'aurais-tu pas effacé par erreur le recordsource de ton
formulaire ?

fenêtre propriétés / onglet donnés / source

--
@+
Raymond Access MVP
http://access.seneque.free.fr/
http://access2003.free.fr/
http://users.skynet.be/mpfa/ pour débuter sur le forum


"pierref" dans le message de

news:33bc01c42919$fa322cd0$
Bonjour,

j'ai un formulaire comtenant trois zones de texte.
Je les ai reliés a une table qui comporte 3 champs et un
seul et unique enregistrement. (cet enregistrement est
effacé et recréé et il n'y en aura toujours qu'un seul)

Malheureusement, les zones de textes affiche #nom? et pas
les valeurs de mon enregistrement.

Comment faire pour que ca marche? (pour chaque zone, j'ai
spécifié un champ de la table dans la propriété "source
controle")

De plus, si l'enregistrement est inexistant, comment
éviter l'affichage du #nom? ?

Merci de m'aider

a+



.



pierref
Le #5039931
finalement, j'ai trouvé une solution plus simple qui
marche.
j'utilise un zone de liste et je lui donne la taille d'une
zone de texte.

ca marche niquel

merci et a+


-----Message d'origine-----
Bonjour.

n'aurais-tu pas effacé par erreur le recordsource de ton
formulaire ?

fenêtre propriétés / onglet donnés / source

--
@+
Raymond Access MVP
http://access.seneque.free.fr/
http://access2003.free.fr/
http://users.skynet.be/mpfa/ pour débuter sur le forum


"pierref" dans le message de

news:33bc01c42919$fa322cd0$
Bonjour,

j'ai un formulaire comtenant trois zones de texte.
Je les ai reliés a une table qui comporte 3 champs et un
seul et unique enregistrement. (cet enregistrement est
effacé et recréé et il n'y en aura toujours qu'un seul)

Malheureusement, les zones de textes affiche #nom? et pas
les valeurs de mon enregistrement.

Comment faire pour que ca marche? (pour chaque zone, j'ai
spécifié un champ de la table dans la propriété "source
controle")

De plus, si l'enregistrement est inexistant, comment
éviter l'affichage du #nom? ?

Merci de m'aider

a+



.



Raymond [mvp]
Le #5039901
faudrait que tu m'expliques la relation entre le 1er post ( #nom) et une
zone de liste qui solutionne.

--
@+
Raymond Access MVP
http://access.seneque.free.fr/
http://access2003.free.fr/
http://users.skynet.be/mpfa/ pour débuter sur le forum


"pierref" news:345d01c4292a$32acd7d0$
finalement, j'ai trouvé une solution plus simple qui
marche.
j'utilise un zone de liste et je lui donne la taille d'une
zone de texte.

ca marche niquel

merci et a+
pierref
Le #5039651
Oui j'ai pas été tres clair ...

pour afficher un champ de l'unique enregistrement d'une
table, je le liais a un zone de texte.
Or j'avais l'erreur #nom? .

En remplacant la zone de texte par un zone de liste liée a
ce champ, j'ai plus d'erreur.

la zone de liste ne contient qu'une ligne( parce qu'un
seul enr dans la table) donc je peux la réduire en hauteur
pour qu'elle ressemble a une zone de texte.

voila

merci et a+




-----Message d'origine-----
faudrait que tu m'expliques la relation entre le 1er post
( #nom) et une

zone de liste qui solutionne.

--
@+
Raymond Access MVP
http://access.seneque.free.fr/
http://access2003.free.fr/
http://users.skynet.be/mpfa/ pour débuter sur le forum


"pierref" dans le message de

news:345d01c4292a$32acd7d0$
finalement, j'ai trouvé une solution plus simple qui
marche.
j'utilise un zone de liste et je lui donne la taille d'une
zone de texte.

ca marche niquel

merci et a+



.



Publicité
Poster une réponse
Anonyme