Cherche une formule

Le
Marc Dayde
J'ai une cellule : E56 qui est le résultat de l'operation E49-D58-D55. je
voudrais que si ce résultat est superieur à 100, la formule me divise par
deux le résultat et m'inscrive le resultat dans la cellule E56 et dans une
autre cellule E57 ( ex : 120 E56` et E57`) .Si par contre, le resultat
est inferieur à 100, le resultat s'affiche en E56 et affiche 0 en E57. Merci
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas B.
Le #1279201
Salut Marc,

En E56 :
=SI(E49-D58-D55>100;(E49-D58-D55)/2;E49-D58-D55)

Et en E57 :
=SI(E49-D58-D55>100;E56;0)


A+
--
Nicolas B.


J'ai une cellule : E56 qui est le résultat de l'operation
E49-D58-D55. je voudrais que si ce résultat est superieur à 100, la
formule me divise par deux le résultat et m'inscrive le resultat dans
la cellule E56 et dans une autre cellule E57 ( ex : 120 E56` et
E57`) .Si par contre, le resultat est inferieur à 100, le resultat
s'affiche en E56 et affiche 0 en E57. Merci


FxM
Le #1279200
Bonsoir Marc,

en E56 : =si((E49-D58-D55)>100 ; 0.5;1)*(E49-D58-D55)
en E57 : =si((E49-D58-D55)>100 ; 0.5;0)*(E49-D58-D55)

@+
FxM


Marc Dayde wrote:
J'ai une cellule : E56 qui est le résultat de l'operation E49-D58-D55. je
voudrais que si ce résultat est superieur à 100, la formule me divise par
deux le résultat et m'inscrive le resultat dans la cellule E56 et dans une
autre cellule E57 ( ex : 120 E56` et E57`) .Si par contre, le resultat
est inferieur à 100, le resultat s'affiche en E56 et affiche 0 en E57. Merci




Philippe.R
Le #1279199
Bonsoir Marc,
En E56 : =si((E49-D58-D55)<0;E49-D58-D55;(E49-D58-D55)/2) ferait à priori l'affaire
En E57 cette formule devrait convenir :
=si((E49-D58-D55)<0;0;(E49-D58-D55)/2)
--
Amicales Salutations
Retirer A_S_ pour répondre.
XL 97 / 2000 / 2002
Pour suivre le forum :
news://msnews.microsoft.com/microsoft.public.fr.excel
(Voulez-vous vous abonner ? -> Oui)

"Marc Dayde" news:c5c4oo$dv5$
J'ai une cellule : E56 qui est le résultat de l'operation E49-D58-D55. je
voudrais que si ce résultat est superieur à 100, la formule me divise par
deux le résultat et m'inscrive le resultat dans la cellule E56 et dans une
autre cellule E57 ( ex : 120 E56` et E57`) .Si par contre, le resultat
est inferieur à 100, le resultat s'affiche en E56 et affiche 0 en E57. Merci




Nicolas B.
Le #1279198
Salut FxM,

Ou encore, un peu plus court pour E56 :
=((E49-D58-D55<100)+0,5)*(E49-D58-D55)


A+
--
Nicolas B.


Bonsoir Marc,

en E56 : =si((E49-D58-D55)>100 ; 0.5;1)*(E49-D58-D55)
en E57 : =si((E49-D58-D55)>100 ; 0.5;0)*(E49-D58-D55)

@+
FxM


Marc Dayde wrote:
J'ai une cellule : E56 qui est le résultat de l'operation
E49-D58-D55. je voudrais que si ce résultat est superieur à 100, la
formule me divise par deux le résultat et m'inscrive le resultat
dans la cellule E56 et dans une autre cellule E57 ( ex : 120
E56` et E57`) .Si par contre, le resultat est inferieur à 100,
le resultat s'affiche en E56 et affiche 0 en E57. Merci




FxM
Le #1279194
Hug Nicolas,

Dans notre série "la plus courte ..." [JièL pourrait t'en raconter :o) ]
j'ai deux légers doutes :

En retournant l'expression ...>100 devient ...<, ce qui exclut le cas où
e49-d58-d55 = 100.

(e49-d58-d55<100) traité en numérique donne 0 ou 1
0+0,5 donne 0,5 (OK) mais 1+0,5 donne 1,5 au lieu de 1

Que dis-tu de :
en E56: =(((E49-D58-D55)<0)/2+0,5)*(E49-D58-D55)

@+
FxM



Nicolas B. wrote:
Salut FxM,

Ou encore, un peu plus court pour E56 :
=((E49-D58-D55<100)+0,5)*(E49-D58-D55)


A+


FxM
Le #1279193
FxM wrote:

Ouh là, autant préciser tout de suite :

Dans notre série "la plus courte ..." [JièL pourrait t'en raconter :o) ]
... je parle de formule, bien sûr !


@+
FxM

Marc Daydé
Le #1279186
Salut FxM
J'ai pris ta soluce( désolé pour les autres) et elle fonctionne . Petit
détail : tu mets dans ta formule : 0.5 alors que c'est 0,5 . ( avec
0.5 , win me met une erreur) Merci pour tout.
Nicolas B.
Le #1279185
Ahlala, j'me suis encore raté dans les calculs.


Mais pour le > et < à 100, la question n'était pas claire :
... si ce résultat est superieur à 100...
...Si par contre, le resultat est inferieur à 100...


Je me suis donc permis de changer la condition.


Merci quand même pour la correction :-)

A+
--
Nicolas B.


Hug Nicolas,

Dans notre série "la plus courte ..." [JièL pourrait t'en raconter
:o) ] j'ai deux légers doutes :

En retournant l'expression ...>100 devient ...<, ce qui exclut le cas
où e49-d58-d55 = 100.

(e49-d58-d55<100) traité en numérique donne 0 ou 1
0+0,5 donne 0,5 (OK) mais 1+0,5 donne 1,5 au lieu de 1

Que dis-tu de :
en E56: =(((E49-D58-D55)<0)/2+0,5)*(E49-D58-D55)

@+
FxM



Nicolas B. wrote:
Salut FxM,

Ou encore, un peu plus court pour E56 :
=((E49-D58-D55<100)+0,5)*(E49-D58-D55)


A+




FxM
Le #1279182
Marc Daydé wrote:

Salut FxM
J'ai pris ta soluce( désolé pour les autres) et elle fonctionne . Petit
détail : tu mets dans ta formule : 0.5 alors que c'est 0,5 . ( avec
0.5 , win me met une erreur) Merci pour tout.


Bonjour Marc,

C'est que sur mon portable, j'ai mis le . en séparateur décimal. Tu as
bien fait de corriger.

euh ... 1/2 ?

@+
FxM

Lord Nelson
Le #1279169
Salut,
En fait, tu dois placer deux formules :
Dans E56
=SI(E49-D58-D55>100;(E49-D58-D55)/2;E49-D58-D55)
et dans E57
=SI(E49-D58-D55>100;(E49-D58-D55)/2;0)
A+
-----Message d'origine-----
J'ai une cellule : E56 qui est le résultat de l'operation
E49-D58-D55. je

voudrais que si ce résultat est superieur à 100, la
formule me divise par

deux le résultat et m'inscrive le resultat dans la
cellule E56 et dans une

autre cellule E57 ( ex : 120 E56` et E57`) .Si par
contre, le resultat

est inferieur à 100, le resultat s'affiche en E56 et
affiche 0 en E57. Merci



.



Publicité
Poster une réponse
Anonyme