Chez moi

Le
Jo Engo
Ça fait un moment que je voulais m'occuper de ce truc et je remettait au
lendemain (procrastination, quand tu nous tiens…)

J'ai ce message d'erreur depuis un certain temps :
Xlib: extension "GLX" missing on display ":0.0".

D'après lspci ma carte est la suivante :

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev
0a)

Par quoi je commence ?

--
"Two beer or not two beer, zat is ze question"
-+- M. Megot, Prof de gym du Petit Spirou -+-
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pierre www.aribaut.com
Le #26505419
Le 13/01/2019 à 16:42, Jo Engo a écrit :
Ça fait un moment que je voulais m'occuper de ce truc et je remettait au
lendemain (procrastination, quand tu nous tiens…)
J'ai ce message d'erreur depuis un certain temps :
Xlib: extension "GLX" missing on display ":0.0".
D'après lspci ma carte est la suivante :
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev
0a)
Par quoi je commence ?

Google est ton ami, ceux avec le même problème et qui ont résolu le
problème :
https://github.com/Bumblebee-Project/Bumblebee/issues/816
Tu as essayé sudo update-glx --config glx et relancer X ?
Vérifie aussi le cablage, puisqu'il y en a un qui a eu le même problème
que toi et au final après avoir testé plein de commandes, il s'est avéré
que c'était un problème hardware :
https://forum.ubuntu-fr.org/viewtopic.php?id#6387
"Problème résolu.
Le problème venait du hardware. J'ai installé un nouveau disque dur il y
a peu de temps. J'ai dû débrancher le câble d'alimentation de la carte
graphique en fouillant dans les fils."
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Jo Engo
Le #26505443
Le Mon, 14 Jan 2019 09:51:29 +0100, Pierre www.aribaut.com a écrit :
https://github.com/Bumblebee-Project/Bumblebee/issues/816

Je n'ai pas encore visité vu que tu racontes la fin du film
Tu as essayé sudo update-glx --config glx et relancer X ?

Ça a l'air très bien mais quel est le pourquoi du comment ?
Je suis d'autant plus perplexe et circonspect (je parie 10 cent que c'est
un outil - propriétaire - nvidia, or je préfère ce qui est libre) qu'il
me propose :
Sélection Chemin Priorité État
------------------------------------------------------------
* 0 /usr/lib/nvidia 100 mode automatique
1 /usr/lib/mesa-diverted 5 mode manuel
2 /usr/lib/nvidia 100 mode manuel
3 /usr/lib/nvidia/bumblebee 95 mode manuel
or ma carte est une intel, pas une nvidia. Je vais essayer le 1 mais là
c'est quasi-certain que je ne profiterai pas de l'accélération graphique
bien que «ça marche».
--
On ne voit bien qu'avec le coeur. L'essentiel est invisible pour les
yeux.
-+- Antoine de Saint-Exupéry (1900-1944) -+-
Sergio
Le #26505447
Le 14/01/2019 à 11:56, Jo Engo a écrit :
Le Mon, 14 Jan 2019 09:51:29 +0100, Pierre www.aribaut.com a écrit :
Je suis d'autant plus perplexe et circonspect (je parie 10 cent que c'est
un outil - propriétaire - nvidia, or je préfère ce qui est libre) qu'il
me propose :
Sélection Chemin Priorité État
------------------------------------------------------------
* 0 /usr/lib/nvidia 100 mode automatique
1 /usr/lib/mesa-diverted 5 mode manuel
2 /usr/lib/nvidia 100 mode manuel
3 /usr/lib/nvidia/bumblebee 95 mode manuel
or ma carte est une intel, pas une nvidia. Je vais essayer le 1 mais là
c'est quasi-certain que je ne profiterai pas de l'accélération graphique
bien que «ça marche».

Pour info, bumblebee est le pilote Linux (libre) pour utiliser la techno "Optimus" de NVIDIA.
Optimus consiste à utiliser (sur un portable) soit la carte graphique Intel, soit la NVidia, suivant les besoins.
cf https://doc.ubuntu-fr.org/bumblebee
Note: Avant de se lancer dans des manips compliquées, il est très intéressant d'utiliser un moteur de recherche pour savoir si quelqu'un ne l'a pas déjà fait...
--
Serge http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Pierre www.aribaut.com
Le #26505446
Le 14/01/2019 à 11:56, Jo Engo a écrit :
Le Mon, 14 Jan 2019 09:51:29 +0100, Pierre www.aribaut.com a écrit :
https://github.com/Bumblebee-Project/Bumblebee/issues/816

or ma carte est une intel, pas une nvidia. Je vais essayer le 1 mais là
c'est quasi-certain que je ne profiterai pas de l'accélération graphique
bien que «ça marche».

Au passage tu n'as pas eu de carte nvidia à un moment sur ce pc ?
Ça donne quoi la commande glxinfo sur ce pc ?
Si tu peux nous poster aussi le log dans le fichier xorg.0.log ?
Il se trouve dans le répertoire /var/log/
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Pierre www.aribaut.com
Le #26505448
Le 14/01/2019 à 12:14, Sergio a écrit :
Le 14/01/2019 à 11:56, Jo Engo a écrit :
Le Mon, 14 Jan 2019 09:51:29 +0100, Pierre www.aribaut.com a écrit :

Je suis d'autant plus perplexe et circonspect (je parie 10 cent que c'est
un outil - propriétaire - nvidia, or je préfère ce qui est libre) qu'il
me propose :
   Sélection   Chemin                     Priorité  État
------------------------------------------------------------
* 0            /usr/lib/nvidia             100       mode automatique
   1            /usr/lib/mesa-diverted      5         mode manuel
   2            /usr/lib/nvidia             100       mode manuel
   3            /usr/lib/nvidia/bumblebee   95        mode manuel
or ma carte est une intel, pas une nvidia. Je vais essayer le 1 mais là
c'est quasi-certain que je ne profiterai pas de l'accélération graphique
bien que «ça marche».

Pour info, bumblebee est le pilote Linux (libre) pour utiliser la techno
"Optimus" de NVIDIA.
Optimus consiste à utiliser (sur un portable) soit la carte graphique
Intel, soit la NVidia, suivant les besoins.
cf https://doc.ubuntu-fr.org/bumblebee
Note: Avant de se lancer dans des manips compliquées, il est très
intéressant d'utiliser un moteur de recherche pour savoir si quelqu'un
ne l'a pas déjà fait...

Tiens je vois qu'il y a son message d'erreur dans la doc :
Xlib: extension "GLX" missing on display ":0"
https://doc.ubuntu-fr.org/bumblebee#les_effets_3d_ne_fonctionnent_pas_je_suis_redirige_vers_unity_2d_ou_gnome_classic_au_lieu_d_unity_3d_ou_gnome_shell_j_ai_les_messages_d_erreurs_suivants
Ils disent de faire :
sudo apt-get install --reinstall libgl1-mesa-glx bumblebee-nvidia
Mais la question que je me pose, est-ce qu'il a déjà utilisé une carte
nvidia sur ce pc ?
Peut-être que cela pourrait expliquer ce message d'erreur si il en a
utilisé une et qu'elle n'est plus présente.
Ou alors il a peut-être installé un driver Nvidia sans faire gaffe.
C'est arrivé à un gars ici, avec la même carte intel que Jo Engo et la
même erreur qu'il a aujourd'hui, il avait installé un driver Nvidia à un
moment, et il avait oublié qu'il avait installé un pilote Nvidia :
https://ubuntuforums.org/showthread.php?t01433
cf. réponse :
It means you tried to install the nvidia driver, and it overwrote the
open-source version of libglx.so with the proprietary nvidia version, so
you need to reinstall the open-source mesa stack.
Try this:
Code:
sudo nvidia-settings --uninstall
sudo apt-get install --reinstall xserver-xorg-video-intel
libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg
Reboot.
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Jo Engo
Le #26505476
Le Mon, 14 Jan 2019 12:28:30 +0100, Pierre www.aribaut.com a écrit :
sudo nvidia-settings --uninstall sudo apt-get install --reinstall
xserver-xorg-video-intel libgl1-mesa-glx libgl1-mesa-dri
xserver-xorg-core sudo dpkg-reconfigure xserver-xorg Reboot.

Je n'ai pas ni même eu sur cette machine une carte nvidia, à moins que
lspci me mente et que la carte «interne» est bien une intel mais la carte
externe une nvidia, or ça m'étonnerait. Je n'ai absolument rien fait
(avant tout à l'heure) pour «installer» une carte nvidia, c'est juste Xorg
qui dépend par cascade des drivers nvidia. J'ai envie de les virer si
c'est ça qui fout la zone ainsi que tous les drivers d'autres cartes que
la/les mienne/s. Bref, ça me semble correct, et après la 1ère manip je
vais faire la seconde (celle ci-dessus). Le reboot me semble de trop, il
s'agit a priori de redémarrer le serveur X mais bon au point où j'en suis…

--
L'expérience est le nom que chacun donne à ses erreurs.
-+- Oscar Wilde -+-
Jo Engo
Le #26505479
Le Mon, 14 Jan 2019 12:28:30 +0100, Pierre www.aribaut.com a écrit :
sudo nvidia-settings --uninstall


ça me semble pas très debian, ça : ça signifie que le cujus a installé le
blob depuis le site nvidia
nvidia-settings(1) General Commands Manual nvidia-
settings(1)
NAME
nvidia-settings - configure the NVIDIA graphics driver
SYNOPSIS
nvidia-settings [options]
nvidia-settings [options] --no-config
nvidia-settings [options] --load-config-only
nvidia-settings [options] {--query=attr | --assign=attr=value} ...
nvidia-settings [options] --glxinfo
pas de trace de ce --uninstall, qu'est-ce à dire ?
--
Il n'y a pas la preuve que la puce qui vit sur la souris craigne le
chat.
-+- Henri Michaux -+-
Jo Engo
Le #26505481
Le Mon, 14 Jan 2019 12:16:47 +0100, Pierre www.aribaut.com a écrit :
Au passage tu n'as pas eu de carte nvidia à un moment sur ce pc ?

Non, en aucun cas.
Ça donne quoi la commande glxinfo sur ce pc ?

42 fois l'erreur ci-dessus (1 fois par test)
Si tu peux nous poster aussi le log dans le fichier xorg.0.log ? Il se
trouve dans le répertoire /var/log/

vraiment ? j'aurais juré qu'il était dans le répertoire /etc/mess/brothel
en tout cas Xorg.0.log se trouve bien dans /var/log/ (quelque part c'est
logique, mais xorg.0.log doit bel et bien se trouver dans /etc/brothel/
mess tu veux en faire quoi ?mais je ne vais pas l'y chercher trève de
plaisanterie
Je passe les simples infos (juste les WW et les EE, donc)
[ 148.043] (WW) Falling back to old probe method for fbdev

[ 157.255] (EE) Failed to initialize GLX extension (Compatible NVIDIA X
driver not found)

[ 72195.147] (EE) client bug: timer event1 middlebutton: offset negative
(-125ms)
[ 72436.689] (EE) client bug: timer event1 keyboard: offset negative
(-34ms)
[ 72436.719] (EE) client bug: timer event1 keyboard: offset negative
(-31ms)

[ 84967.996] (EE) client bug: timer event1 middlebutton: offset negative
(-35ms)
(plein comme ça)
(that's all folk)
--
Nos logiciels sont extrêmement petits en taille car en format MultiDeskOS.
-- Jayce - CQFD. --
Jo Engo
Le #26505493
Le Mon, 14 Jan 2019 12:16:47 +0100, Pierre www.aribaut.com a écrit :
Si tu peux nous poster aussi le log dans le fichier xorg.0.log ?

Non, je ne peux pas, même après correction, ça prend trop de place. Sinon
ça a été utile (quand j'ai su ce qu'il fallait chercher :
$ grep -n -A 3 glx Xorg.0.log
Quine ! (bingo en bon français)
50:[ 142.214] (II) LoadModule: "glx"
51:[ 142.418] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
52:[ 146.808] (II) Module glx: vendor="NVIDIA Corporation"
53-[ 146.808] compiled for 4.0.2, module version = 1.0.0
54-[ 146.808] Module class: X.Org Server Extension
55-[ 146.818] (II) NVIDIA GLX Module 390.87 Tue Aug 21 16:10:56 PDT
2018
--
Sans l'illusion, où irons-nous ?
-+- Honoré de Balzac -+-
Jo Engo
Le #26505517
Le Mon, 14 Jan 2019 18:49:02 +0100, Pierre www.aribaut.com a écrit :
sudo nvidia-settings --uninstall

Cette option (--uninstall) n'est pas ocumentée (bis)

--
Un gosse puant, jeune, a deux gnons.
Coutume ? Ouais, chose invérifiable !
-- Esposito-Farese, Gilles
Publicité
Poster une réponse
Anonyme