choix de formule conditions multiples

Le
bequet
Bonjour,

Soit le problème suivant:

si hypothèse A, condition A1, appliquer formule 1
si hypothèse A, condition A2, appliquer formule 2
si hypothèse B, condition B1, appliquer formule 3
si hypothèse B, condition B2, appliquer formule 4
si hypothèse B, condition B3, appliquer formule 5

Comment formuler cela sous excell?

la formule SI ne me paraît pas adaptée
la fonction Recherchev ne semble pas fonctionner avec les formules mais
seulement avec les valeurs?

merci de me communiquer votre solution.

  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
AV
Le #1857813
Il serait bon de préciser un peu plus au travers d'un exemple... !

AV
bequet
Le #1857809
si abattement 875 375
âge < 10 formule1 formule 2 âge <5
âge >10 formule3 formule 4 âge >5 et <15
formule 5 âge >15


Il serait bon de préciser un peu plus au travers d'un exemple... !

AV





AV
Le #1861159
si abattement 875 375
âge < 10 formule1 formule 2 âge <5
âge >10 formule3 formule 4 âge >5 et <15
formule 5 âge >15


Regrets mais pour moi c'est totalement illisible....!
AV

® © ¿
Le #1860089
pfff....
;o)))
pour les tranches, je pense avoir compris ça ???
=CHOISIR(MIN(6;1+(A1/5));"-5";"5-10";"10-15";"15-20";"20-
25";"25+")

mais je suis abattu concernant l'abattement ????

madame Soleil à laissé des séquelles....


@+


-----Message d'origine-----
si abattement 875 375
âge < 10 formule1 formule 2 âge <5
âge >10 formule3 formule 4 âge >5 et <15
formule 5
âge >15



Regrets mais pour moi c'est totalement illisible....!
AV


.




bequet
Le #1860081
Désolé si l'explication mathématique n'est pas compréhensible,. Je le dirais
en français.

Je doit calculer l'abattement à recevoir sur les droits de succession pour
une personne déterminée.
Si la part qu'elle hérite est inférieure à 125 000 EUR et que son âge est
inférieur à 10 ans je dois appliquer la formule un. S'il est supérieur à 10
ans je dois appliquer la formule numéro 2
Si la part qu'elle hérite est supérieure à 125 000 EUR et que son âge est
inférieur à 5 ans, je dois appliquer la formule numéro trois;
s'il est compris entre 5 et 15 ans, on applique la formule quatre et s'il
est supérieur à quinze, la formule cinq.

la formule 1 est à titre exemplatif (âge*2500*5%)
2 ((âge-10)*2500*7%)+1250
on saute en effet de tranche d'imposition

Nous nous trouvons devant un choix multiples, dont le résultat détermine la
formule à choisir et à appliquer.

Merci de proposer votre solution.


pfff....
;o)))
pour les tranches, je pense avoir compris ça ???
=CHOISIR(MIN(6;1+(A1/5));"-5";"5-10";"10-15";"15-20";"20-
25";"25+")

mais je suis abattu concernant l'abattement ????

madame Soleil à laissé des séquelles....


@+


-----Message d'origine-----
si abattement 875 375
âge < 10 formule1 formule 2 âge <5
âge >10 formule3 formule 4 âge >5 et <15
formule 5
âge >15



Regrets mais pour moi c'est totalement illisible....!
AV


.







AV
Le #1858125
Désolé si l'explication mathématique n'est pas compréhensible,.


Achhh... Je savais bien que je valais pas un clou en maths !

Merci de proposer votre solution.


=SI(ET(MontantHéritage<125000;Age<10);Calcul1;SI(ET(MontantHéritage<125000;Age> 10);Calcul2;SI(ET(MontantHéritage>125000;Age<5);Calcul3;SI(ET(MontantHéritage<12
5000;Age<;Age>=5);Calcul4;SI(ET(MontantHéritage<125000;Age>15);Calcul5;"cas
non envisagé !")))))

Ceci dit (ou plutôt écrit), il me semble qu'il manque un certain nombre de cas
non envisagés !

AV

bequet
Le #1858046
merci.

la programmation on goto me paraissait plus simple


Désolé si l'explication mathématique n'est pas compréhensible,.


Achhh... Je savais bien que je valais pas un clou en maths !

Merci de proposer votre solution.


=SI(ET(MontantHéritage<125000;Age<10);Calcul1;SI(ET(MontantHéritage<125000;Age> > 10);Calcul2;SI(ET(MontantHéritage>125000;Age<5);Calcul3;SI(ET(MontantHéritage<12
5000;Age<;Age>=5);Calcul4;SI(ET(MontantHéritage<125000;Age>15);Calcul5;"cas
non envisagé !")))))

Ceci dit (ou plutôt écrit), il me semble qu'il manque un certain nombre de cas
non envisagés !

AV






Poster une réponse
Anonyme