choix de l'utilisateur dans pkexec

Le
hamster
J'ai un ordi avec debian 10, un compte pour l'utilisateur toto, un
compte pour l'utilisateur tata qui est administrateur et bien sur le
compte root. Quand je suis logué sous l'utilisateur toto (non
administrateur) et que je lance synaptic en passant par le menu (ce qui
lance la commande synaptic-pkexec), ca ouvre une fenetre qui me demande
le mot de passe de l'utilisateur tata au lieu du mot de passe de root.
Je trouve pas comment rétablir le fonctionnement normal, c'est a dire
que ca me demande le mot de passe root.

J'ai essayé de désactiver le compte tata, j'ai cherché dans le man et
sur le web, mais je suis toujours autant le bec dans l'eau. Si quelqu'un
a un tuyau a me donner je suis preneur.

Merci d'avance.
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Bernard Schoenacker
Le #26561477
----- Mail original -----
De: "hamster" À: "debian-user-french" Envoyé: Mardi 1 Décembre 2020 03:04:50
Objet: choix de l'utilisateur dans pkexec
J'ai un ordi avec debian 10, un compte pour l'utilisateur toto, un
compte pour l'utilisateur tata qui est administrateur et bien sur le
compte root. Quand je suis logué sous l'utilisateur toto (non
administrateur) et que je lance synaptic en passant par le menu (ce
qui
lance la commande synaptic-pkexec), ca ouvre une fenetre qui me
demande
le mot de passe de l'utilisateur tata au lieu du mot de passe de
root.
Je trouve pas comment rétablir le fonctionnement normal, c'est a dire
que ca me demande le mot de passe root.
J'ai essayé de désactiver le compte tata, j'ai cherché dans le man et
sur le web, mais je suis toujours autant le bec dans l'eau. Si
quelqu'un
a un tuyau a me donner je suis preneur.
Merci d'avance.

bonjour,
pourrais tu simplement désactiver l'accès de l'utilisateur via
sudo et revenir Í  la base en employant su -
merci pour ton aimable attention
bien Í  toi
Bernard
steve
Le #26561478
Salut,
Le 01-12-2020, Í  03:04:50 +0100, hamster a écrit :
J'ai un ordi avec debian 10, un compte pour l'utilisateur toto, un
compte pour l'utilisateur tata qui est administrateur et bien sur le
compte root. Quand je suis logué sous l'utilisateur toto (non
administrateur) et que je lance synaptic en passant par le menu (ce qui
lance la commande synaptic-pkexec), ca ouvre une fenetre qui me demande
le mot de passe de l'utilisateur tata au lieu du mot de passe de root.
Je trouve pas comment rétablir le fonctionnement normal, c'est a dire
que ca me demande le mot de passe root.

En fait c'est le fonctionnement normal depuis deux ou trois versions de
Debian (squeeze peut-être).
«Â Dans le cas o͹ vous ne saisissez pas de mot de passe pour le
superutilisateur, ce compte sera désactivé. En revanche, le paquet sudo
sera installé pour permettre d'effectuer les tÍ¢ches d'administration du
nouveau système, et le premier utilisateur créé sera autorisé Í  utiliser
la commande sudo. »
Voir https://www.debian.org/releases/stable/amd64/ch06s03.fr.html#di-user-setup
J'ai essayé de désactiver le compte tata, j'ai cherché dans le man et
sur le web, mais je suis toujours autant le bec dans l'eau. Si quelqu'un
a un tuyau a me donner je suis preneur.

Essaie de donner un mot de passe Í  root avec
sudo passwd root
(tu devras entrer le mot de passe de tata)
Hope it helps.
steve
hamster
Le #26561481
Le 01/12/2020 Í  05:39, steve a écrit :
Salut,
Le 01-12-2020, Í  03:04:50 +0100, hamster a écrit :
J'ai un ordi avec debian 10, un compte pour l'utilisateur toto, un
compte pour l'utilisateur tata qui est administrateur et bien sur le
compte root. Quand je suis logué sous l'utilisateur toto (non
administrateur) et que je lance synaptic en passant par le menu (ce qui
lance la commande synaptic-pkexec), ca ouvre une fenetre qui me demande
le mot de passe de l'utilisateur tata au lieu du mot de passe de root.
Je trouve pas comment rétablir le fonctionnement normal, c'est a dire
que ca me demande le mot de passe root.

En fait c'est le fonctionnement normal depuis deux ou trois versions de
Debian (squeeze peut-être).
«Â Dans le cas o͹ vous ne saisissez pas de mot de passe pour le
superutilisateur, ce compte sera désactivé. En revanche, le paquet sudo
sera installé pour permettre d'effectuer les tÍ¢ches d'administration du
nouveau système, et le premier utilisateur créé sera autorisé Í  utiliser
la commande sudo. »

J'ai donné un mot de passe au compte root a l'install. La commande su -
fonctionne. Le premier utilisateur créé n'est pas administrateur et
n'est pas sudoer. C'est le deuxième utilisateur créé a qui j'ai donné
les droits d'administration, et depuis ce moment le lancement de
synaptic me demande le mot de passe du deuxième utilisateur alors qu'il
me demandait le mot de passe de root avant.
steve
Le #26561486
Le 01-12-2020, Í  07:08:06 +0100, hamster a écrit :
J'ai donné un mot de passe au compte root a l'install. La commande su -
fonctionne. Le premier utilisateur créé n'est pas administrateur et
n'est pas sudoer. C'est le deuxième utilisateur créé a qui j'ai donné
les droits d'administration, et depuis ce moment le lancement de
synaptic me demande le mot de passe du deuxième utilisateur alors qu'il
me demandait le mot de passe de root avant.

Désolé j'avais mal compris.
Manifestement synaptic se mélange les pinceaux depuis la création du
second utilisateur. Peut-être qu'en lançant synaptic avec strace tu
pourrais déterminer le problème ?
Gaëtan PERRIER
Le #26561529
--=-aEwwSZWFEGvJUAPJtYe6
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
Le mardi 01 d̓©cembre 2020 ̓  08:51 +0100, steve a ̓©crit͂ :
Le 01-12-2020, ̓  07:08:06 +0100, hamster a ̓©crit :
J'ai donn̓© un mot de passe au compte root a l'install. La commande su -
fonctionne. Le premier utilisateur cr̓©Íƒ© n'est pas administrateur et
n'est pas sudoer. C'est le deuxi̓¨me utilisateur cr̓©Íƒ© a qui j'ai donn̓©
les droits d'administration, et depuis ce moment le lancement de
synaptic me demande le mot de passe du deuxi̓¨me utilisateur alors qu'il
me demandait le mot de passe de root avant.

D̓©sol̓© j'avais mal compris.
Manifestement synaptic se m̓©lange les pinceaux depuis la cr̓©ation du
second utilisateur. Peut-̓ªtre qu'en lan̓§ant synaptic avec strace tu
pourrais d̓©terminer le probl̓¨me
͂ ?


Bonjour,
J'ai l'impression que synaptic (mais ce ne doit pas ̓ªtre lui en fait) regarde
s'il y a un sudouser et l'utilise par d̓©faut.
Ga̓«tan
--=-aEwwSZWFEGvJUAPJtYe6
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part
Content-Transfer-Encoding: 7bit
-----BEGIN PGP SIGNATURE-----
iQEzBAABCgAdFiEEd7zcTjS9jiJYzB4MTEjQapSg6ZkFAl/GLJIACgkQTEjQapSg
6Zlc8gf9GU2BdB/VA5HUpEMNeUvi8IApSBJAteR9Cn0vXq6RqdQWbo3K0cD2qygi
C9jaSYnLINGmYkqwayvPZeKtn9UWk3xLPKSYddSjSjfjyDTmZgOxHTSwqjGp2IeM
ZS2XnfX9wQhrI6YMc2UzBd0B/fo6guV+dsKMOgR1/mKlLsNHvQ2pRyCtfucutMrA
NrtzgYOf4UxfQzEkt2UmaVqJuQyWot8Q1HrGcyk9/h0hJQdrPNSpOBFTU1XH7f06
RHwe0W1iep+7Nazj1Ry3SVEtQ6rwkemTAw4ZEpyAU7fiZeWzNRwSm/XfySsgPQLm
52GLOzhRyVHeIceZliW6Q2peqVun5Q==LE0M
-----END PGP SIGNATURE-----
--=-aEwwSZWFEGvJUAPJtYe6--
Poster une réponse
Anonyme