clavier français et sway

Le
Stéphane CARPENTIER
Bonjour,

est-ce qu'il y en a qui maÍ®trisent sway ici ? Avant d'étaler toutes mes
configs, je préfère me renseigner.

D'abord, avec i3wm, j'ai tout qui marche bien, quand je fais
[Windows]+[3] je bascule sur le 3ième bureau virtuel. Avec sway, il faut que
je fasse [Windows]+[Shift]+[3]. Ce qui ne me plaͮt pas parce que d'abord
c'est plus compliqué et ensuite, c'est supposé être utiliser pour
déplacer les applications sur les bureaux virtuels. Mapper sur ["] me
semble plus joueur, mapper sur [F3] me semble préférable mais je préfère
comprendre.

En passant de i3wm Í  sway, je suis passé du clavier français au clavier
anglais, mais j'ai tout bien configuré pour repasser au français. Sauf
que quand je vois ça (dans sayw pas dans i3wm ou c'est bien fr et oss) :
(stef)> setxkbmap -print -verbose 10
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev
Trying to load rules file /usr/share/X11/xkb/rules/evdev
Success.
Applied rules from evdev:
rules: evdev
model: pc105
layout: us
Trying to build keymap using the following components:
keycodes: evdev+aliases(qwerty)
types: complete
compat: complete
symbols: pc+us+inet(evdev)
geometry: pc(pc105)
xkb_keymap {
xkb_keycodes { include "evdev+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include "pc+us+inet(evdev)" };
xkb_geometry { include "pc(pc105)" };
};

Je me dis qu'il y a peut-être un truc pourri qui traine.
Mais applis sont bien mappées sur le clavier français (c'est facile Í 
voir) et sway aussi (j'ai mappé le lancement d'une application sur
[Windows]+[m] et ça marche).

Je ne sais pas si c'est ça qui pose problème ou si c'est une
coincidence. Une idée ?

--
Si vous avez du temps Í  perdre :
https://scarpet42.gitlab.io
  • Partager ce contenu :
Vos réponses Page 1 / 2
Trier par : date / pertinence
Stéphane CARPENTIER
Le #26573585
Le 14-05-2021, Stéphane CARPENTIER
Je ne sais pas si c'est ça qui pose problème ou si c'est une
coincidence. Une idée ?


Bon, OK, c'est une fois que j'ai envoyé mon message que j'ai trouvé.
J'aurais dÍ» poser ma question plus tÍ´t, j'aurais trouvé plus vite.
Pour info, ça doit marcher, j'essaye :
bindsym $mod+ampersand workspace 1
bindsym $mod+eacute workspace 2
bindsym $mod+quotedbl workspace 3
bindsym $mod+apostrophe workspace 4
bindsym $mod+parenleft workspace 5
bindsym $mod+minus workspace 6 # +section on Apple keyboards
bindsym $mod+egrave workspace 7
bindsym $mod+underscore workspace 8 # +exclam on Apple keyboards
bindsym $mod+ccedilla workspace 9
bindsym $mod+agrave workspace 10
--
Si vous avez du temps Í  perdre :
https://scarpet42.gitlab.io
Stéphane CARPENTIER
Le #26573587
Le 14-05-2021, Stéphane CARPENTIER
Le 14-05-2021, Stéphane CARPENTIER
Je ne sais pas si c'est ça qui pose problème ou si c'est une
coincidence. Une idée ?

Bon, OK, c'est une fois que j'ai envoyé mon message que j'ai trouvé.
J'aurais dÍ» poser ma question plus tÍ´t, j'aurais trouvé plus vite.
Pour info, ça doit marcher, j'essaye :
bindsym $mod+ampersand workspace 1
bindsym $mod+eacute workspace 2
bindsym $mod+quotedbl workspace 3
bindsym $mod+apostrophe workspace 4
bindsym $mod+parenleft workspace 5
bindsym $mod+minus workspace 6 # +section on Apple keyboards
bindsym $mod+egrave workspace 7
bindsym $mod+underscore workspace 8 # +exclam on Apple keyboards
bindsym $mod+ccedilla workspace 9
bindsym $mod+agrave workspace 10

OK, ça marche, mais ils ne précisent pas que ça empiète sur la
configuration du scratchpad, j'ai désactivé scratchpad que je n'ai
jamais utilisé, je verrai plus tard pour l'utiliser.
Ça n'empêche que ça me gonfle d'avoir du "us" qui apparaÍ®t dans ma
configuration.
En répondant depuis sway, je remarque que gvim a besoin d'être en plein
écran pour s'afficher initialement : ça va pas me plaire longtemps. Il
faut que je vois comment changer ça parce que pour répondre avec slrn il
faut que je déplace gvim vers un autre bureau.
--
Si vous avez du temps Í  perdre :
https://scarpet42.gitlab.io
Christophe PEREZ
Le #26573589
Le Fri, 14 May 2021 18:23:08 +0000, Stéphane CARPENTIER a écrit :
Bon, OK, c'est une fois que j'ai envoyé mon message que j'ai trouvé.

Un grand classique !
Et si tu postes plus tÍ´t, tu te reproches de ne pas avoir assez cherché
avant...
Le fameux cercle vicieux.
william
Le #26573592
On 2021-05-14, Stéphane CARPENTIER
OK, ça marche, mais ils ne précisent pas que ça empiète sur la
configuration du scratchpad, j'ai désactivé scratchpad que je n'ai
jamais utilisé, je verrai plus tard pour l'utiliser.
Ça n'empêche que ça me gonfle d'avoir du "us" qui apparaÍ®t dans ma
configuration.
En répondant depuis sway, je remarque que gvim a besoin d'être en plein
écran pour s'afficher initialement : ça va pas me plaire longtemps. Il
faut que je vois comment changer ça parce que pour répondre avec slrn il
faut que je déplace gvim vers un autre bureau.

Ce ne serait pas plus simple d'utiliser vim avec slrn ?
Stéphane CARPENTIER
Le #26573595
Le 14-05-2021, Christophe PEREZ
Le Fri, 14 May 2021 18:23:08 +0000, Stéphane CARPENTIER a écrit :
Bon, OK, c'est une fois que j'ai envoyé mon message que j'ai trouvé.

Un grand classique !

Oui, mais c'est plus drÍ´le quand ça arrive aux autres.
--
Si vous avez du temps Í  perdre :
https://scarpet42.gitlab.io
Stéphane CARPENTIER
Le #26573596
Le 14-05-2021, william
On 2021-05-14, Stéphane CARPENTIER
OK, ça marche, mais ils ne précisent pas que ça empiète sur la
configuration du scratchpad, j'ai désactivé scratchpad que je n'ai
jamais utilisé, je verrai plus tard pour l'utiliser.
Ça n'empêche que ça me gonfle d'avoir du "us" qui apparaÍ®t dans ma
configuration.
En répondant depuis sway, je remarque que gvim a besoin d'être en plein
écran pour s'afficher initialement : ça va pas me plaire longtemps. Il
faut que je vois comment changer ça parce que pour répondre avec slrn il
faut que je déplace gvim vers un autre bureau.

Ce ne serait pas plus simple d'utiliser vim avec slrn ?

Je ne sais pas, les deux dans le même terminal ? Ça veut dire que slrn
s'efface pour laisser la place Í  vim ? Sinon, s'il faut ouvrir vim dans
un autre terminal, ce ne sera pas plus simple.
De toutes façons, contrairement Í  ce que je croyais, c'est pas un problème de
plein écran mais de redimensionnement. Si j'ouvre gvim en plein écran,
ça fait pareil, c'est une fois qu'il est redimensionné que c'est bon.
Donc, il faut quand même que je trouve parce que je n'utilises pas gvim
qu'avec slrn.
--
Si vous avez du temps Í  perdre :
https://scarpet42.gitlab.io
Christophe PEREZ
Le #26573602
Le Fri, 14 May 2021 20:26:49 +0000, Stéphane CARPENTIER a écrit :
Oui, mais c'est plus drÍ´le quand ça arrive aux autres.

:D
Stéphane CARPENTIER
Le #26573679
Le 14-05-2021, Stéphane CARPENTIER
De toutes façons, contrairement Í  ce que je croyais, c'est pas un problème de
plein écran mais de redimensionnement. Si j'ouvre gvim en plein écran,
ça fait pareil, c'est une fois qu'il est redimensionné que c'est bon.
Donc, il faut quand même que je trouve parce que je n'utilises pas gvim
qu'avec slrn.

OK, j'ai trouvé et le problème ne vient pas de moi, mais est bien
général.
Donc, soit attendre que sway/wayland soit mature, soit passer Í  neovim.
J'hésite parce que c'est l'un des deux derniers trucs qui me gênent avec
sway. L'autre, c'est le focus. Ils disent que c'est mieux parce qu'il
n'y a plus Í  utiliser picom, mais picom avait un super avantage de
mettre un peu de transparence sur les fenêtres qui n'avaient pas le
focus pour m'aider Í  repérer facilement la fenêtre qui a le focus. Et
lÍ , j'ai du mal Í  voir comment faire.
--
Si vous avez du temps Í  perdre :
https://scarpet42.gitlab.io
Jo Engo
Le #26573682
Le Sun, 16 May 2021 15:31:34 +0000, Stéphane CARPENTIER a écrit :
sway/wayland


Je ne trouve pas ton truc dans le ouaibe, ça me renvoie Í  Office365
supersedes, il a fallu que je poste pour me rendre compte de mon erreur :
il fallait que je cherche swaywm, bien sͻr.
--
X et sa nouvelle politique de recrutement dans les ZEP.
-- Breton, J.C.
Stéphane CARPENTIER
Le #26573689
Le 16-05-2021, Jo Engo
Le Sun, 16 May 2021 15:31:34 +0000, Stéphane CARPENTIER a écrit :
sway/wayland

Je ne trouve pas ton truc dans le ouaibe, ça me renvoie Í  Office365
supersedes, il a fallu que je poste pour me rendre compte de mon erreur :
il fallait que je cherche swaywm, bien sͻr.

Je ne sais pas qui a choisi le nom en premier pour sway, mais c'est
juste horrible. Toutes les recherches sur le web doivent se faire avec
« -microsoft » pour pouvoir trouver quelque chose qui corresponde. parce
que swaywm ne va pas toujours être complet.
--
Si vous avez du temps Í  perdre :
https://scarpet42.gitlab.io
Poster une réponse
Anonyme