Comment faire fonctionner le wifi sous linux mint 18.2/18.3 avec carte realtek rtl8723be et kernel 4.13 qui coupait le wif i (problème résolu)

Le
Pierre www.zetrader.fr
Coucou les gars, j'avais pas envie de rester sur un problème non résolu,
donc j'ai retenté une fois de plus, et cette fois j'ai trouvé comment
faire marcher le wifi pour la carte realtek rtl8723be avec les dernières
versions de kernel (4.13) proposés par Linux Mint :)
Exposé du problème :
- Du kernel 4.8 au kernel 4.10.0-42 le wifi fonctionnait, toutes les
mises à jour de kernel se sont bien passé jusqu'au kernel 4.10.0-42,
aucun problème sur le wifi, 6 mois de mises à jour sans problème.
- En mettant à jour le kernel à la version 4.13 suite aux propositions
de mises à jour de linux mint : plus d'accès au wifi, plus moyen de se
connecter, j'ai alors essayé plusieurs versions 4.13.0-21, 4.13.0-26,
4.13.0-31, et même 4.14.8 et aujourd'hui même 4.13.0-32 (dernière
version proposée par linux mint), même problème pour tous, cela me coupe
l'accès au wifi.

Au détour de mes recherches, j'ai vu un gars qui disait qu'un truc avait
fonctionné pour lui sur Debian, c'était encore différent de ce que
j'avais fait pour stabiliser ma connexion wifi sur linux mint (au départ
il y a environ 6 mois de ça, ma connexion était instable avec cette
carte réseau sous linux mint, problème résolu assez rapidement après
l'installation d'un module).
Voici donc la démarche à suivre (avant de tester le kernel 4.13 puisque
cela coupe l'accès à internet) :
1) aller sur https://github.com/roopansh/rtl8723be_wifi/
2) télécharger le zip "rtl8723be_wifi-master.zip"
3) le dézipper sur son disque dur
4) installer le kernel 4.13 et redémarrer
5) aller dans le répertoire rtl8723be_wifi-master que vous avez dézippé
sur le disque dur
6) lancer le script "rtl8723be.sh", dans la doc il est dit de faire la
commande "bash rtl8723be.sh" pour le lancer mais il m'a répondu "Please
run as root" donc il faut faire en fait "sudo bash rtl8723be.sh" (en
tout cas chez moi)

Ensuite voilà ce que cela a fait chez moi :
Removing rtl8723be module form the kernel
Entering /etc/modprobe.d/
Changing the rtl8723be settings
options rtl8723be fwlps=N ips=N ant_sel=1
Adding rtl8723be module back to the kernel
Return status 0

Et.magie le wifi s'est mis à fonctionner.
J'ai redémarré 2 fois pour voir si ce n'était pas temporaire ou si
j'allais avoir à nouveau le problème en relançant la session, ce n'est
pas temporaire cela fonctionne bien, pas de coupure pour le moment, cela
a l'air stable :)

Désactiver le module pour éventuellement en réactiver un plus adéquat ou
laisser un autre activé pour éviter tout conflit c'est l'hypothèse que
j'avais émise et qui m'a valu de me faire traiter de neuneu, finalement
c'était la bonne piste.
Merci quand même à ceux qui ont essayé de m'aider, sans m'insulter au
passage.
Si vous m'aviez dit les 6 points que je dis plus haut, là vous auriez pu
me prendre de haut, en attendant concrètement personne ne m'a donné la
solution, j'ai donc dû la trouver tout seul, donc pour ceux qui se
prennent pour Dieu sur ce forum, merci de rester humble, le neuneu sait
aussi résoudre ses problèmes jusqu'ici quand personne ne lui dit la
solution.
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pierre www.zetrader.fr
Le #26461485
Le 26/01/2018 à 13:45, Pierre www.zetrader.fr a écrit :
Coucou les gars, j'avais pas envie de rester sur un problème non résolu,
donc j'ai retenté une fois de plus, et cette fois j'ai trouvé comment
faire marcher le wifi pour la carte realtek rtl8723be avec les dernières
versions de kernel (4.13) proposés par Linux Mint :)
Exposé du problème :
- Du kernel 4.8 au kernel 4.10.0-42 le wifi fonctionnait, toutes les
mises à jour de kernel se sont bien passé jusqu'au kernel 4.10.0-42,
aucun problème sur le wifi, 6 mois de mises à jour sans problème.
- En mettant à jour le kernel à la version 4.13 suite aux propositions
de mises à jour de linux mint : plus d'accès au wifi, plus moyen de se
connecter, j'ai alors essayé plusieurs versions 4.13.0-21, 4.13.0-26,
4.13.0-31, et même 4.14.8 et aujourd'hui même 4.13.0-32 (dernière
version proposée par linux mint), même problème pour tous, cela me coupe
l'accès au wifi.
Au détour de mes recherches, j'ai vu un gars qui disait qu'un truc avait
fonctionné pour lui sur Debian, c'était encore différent de ce que
j'avais fait pour stabiliser ma connexion wifi sur linux mint (au départ
 il y a environ 6 mois de ça, ma connexion était instable avec cette
carte réseau sous linux mint, problème résolu assez rapidement après
l'installation d'un module).
Voici donc la démarche à suivre (avant de tester le kernel 4.13 puisque
cela coupe l'accès à internet) :
1) aller sur https://github.com/roopansh/rtl8723be_wifi/
2) télécharger le zip "rtl8723be_wifi-master.zip"
3) le dézipper sur son disque dur
4) installer le kernel 4.13 et redémarrer
5) aller dans le répertoire rtl8723be_wifi-master que vous avez dézippé
sur le disque dur
6) lancer le script "rtl8723be.sh", dans la doc il est dit de faire la
commande "bash rtl8723be.sh" pour le lancer mais il m'a répondu "Please
run as root" donc il faut faire en fait "sudo bash rtl8723be.sh" (en
tout cas chez moi)
Ensuite voilà ce que cela a fait chez moi :
Removing rtl8723be module form the kernel
Entering /etc/modprobe.d/
Changing the rtl8723be settings
options rtl8723be fwlps=N ips=N ant_sel=1
Adding rtl8723be module back to the kernel
Return status 0
Et....magie le wifi s'est mis à fonctionner.
J'ai redémarré 2 fois pour voir si ce n'était pas temporaire ou si
j'allais avoir à nouveau le problème en relançant la session, ce n'est
pas temporaire cela fonctionne bien, pas de coupure pour le moment, cela
a l'air stable :)
Désactiver le module pour éventuellement en réactiver un plus adéquat ou
laisser un autre activé pour éviter tout conflit c'est l'hypothèse que
j'avais émise et qui m'a valu de me faire traiter de neuneu, finalement
c'était la bonne piste.
Merci quand même à ceux qui ont essayé de m'aider, sans m'insulter au
passage.
Si vous m'aviez dit les 6 points que je dis plus haut, là vous auriez pu
me prendre de haut, en attendant concrètement personne ne m'a donné la
solution, j'ai donc dû la trouver tout seul, donc pour ceux qui se
prennent pour Dieu sur ce forum, merci de rester humble, le neuneu sait
aussi résoudre ses problèmes jusqu'ici quand personne ne lui dit la
solution.

Je tourne donc sous le noyau 4.13.0-32 qui contient les patchs pour les
dernières failles de sécurité, en résolvant le problème du wifi, je fais
d'une pierre deux coups :
1) avoir un kernel plus récent sans forcément passer à xubuntu 17.10.1
(c'était une éventualité pour contourner le problème)
2) avoir le kernel patché par rapport aux dernières failles de sécurité
(par rapport au navigateur et au microcode intel, c'était déjà fait, il
manquait le kernel qui va bien)
Voili Voilou, content d'avoir trouvé comment faire :)
Maintenant je peux attendre tranquillement la version 18.04 d'ubuntu et
variantes diverses (xubuntu 18.04, linux mint 19) ou tester xubuntu
17.10.1 si cela me chante en attendant, si j'ai un problème pour le
wifi, a priori cette même solution a des chances de marcher...
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Pierre www.zetrader.fr
Le #26461489
Le 26/01/2018 à 13:45, Pierre www.zetrader.fr a écrit :
Coucou les gars, j'avais pas envie de rester sur un problème non résolu,
donc j'ai retenté une fois de plus, et cette fois j'ai trouvé comment
faire marcher le wifi pour la carte realtek rtl8723be avec les dernières
versions de kernel (4.13) proposés par Linux Mint :)
Exposé du problème :
- Du kernel 4.8 au kernel 4.10.0-42 le wifi fonctionnait, toutes les
mises à jour de kernel se sont bien passé jusqu'au kernel 4.10.0-42,
aucun problème sur le wifi, 6 mois de mises à jour sans problème.
- En mettant à jour le kernel à la version 4.13 suite aux propositions
de mises à jour de linux mint : plus d'accès au wifi, plus moyen de se
connecter, j'ai alors essayé plusieurs versions 4.13.0-21, 4.13.0-26,
4.13.0-31, et même 4.14.8 et aujourd'hui même 4.13.0-32 (dernière
version proposée par linux mint), même problème pour tous, cela me coupe
l'accès au wifi.
Au détour de mes recherches, j'ai vu un gars qui disait qu'un truc avait
fonctionné pour lui sur Debian, c'était encore différent de ce que
j'avais fait pour stabiliser ma connexion wifi sur linux mint (au départ
 il y a environ 6 mois de ça, ma connexion était instable avec cette
carte réseau sous linux mint, problème résolu assez rapidement après
l'installation d'un module).
Voici donc la démarche à suivre (avant de tester le kernel 4.13 puisque
cela coupe l'accès à internet) :
1) aller sur https://github.com/roopansh/rtl8723be_wifi/
2) télécharger le zip "rtl8723be_wifi-master.zip"
3) le dézipper sur son disque dur
4) installer le kernel 4.13 et redémarrer
5) aller dans le répertoire rtl8723be_wifi-master que vous avez dézippé
sur le disque dur
6) lancer le script "rtl8723be.sh", dans la doc il est dit de faire la
commande "bash rtl8723be.sh" pour le lancer mais il m'a répondu "Please
run as root" donc il faut faire en fait "sudo bash rtl8723be.sh" (en
tout cas chez moi)
Ensuite voilà ce que cela a fait chez moi :
Removing rtl8723be module form the kernel
Entering /etc/modprobe.d/
Changing the rtl8723be settings
options rtl8723be fwlps=N ips=N ant_sel=1
Adding rtl8723be module back to the kernel
Return status 0
Et....magie le wifi s'est mis à fonctionner.
J'ai redémarré 2 fois pour voir si ce n'était pas temporaire ou si
j'allais avoir à nouveau le problème en relançant la session, ce n'est
pas temporaire cela fonctionne bien, pas de coupure pour le moment, cela
a l'air stable :)
Désactiver le module pour éventuellement en réactiver un plus adéquat ou
laisser un autre activé pour éviter tout conflit c'est l'hypothèse que
j'avais émise et qui m'a valu de me faire traiter de neuneu, finalement
c'était la bonne piste.
Merci quand même à ceux qui ont essayé de m'aider, sans m'insulter au
passage.
Si vous m'aviez dit les 6 points que je dis plus haut, là vous auriez pu
me prendre de haut, en attendant concrètement personne ne m'a donné la
solution, j'ai donc dû la trouver tout seul, donc pour ceux qui se
prennent pour Dieu sur ce forum, merci de rester humble, le neuneu sait
aussi résoudre ses problèmes jusqu'ici quand personne ne lui dit la
solution.

Pour ce qui est du script qu'on lance (j'en ai déjà utilisé il y a plus
de 10 ans lors de mes essais linux à l'époque, pour me faire des
raccourcis sur le bureau en .sh, je me souviens, c'était sympa), qui
n'est rien d'autre qu'une liste de commandes, en voici le contenu pour
mieux comprendre ce que cela fait (c'est quand même mieux que ce soit
sous forme de script que devoir faire ça à la main) :
*****
#!/bin/bash
if [ $EUID -ne 0 ]; then
echo "Please run as root"
exit
fi
echo "Removing rtl8723be module form the kernel"
modprobe -r rtl8723be
if [ "$?" = "0" ]; then
echo "Entering /etc/modprobe.d/"
echo "Changing the rtl8723be settings"
echo "options rtl8723be fwlps=N ips=N ant_sel=1" | sudo tee
/etc/modprobe.d/rtl8723be.conf
if [ "$?" = "0" ]; then
echo "Adding rtl8723be module back to the kernel"
echo "Return status 0"
else
echo "There were errors editing the module options"
echo "Process returned with some errors"
modprobe rtl8723be
return 1
fi
else
echo "There were errors removing the Module from the kernel"
echo "Process returned with some errors"
return 1
fi
modprobe rtl8723be
****
On constate une petite faute de frappe qu'on retrouve dans le process
que cela a fait sur mon ordi "Removing rtl8723be module *form* the
kernel", rien de grave, cela ne change rien au process, on pourrait
écrire n'importe quoi à la place, ou encore corriger cette faute de
frappe, c'est sans incidence sur le processus.
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
dyrmak
Le #26461488
En 79 lignes Pierre www.zetrader.fr a écrit
dans news:5a6b2421$0$3306$
le vendredi, 26 janvier 2018 à 13:50:40 :
Voili Voilou, content d'avoir trouvé comment faire :)
Maintenant je peux attendre tranquillement la version 18.04 d'ubuntu et
variantes diverses (xubuntu 18.04, linux mint 19) ou tester xubuntu
17.10.1 si cela me chante en attendant, si j'ai un problème pour le
wifi, a priori cette même solution a des chances de marcher...

Ce module fonctionne, soit, mais il n'est pas ripoliné, spectre_v2
menace toujours, sans parler de spectre_v1 qui est toujours la menace.
dyrmak
--
Dese prisa suba al bote se está yendo la marea
++++ --- ++++
Linux operating system
++++ --- ++++
Pierre www.zetrader.fr
Le #26461497
Le 26/01/2018 à 14:07, dyrmak a écrit :
En 79 lignes Pierre www.zetrader.fr a écrit
dans news:5a6b2421$0$3306$
le vendredi, 26 janvier 2018 à 13:50:40 :
Voili Voilou, content d'avoir trouvé comment faire :)
Maintenant je peux attendre tranquillement la version 18.04 d'ubuntu et
variantes diverses (xubuntu 18.04, linux mint 19) ou tester xubuntu
17.10.1 si cela me chante en attendant, si j'ai un problème pour le
wifi, a priori cette même solution a des chances de marcher...

Ce module fonctionne, soit, mais il n'est pas ripoliné, spectre_v2
menace toujours, sans parler de spectre_v1 qui est toujours la menace.
dyrmak

Mince, explique ?
J'ai fait maintenant toutes les mises à jour proposées contre les
dernières failles meltdown et spectre :
- google chrome
- firefox
- microcode intel
- kernel 4.13.0-32
Il date d'aujourd'hui ce kernel :
https://launchpad.net/ubuntu/+source/linux/4.13.0-32.35
Il fait partie des patchés :
https://usn.ubuntu.com/usn/usn-3548-2/
Qu'est-ce que je peux faire de plus maintenant ?
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Pierre www.zetrader.fr
Le #26461496
Le 26/01/2018 à 14:15, Pierre www.zetrader.fr a écrit :
Le 26/01/2018 à 14:07, dyrmak a écrit :
En 79 lignes Pierre www.zetrader.fr a écrit
dans news:5a6b2421$0$3306$
  le vendredi, 26 janvier 2018 à 13:50:40 :
Voili Voilou, content d'avoir trouvé comment faire :)
Maintenant je peux attendre tranquillement la version 18.04 d'ubuntu et
variantes diverses (xubuntu 18.04, linux mint 19) ou tester xubuntu
17.10.1 si cela me chante en attendant, si j'ai un problème pour le
wifi, a priori cette même solution a des chances de marcher...

Ce module fonctionne, soit, mais il n'est pas ripoliné, spectre_v2
menace toujours, sans parler de spectre_v1 qui est toujours la menace.
dyrmak

Mince, explique ?
J'ai fait maintenant toutes les mises à jour proposées contre les
dernières failles meltdown et spectre :
- google chrome
- firefox
- microcode intel
- kernel 4.13.0-32
Il date d'aujourd'hui ce kernel :
https://launchpad.net/ubuntu/+source/linux/4.13.0-32.35

Je lis pour ce kernel "SAUCE: x86/entry: Fix up retpoline assembler labels"
Ripoliner ça veut dire quoi au fait ?
Il fait partie des patchés :
https://usn.ubuntu.com/usn/usn-3548-2/
Qu'est-ce que je peux faire de plus maintenant ?

--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Jo Engo
Le #26461495
Le Fri, 26 Jan 2018 13:45:17 +0100, Pierre www.zetrader.fr a écrit :
en attendant concrètement personne ne m'a donné la solution,

On ne pouvait pas, toi tu voulais à tout cor installer xubuntu. Il a
fallu que j'insiste et te dise que ça risquait de planter idem pour que
tu changes de braquet.

--
Être fidèle, c'est, bien souvent, enchaîner l'autre.
-+- Sacha Guitry -+-
Jo Engo
Le #26461494
Le Fri, 26 Jan 2018 14:15:57 +0100, Pierre www.zetrader.fr a écrit :
failles meltdown et spectre :
- google chrome - firefox - microcode intel - kernel 4.13.0-32

Il manque juste le module real tech.

--
¡ aun une !
-- Schulz, Rémi
dyrmak
Le #26461493
En 33 lignes Pierre www.zetrader.fr a écrit
dans news:5a6b2a0e$0$3424$
le vendredi, 26 janvier 2018 à 14:15:57 :
Ce module fonctionne, soit, mais il n'est pas ripoliné, spectre_v2
menace toujours, sans parler de spectre_v1 qui est toujours la menace.
dyrmak

Mince, explique ?
J'ai fait maintenant toutes les mises à jour proposées contre les
dernières failles meltdown et spectre :
- google chrome
- firefox
- microcode intel
- kernel 4.13.0-32
Il date d'aujourd'hui ce kernel :
https://launchpad.net/ubuntu/+source/linux/4.13.0-32.35
Il fait partie des patchés :
https://usn.ubuntu.com/usn/usn-3548-2/
Qu'est-ce que je peux faire de plus maintenant ?

Ce kernel en effet semble ripoliné:
Pour en être sûr il faut la ligne de commande:
grep . /sys/devices/system/cpu/vulnerabilities/*
ça doit sortir:
/sys/devices/system/cpu/vulnerabilities/meltdown:Mitigation: PTI
/sys/devices/system/cpu/vulnerabilities/spectre_v1:Vulnerable
/sys/devices/system/cpu/vulnerabilities/spectre_v2:Mitigation: Full generic retp
Que je sache spectre_v1 n'a pas encore de contre-mesure.
dyrmak
--
El oso polar
++++ --- ++++
Linux operating system
++++ --- ++++
Pierre www.zetrader.fr
Le #26461501
Le 26/01/2018 à 14:25, Jo Engo a écrit :
Le Fri, 26 Jan 2018 13:45:17 +0100, Pierre www.zetrader.fr a écrit :
en attendant concrètement personne ne m'a donné la solution,

On ne pouvait pas, toi tu voulais à tout cor installer xubuntu. Il a
fallu que j'insiste et te dise que ça risquait de planter idem pour que
tu changes de braquet.

Oui j'avoue, merci ;)
Maintenant peut-être qu'en installant Xubuntu 17.10.1 cela aurait résolu
le problème aussi, en fonctionnant directement...ou pas.
Tant que je ne teste pas je ne peux pas savoir.
La bonne news c'est que si ça foire sous Xubuntu 17.10.1 maintenant a
priori j'ai une alternative.
Un truc m'a attiré l'attention dans le contenu du readme :
**NOTE : IT DOESN' WORK IN KALI-LINUX**
C'est la distribution où cette carte marche très bien d'entrée de jeu,
en l'ayant installé de ce que disait un gars en forum, il était surpris
que sous debian et dérivés il y ait des problèmes à résoudre avec cette
carte, alors que sous kali linux c'était nickel sans rien faire.
Cela laisse donc penser que le module par défaut pour cette carte est
meilleur dans Kali Linux ou plus compatible avec les kernels récents,
distribution visiblement faite pour tester des failles de sécurité,
simuler des attaques (j'en apprends au passage, je ne la connaissais pas).
Elle tourne sous 4.14 par défaut alors qu'aucun ubuntu ou dérivé n'a
cette version de kernel par défaut.
Je me demande si elle pourrait servir de distribution "classique" en
installant les paquets nécessaires, je suppose que oui ?
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Nicolas George
Le #26461526
"Pierre www.zetrader.fr" , dans le message
<snip>
Dis, le neuneu, tu vas respecter les chartes un jour ?
Publicité
Poster une réponse
Anonyme