Comment foutre en l'air des heures et des heures de travail avec WD !

Le
Val
Bonjour,

J'utilise Windev depuis sa version 4, c'est-à-dire depuis pas mal d'années
maintenant.
Pour cette raison et comme beaucoup de développeurs, j'ai été confronté à de
nombreuses galères et de déboires et, avec le temps, j'ai forcément
emmagasiné pas mal de petites astuces pour éviter les grosses gagades qui
peuvent foutre en l'air des heures, des jours voire même des semaines de
travail

En fait, aujourd'hui, je n'utilise même pas certains des composant fournis
avec Windev et que certains désignent, à juste titre, comme des gadgets et
qui sont censées rendre service au développeur, comme par exemple le module
de nettoyage des projets.
En effet, un jour je l'ai utilisé et pan il m'a fallu plusieurs heures
pour réparer les dégâts !
Ah oui question nettoyage, il nettoyait à fond
Ainsi, à l'époque où j'ai testé ce module et puisque les images affectées
directement via le Wlangage à des objets n'étaient pas détectés hop
elles passaient à la trappe.
Bien sur, cette gagade a certainement été corrigée depuis par les excellents
développeurs de PC-SOFT oui mais bon entre temps j'ai mis en oeuvre
une méthode de travail qui me permet de garder des dossiers propres
donc, je n'utilise pas ce nettoyeur.
Je n'utilise pas non plus, depuis la version 7.5, les outils de création
d'install qui, la dernière fois où je les ai testés, étaient encore buggés.
A cette époque, on ne pouvait même pas créer des raccourcis c'est dire

Bien sur, là aussi, ces gagades ont certainement été corrigées depuis par
les excellents développeurs de PC-SOFT oui mais bon entre temps
j'ai appris à utiliser des outils de création d'install (INNO SETUP en
particulier) fiables, personnalisables et avec lesquels on peut créer des
installs dignes de ce nom et avec des tailles "raisonnables".
Je n'utilise pas non plus les outils de sauvegarde puisque, la dernière fois
où je les ai utilisés (en version 7 il me semble), je me suis retrouvé avec
un pataquesse pas possible dans une analyse.
Bien sur, là aussi, ces gagades ont certainement été corrigées depuis par
les excellents développeurs de PC-SOFT oui mais bon entre temps,
j'ai mis en oeuvre une méthode de sauvegarde qui n'a jamais été mise en
défaut jusqu'à aujourd'hui !!

Et oui ce matin, je me suis retrouvé confronté à un problème très
particulier avec mon excellent WD11, payé cash !

Ainsi, dans un projet, quand j'ouvre une fenêtre du projet dans l'éditeur de
fenêtre, la fenêtre se charge, puis la boite de dialogue "PC SOFT Windev 11
a rencontré un problème et doit fermer. Nous vous prions etc " s'affiche.
Pour la signature de l'erreur, il est indiqué ceci:
AppName: windev11.exe AppVer: 11.0.0.4 ModName: msvcrt.dll
ModVer: 7.0.2600.2180 Offset: 00036fa3

Bien évidemment, Windev se ferme
Bon j'ai tout essayé, même de ré-installer WD rien à faire.

Donc, me dis-je la fenêtre est abîmée donc je vais restaurer une
sauvegarde de ladite fenêtre.
Comme je fais des sauvegardes 2 fois par jour, je ne suis pas inquiet
Et hop je restaure la fenêtre d'hier soir pareil impossible de
l'ouvrir
Donc, je restaure la fenêtre d'hier midi pareil impossible de
l'ouvrir
Et ainsi de suite jusqu'à la sauvegarde du 8 Janvier au soir
Oui oui il m'a fallu remonter jusqu'au 8 Janvier au soir pour récupérer
la fenêtre
Pfuu !!!!!
Quelle mer####
Bon, le problème, c'est qu'entre temps ladite fenêtre à été fortement
modifiée donc toutes les heures de travail correspondant à ces
modifications passent à la trappe !!

Donc, comme déjà dit . Pfuu !!!!!

Bon étant donné la situation, je me suis donc attaqué à la
reconstruction de la fenêtre et je ne vous cache pas mon humeur
Bon tout en bricolant, j'ai continué à cogiter sur les causes
Ce qui est étrange, me suis-je dit, c'est qu'il m'ait fallu remonter à une
sauvegarde du 8 janvier alors que, entre temps, la fenêtre avait été
modifiée.
Et oui quand j'examine mon planning de travail, je note que cette
fenêtre a été modifiée, pour la dernière fois, le 1 février donc cela
veut dire
qu'à cette date là, elle n'était pas abîmée donc pourquoi, aujourd'hui,
la sauvegarde du 1 février est abîmée, tout comme celle du 31 Janvier, du 30
Janvier, etc jusqu'au 8 janvier ?
Etrange hein ???
Peut-être, me suis-je dit, il y a un problème sur le disque dur
impossible, puisque les sauvegardes sont effectuées sur 3 disques distincts.
Bon ceci dit, on ne sait jamais donc j'ai vérifié les 3 disques
rien de spécial.

Bon alors j'ai continué à cogiter tout en marmonnant

Et oui étrange c'est pourquoi je me suis dit, à la manière de
l'inspecteur Bourrel, bon sang mais c'est bien sur c'est WD11 qui me
fout la me###"
Et là subitement, j'ai eu un éclair de lucité par le seul fait de m'être
exclamé "c'est WD11 qui me fout la me###".
Et oui en disant cela, j'ai trouvé ce qu'il s'est passé
Je m'explique.
En fait, dans un menu contextuel de la fenêtre, j'ai un champ image qui
contient l'icône du logiciel le truc tout simple quoi !
Et c'est là que cela coince !!!
Oui oui c'est là au niveau de l'icône.
En fait, la semaine passée, j'ai modifié l'icône du logiciel et, désormais,
le fichier icône est un fichier utilisant un groupes d'icônes
de différentes tailles et de différentes résolutions de couleurs (les icônes
ont été créés avec un outil classant les icônes par taille croissante et par
résolution de couleurs décroissante).
Or, figurez-vous que cet icône ne pose absolument aucun problème sauf
ici dans ce champ image de la fenêtre.
Ainsi, maintenant que cet icône est un fichier utilisant un groupes icônes,
la fenêtre plante quand je cherche à l'ouvrir dans l'éditeur de fenêtre.
Donc, il m'a suffit de supprimer cet icône pour pouvoir charger la fenêtre
et hop ça roule oui mais bon après 1/2 journée de boulot de
perdue !!

Pas mal
Merci Windev
Donc, faite gaffe si, comme moi, vous vous mettez en tête d'utiliser des
icônes qui utilisent des groupes icônes.
En effet si, quelque part dans votre projet, vous utilisez l'icône dans un
champ image (mais aussi dans un menu contextuel, sur un bouton, etc )
pensez à virer cet icône de là sinon plantage de WD11 garanti !!!
D'ailleurs, je ne sais pas si c'est ici ou en face, mais il y a quelques
jours il me semble avoir vu passer un fil ouvert par un développeur qui
avait un problème de plantage de WD et dans lequel la dll msvcrt.dll était
en cause
Peut-être était-il confronté à ce problème là si c'est le cas, il suffit
de supprimer l'icône

A+

Val
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
tarek.demiati
Le #14669781
"j'ai forcément
emmagasiné pas mal de petites astuces pour éviter les grosses gagades
qui
peuvent foutre en l'air des heures, des jours voire même des semaines
de
travail ... "

Tu devrais blogger sur chaque problème et paliatif ...
Sur une note plus sérieuse, je supose que globalement tu dois être
satisfait (en terme de productivité) du produit, malgrés ces quelques
déboires ...
Gilles , Le nouveau
Le #14669541
a écrit :
"j'ai forcément
emmagasiné pas mal de petites astuces pour éviter les grosses gagades
qui
peuvent foutre en l'air des heures, des jours voire même des semaines
de
travail ... "

Tu devrais blogger sur chaque problème et paliatif ...
Sur une note plus sérieuse, je supose que globalement tu dois être
satisfait (en terme de productivité) du produit, malgrés ces quelques
déboires ...







Et il recommence !
Tu te f* pas de la gueule du monde là !
RF
Le #14669531
a couché sur son écran :

Sur une note plus sérieuse, je supose que globalement tu dois être
satisfait (en terme de productivité) du produit, malgrés ces quelques
déboires ...



On a visiblement pas les mêmes dictionnaires!
Cela expliquerai les différences des définitions des mots "sérieux" et
"satisfait"...

Fumiste en montpelliérain (ou en PCSoftien), cela se dit comment?

:D
Dc
Le #14665891
Bonjour,

Après mûre réflexion, Val a écrit :
Donc, faite gaffe si, comme moi, vous vous mettez en tête d'utiliser des
icônes qui utilisent des groupes icônes.



J'ai un pb similaire mais non constant avec une fenetre dans laquelle
je n'ai rien fait niveau "icone"
C'est apparu avec la 35f de WD11
Ce soir j'ai mis a jour en 40m , on verra...

a plus..

--
-------------------------------------------------------------
www.ctc-soft.com
NOUV : Logiciel de Gestion Documentaire
Comptabilité shareware
Logiciels de Gestion de saisie terrain
Spécialisé Tournées de boulangers
-------------------------------------------------------------
PERCAPITA
Le #14665841
Je compatis, c'est très énervant.Moi j'ai du mal à admettre nombre de
plantage journalier de l'éditeur. Pire qu'en WD5.5. Parfois reproductible,
parfois non. Mais ca continue de version en version.


"Val" 45dad4e3$0$21151$
Bonjour,

J'utilise Windev depuis sa version 4, c'est-à-dire depuis pas mal d'années
maintenant.
Pour cette raison et comme beaucoup de développeurs, j'ai été confronté à
de
nombreuses galères et de déboires et, avec le temps, j'ai forcément
emmagasiné pas mal de petites astuces pour éviter les grosses gagades qui
peuvent foutre en l'air des heures, des jours voire même des semaines de
travail ...

En fait, aujourd'hui, je n'utilise même pas certains des composant fournis
avec Windev et que certains désignent, à juste titre, comme des gadgets et
qui sont censées rendre service au développeur, comme par exemple le
module
de nettoyage des projets.
En effet, un jour je l'ai utilisé et pan ... il m'a fallu plusieurs heures
pour réparer les dégâts !
Ah oui ... question nettoyage, il nettoyait à fond ...
Ainsi, à l'époque où j'ai testé ce module et puisque les images affectées
directement via le Wlangage à des objets n'étaient pas détectés ... hop
elles passaient à la trappe.
Bien sur, cette gagade a certainement été corrigée depuis par les
excellents
développeurs de PC-SOFT ... oui mais bon ... entre temps j'ai mis en
oeuvre
une méthode de travail qui me permet de garder des dossiers propres ...
donc, je n'utilise pas ce nettoyeur.
Je n'utilise pas non plus, depuis la version 7.5, les outils de création
d'install qui, la dernière fois où je les ai testés, étaient encore
buggés.
A cette époque, on ne pouvait même pas créer des raccourcis ... c'est dire
...
Bien sur, là aussi, ces gagades ont certainement été corrigées depuis par
les excellents développeurs de PC-SOFT ... oui mais bon ... entre temps
j'ai appris à utiliser des outils de création d'install (INNO SETUP en
particulier) fiables, personnalisables et avec lesquels on peut créer des
installs dignes de ce nom et avec des tailles "raisonnables".
Je n'utilise pas non plus les outils de sauvegarde puisque, la dernière
fois
où je les ai utilisés (en version 7 il me semble), je me suis retrouvé
avec
un pataquesse pas possible dans une analyse.
Bien sur, là aussi, ces gagades ont certainement été corrigées depuis par
les excellents développeurs de PC-SOFT ... oui mais bon ... entre temps,
j'ai mis en oeuvre une méthode de sauvegarde qui n'a jamais été mise en
défaut ... jusqu'à aujourd'hui !!

Et oui ... ce matin, je me suis retrouvé confronté à un problème très
particulier avec mon excellent WD11, payé cash !

Ainsi, dans un projet, quand j'ouvre une fenêtre du projet dans l'éditeur
de
fenêtre, la fenêtre se charge, puis la boite de dialogue "PC SOFT Windev
11
a rencontré un problème et doit fermer. Nous vous prions etc ..."
s'affiche.
Pour la signature de l'erreur, il est indiqué ceci:
AppName: windev11.exe AppVer: 11.0.0.4 ModName: msvcrt.dll
ModVer: 7.0.2600.2180 Offset: 00036fa3

Bien évidemment, Windev se ferme ...
Bon ... j'ai tout essayé, même de ré-installer WD ... rien à faire.

Donc, me dis-je ... la fenêtre est abîmée ... donc je vais restaurer une
sauvegarde de ladite fenêtre.
Comme je fais des sauvegardes 2 fois par jour, je ne suis pas inquiet ...
Et hop ... je restaure la fenêtre d'hier soir ... pareil ... impossible de
l'ouvrir ...
Donc, je restaure la fenêtre d'hier midi ... pareil ... impossible de
l'ouvrir ...
Et ainsi de suite ... jusqu'à la sauvegarde du 8 Janvier au soir ...
Oui oui ... il m'a fallu remonter jusqu'au 8 Janvier au soir pour
récupérer
la fenêtre ...
Pfuu !!!!!
Quelle mer####
Bon, le problème, c'est qu'entre temps ladite fenêtre à été fortement
modifiée ... donc toutes les heures de travail correspondant à ces
modifications passent à la trappe !!

Donc, comme déjà dit .... Pfuu !!!!!

Bon ... étant donné la situation, je me suis donc attaqué à la
reconstruction de la fenêtre et je ne vous cache pas mon humeur ...
Bon ... tout en bricolant, j'ai continué à cogiter sur les causes ...
Ce qui est étrange, me suis-je dit, c'est qu'il m'ait fallu remonter à une
sauvegarde du 8 janvier alors que, entre temps, la fenêtre avait été
modifiée.
Et oui ... quand j'examine mon planning de travail, je note que cette
fenêtre a été modifiée, pour la dernière fois, le 1 février ... donc cela
veut dire
qu'à cette date là, elle n'était pas abîmée ... donc pourquoi,
aujourd'hui,
la sauvegarde du 1 février est abîmée, tout comme celle du 31 Janvier, du
30
Janvier, etc ... jusqu'au 8 janvier ?
Etrange hein ???
Peut-être, me suis-je dit, il y a un problème sur le disque dur ...
impossible, puisque les sauvegardes sont effectuées sur 3 disques
distincts.
Bon ... ceci dit, on ne sait jamais ... donc j'ai vérifié les 3 disques
...
rien de spécial.

Bon ... alors j'ai continué à cogiter tout en marmonnant ...

Et oui ... étrange ... c'est pourquoi je me suis dit, à la manière de
l'inspecteur Bourrel, bon sang mais c'est bien sur ... c'est WD11 qui me
fout la me###"
Et là ... subitement, j'ai eu un éclair de lucité par le seul fait de
m'être
exclamé "c'est WD11 qui me fout la me###".
Et oui ... en disant cela, j'ai trouvé ce qu'il s'est passé ...
Je m'explique.
En fait, dans un menu contextuel de la fenêtre, j'ai un champ image qui
contient l'icône du logiciel ... le truc tout simple quoi !
Et c'est là que cela coince !!!
Oui oui c'est là ... au niveau de l'icône.
En fait, la semaine passée, j'ai modifié l'icône du logiciel et,
désormais,
le fichier icône est un fichier utilisant un groupes d'icônes
de différentes tailles et de différentes résolutions de couleurs (les
icônes
ont été créés avec un outil classant les icônes par taille croissante et
par
résolution de couleurs décroissante).
Or, figurez-vous que cet icône ne pose absolument aucun problème ... sauf
ici ... dans ce champ image de la fenêtre.
Ainsi, maintenant que cet icône est un fichier utilisant un groupes
icônes,
la fenêtre plante quand je cherche à l'ouvrir dans l'éditeur de fenêtre.
Donc, il m'a suffit de supprimer cet icône pour pouvoir charger la fenêtre
... et hop ça roule ... oui mais bon ... après 1/2 journée de boulot de
perdue !!

Pas mal ...
Merci Windev ...
Donc, faite gaffe si, comme moi, vous vous mettez en tête d'utiliser des
icônes qui utilisent des groupes icônes.
En effet si, quelque part dans votre projet, vous utilisez l'icône dans un
champ image (mais aussi dans un menu contextuel, sur un bouton, etc ...)
pensez à virer cet icône de là sinon ... plantage de WD11 garanti !!!
D'ailleurs, je ne sais pas si c'est ici ou en face, mais il y a quelques
jours il me semble avoir vu passer un fil ouvert par un développeur qui
avait un problème de plantage de WD et dans lequel la dll msvcrt.dll était
en cause ...
Peut-être était-il confronté à ce problème là ... si c'est le cas, il
suffit de supprimer l'icône ...

A+

Val





mat
Le #14665811
PERCAPITA wrote:
Je compatis, c'est très énervant.Moi j'ai du mal à admettre nombre de
plantage journalier de l'éditeur. Pire qu'en WD5.5. Parfois reproductible,
parfois non. Mais ca continue de version en version.





En ce qui concerne les plantages, Windev est sans doute le numéro 1
parmi les applications que j'utilise. Mais le nombre de plantages a été
fortement réduit (de "plusieurs fois par jour" à "de temps en temps") en
forçant le "flush", menu Outils, onglet Général. C'est plus lent pour
compiler le projet, mais j'ai gagné en stabilité.
Dc
Le #14663001
Bonjour,

mat a utilisé son clavier pour écrire :
"flush", menu Outils, onglet Général. C'est plus lent pour compiler le
projet, mais j'ai gagné en stabilité.



Ouah !! pas mal, on dirait que ca a arrangé mon pb .

a plus ...

--
-------------------------------------------------------------
www.ctc-soft.com
NOUV : Logiciel de Gestion Documentaire
Comptabilité shareware
Logiciels de Gestion de saisie terrain
Spécialisé Tournées de boulangers
-------------------------------------------------------------
PERCAPITA
Le #14662991
La désactivation du LiveUpdate dans les propriétés du projet ca aide
également ;-)

"mat"
PERCAPITA wrote:
Je compatis, c'est très énervant.Moi j'ai du mal à admettre nombre de
plantage journalier de l'éditeur. Pire qu'en WD5.5. Parfois
reproductible, parfois non. Mais ca continue de version en version.





En ce qui concerne les plantages, Windev est sans doute le numéro 1 parmi
les applications que j'utilise. Mais le nombre de plantages a été
fortement réduit (de "plusieurs fois par jour" à "de temps en temps") en
forçant le "flush", menu Outils, onglet Général. C'est plus lent pour
compiler le projet, mais j'ai gagné en stabilité.


patrice
Le #14662951
PERCAPITA a écrit :
La désactivation du LiveUpdate dans les propriétés du projet ca aide
également ;-)




Je l'ai desactivé mais j'ai qd meme des plantages avec une fenetre au
doux titre de 'acquire proxy' (c'est vrai que y'a pas un acces direct à
l'internet)

//mode troll
windev serait t'il un gigantesque spyware ?
Publicité
Poster une réponse
Anonyme