Comment intégrer une question/reponse dans une formule ??

Le
stepro
Sur une formule je voudrais qu'une question s'integre afin d'avoir le choix !
ex:

=SI(C6=0.125;'Diam cana'!B9;SI(C6=0.16;'Diam cana'!B10;SI(C6=0.2;'Diam
cana'!B11;SI(C6=0.25;'Diam cana'!B12;SI(C6=0.3;'Diam
cana'!B13;SI(C6=0.315;'Diam cana'!B13;SI(C6=0.4;'Diam
cana'!F10;SI(C6=0.5;'Diam cana'!F11))))))))

E dans cette formule j'aimerai intégrer la questio suivante PVC ou Béton ?

Merci à vous.
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
michdenis
Le #3339161
Bonjour Stepro,

Ta question n'est pas très claire !

Dans la suite de tes si, si une condition est remplie ou non, tu poses ta question...

=Si(a1="OK";"PVC ou Béton";"")
Ou
=Si(a1="OK";"";"PVC ou Béton")

Au delà de ça, il faudra préciser ce que tu veux !


Salutations!




"stepro" Sur une formule je voudrais qu'une question s'integre afin d'avoir le choix !
ex:

=SI(C6=0.125;'Diam cana'!B9;SI(C6=0.16;'Diam cana'!B10;SI(C6=0.2;'Diam
cana'!B11;SI(C6=0.25;'Diam cana'!B12;SI(C6=0.3;'Diam
cana'!B13;SI(C6=0.315;'Diam cana'!B13;SI(C6=0.4;'Diam
cana'!F10;SI(C6=0.5;'Diam cana'!F11))))))))

E dans cette formule j'aimerai intégrer la questio suivante PVC ou Béton ?

Merci à vous....
JB
Le #3338631
Bonjour,

http://cjoint.com/?mwuyWQnpPs ton exemple

http://cjoint.com/?mwuAfDFV2S explications

A B C
Beton Pcv
1 0,16 10 20
2 0,2 11 21
3 0,25 12 22
4 0,3 13 23
5 0,315 14 24
6 0,4 15 25

E F
1 Valeur cherchée Type
2 0,25 PVC


=INDEX(B2:C8;EQUIV(E2;A2:A8;1);EQUIV(F2;B1:C1;1))


Cordialement JB
stepro
Le #3338471
Merci pour votre reponse !

Mais je n'ai toujours pas résolu mon probleme de question, je suis novice !!

JB les liens que tu m'as transmi ne fonctionne pas ??

Merci à vous pour votre soutien, ce site est vraiment excellent.

Stéphane




Bonjour,

http://cjoint.com/?mwuyWQnpPs ton exemple

http://cjoint.com/?mwuAfDFV2S explications

A B C
Beton Pcv
1 0,16 10 20
2 0,2 11 21
3 0,25 12 22
4 0,3 13 23
5 0,315 14 24
6 0,4 15 25

E F
1 Valeur cherchée Type
2 0,25 PVC


=INDEX(B2:C8;EQUIV(E2;A2:A8;1);EQUIV(F2;B1:C1;1))


Cordialement JB




Ange Ounis
Le #3498331
Pour intégrer une question/réponse dans une formule, tu peux passer par une
fonction perso VBA. Petit exemple (basique) :

Function Quoi()
Quoi = InputBox("PVC ou Béton ?")
End Function

et dans une cellule Excel :

"8&" "&quoi()

----------
Ange Ounis
----------

Sur une formule je voudrais qu'une question s'integre afin d'avoir le choix !
ex:

=SI(C6=0.125;'Diam cana'!B9;SI(C6=0.16;'Diam cana'!B10;SI(C6=0.2;'Diam
cana'!B11;SI(C6=0.25;'Diam cana'!B12;SI(C6=0.3;'Diam
cana'!B13;SI(C6=0.315;'Diam cana'!B13;SI(C6=0.4;'Diam
cana'!F10;SI(C6=0.5;'Diam cana'!F11))))))))

E dans cette formule j'aimerai intégrer la questio suivante PVC ou Béton ?

Merci à vous....


Poster une réponse
Anonyme