comment puis-je sélectionner une partie du texte dans une requêt e?

Le
CDoiron
Bonjour,

J'ai créé un formulaire pour entrer les critères d'un état. J'ai en effet
suivi les étapes indiquées sur le site web de microsft à la lettre. Mon
formulaire "chercher" contient le champs de saisie "chercher".

Dans la requête qui est associée à cette saisie, le critère est identifié
comme [forms]![chercher]![chercher]. Lorsque je saisis un terme contenu dans
la table qui est liée à cette requête, tout fonctionne normalement.

Cependant j'aimerais sélectionner du texte qui serait contenu dans la table.
Dans ma requête, j'ai donc écrit ceci comme critère: Comme
"*[forms]![chercher]![chercher]*" . Cette expression fonctionne
habituellement avec d'autres critères tels comme "*texte123*". Pourquoi cette
expression ne fonctionne pas avec le 1er critère ci-haut? Comment pourrais-je
faire en sorte que l'utilisateur puisse entrer une partie d'un texte et o'u
la requête ferait sortir tous les textes qui contiennent cette entrée?

Merci beaucoup!
Vos réponses
Trier par : date / pertinence
3stone
Le #5623211
Salut,

"CDoiron"
| J'ai créé un formulaire pour entrer les critères d'un état. J'ai en effet
| suivi les étapes indiquées sur le site web de microsft à la lettre. Mon
| formulaire "chercher" contient le champs de saisie "chercher".

Tout ce qui a sur le site Microsoft ?
il t'a fallut 20 vies... ;-)


| Dans ma requête, j'ai donc écrit ceci comme critère: Comme
| "*[forms]![chercher]![chercher]*"

"*" & Forms!Chercher!Chercher & "*"


PS: Tu t'embrouille toi même en nommant le formulaire
et la zone de texte du même nom!
Prends l'habitude de préfixer les nom de formulaire
par frm... frmRecherche


--
A+
Pierre (3stone) Access MVP
Perso: http://users.skynet.be/accesshome/
Conseils MPFA: http://users.skynet.be/mpfa/
Email : http://www.cerbermail.com/?Xfg61Z3IQw
CDoiron
Le #5623161
Bonjour Pierre,

J'ai essayé ton critère dans ma requête et j'ai toujours le même problème:
je suis incapable de faire une recherche sur une partie de texte seulement.
Exemple, si je cherche le mot "astuce", tous les champs contenant exactement
"astuce" vont sortir dans ma requête. Cependant, si je tape "ast", ma requête
va me renvoyer un champ vide. Aurais-tu une solution à ce problème?

Merci beaucoup!


Salut,

"CDoiron"
| J'ai créé un formulaire pour entrer les critères d'un état. J'ai en effet
| suivi les étapes indiquées sur le site web de microsft à la lettre. Mon
| formulaire "chercher" contient le champs de saisie "chercher".

Tout ce qui a sur le site Microsoft ?
il t'a fallut 20 vies... ;-)


| Dans ma requête, j'ai donc écrit ceci comme critère: Comme
| "*[forms]![chercher]![chercher]*"

"*" & Forms!Chercher!Chercher & "*"


PS: Tu t'embrouille toi même en nommant le formulaire
et la zone de texte du même nom!
Prends l'habitude de préfixer les nom de formulaire
par frm... frmRecherche


--
A+
Pierre (3stone) Access MVP
Perso: http://users.skynet.be/accesshome/
Conseils MPFA: http://users.skynet.be/mpfa/
Email : http://www.cerbermail.com/?Xfg61Z3IQw




3stone
Le #5623141
Salut,

"CDoiron"
| J'ai essayé ton critère dans ma requête et j'ai toujours le même problème:
| je suis incapable de faire une recherche sur une partie de texte seulement.
| Exemple, si je cherche le mot "astuce", tous les champs contenant exactement
| "astuce" vont sortir dans ma requête. Cependant, si je tape "ast", ma requête
| va me renvoyer un champ vide. Aurais-tu une solution à ce problème?


tu as mis le "Comme" ?

Like "*" & Forms!Cherche!Cherche & "*"


--
A+
Pierre (3stone) Access MVP
Perso: http://users.skynet.be/accesshome/
Conseils MPFA: http://users.skynet.be/mpfa/
Email : http://www.cerbermail.com/?Xfg61Z3IQw
CDoiron
Le #5622761
Re-Bonjour Pierre,

J'ai mis le "comme" et maintenant ça fonctionne. Cependant, lorsque j'appuie
sur le bouton "ok" définit dans les instructions Microsoft "créer un
formulaire pour entrer les critères d'un état", je vois apparaître un menu me
demandant une 2e fois d'entrer la valeur du paramètre
"formulaires!cherche!cherche". Aurais-tu une solution à ce problème? Il me
semble que la valeur entrée dans le menu que j'ai défini n'est pas stockée et
alors access me demande de l'entrer à nouveau.

Merci encore!


Salut,

"CDoiron"
| J'ai essayé ton critère dans ma requête et j'ai toujours le même problème:
| je suis incapable de faire une recherche sur une partie de texte seulement.
| Exemple, si je cherche le mot "astuce", tous les champs contenant exactement
| "astuce" vont sortir dans ma requête. Cependant, si je tape "ast", ma requête
| va me renvoyer un champ vide. Aurais-tu une solution à ce problème?


tu as mis le "Comme" ?

Like "*" & Forms!Cherche!Cherche & "*"


--
A+
Pierre (3stone) Access MVP
Perso: http://users.skynet.be/accesshome/
Conseils MPFA: http://users.skynet.be/mpfa/
Email : http://www.cerbermail.com/?Xfg61Z3IQw




3stone
Le #5622671
Salut,

"CDoiron"
| J'ai mis le "comme" et maintenant ça fonctionne. Cependant, lorsque j'appuie
| sur le bouton "ok" définit dans les instructions Microsoft "créer un
| formulaire pour entrer les critères d'un état", je vois apparaître un menu me
| demandant une 2e fois d'entrer la valeur du paramètre
| "formulaires!cherche!cherche". Aurais-tu une solution à ce problème? Il me
| semble que la valeur entrée dans le menu que j'ai défini n'est pas stockée et
| alors access me demande de l'entrer à nouveau.

Heu... pas très clair...


Il faut bien sûr que le formulaire "Cherche" reste ouvert si la
requête est exécutée à nouveau!


--
A+
Pierre (3stone) Access MVP
Perso: http://users.skynet.be/accesshome/
Conseils MPFA: http://users.skynet.be/mpfa/
Email : http://www.cerbermail.com/?Xfg61Z3IQw
CDoiron
Le #5622621
Re-bonjour,

Désolée de ne pas avoir été assez claire. Mon formulaire "cherche" est
ouvert et je tape un mot dans le champ "cherche". Je clique sur le bouton
"ok". Ensuite, au lieu de m'afficher l'état o'u sont habituellement affichés
les résultats, Access m'affiche un menu (que je n'ai pas défini) me demandant
d'entrer la valeur du paramètre "formulaires!cherche!cherche". Ce menu
n'apparaissait pas auparavant. On dirait que la valeur que j'entre dans le
menu (formulaire) que j'ai moi-même défini ("cherche") n'est pas enregistrée
dans la requête alors Access me la demande.

Je ne sais pas si je suis claire cette fois?


Re-Bonjour Pierre,

J'ai mis le "comme" et maintenant ça fonctionne. Cependant, lorsque j'appuie
sur le bouton "ok" définit dans les instructions Microsoft "créer un
formulaire pour entrer les critères d'un état", je vois apparaître un menu me
demandant une 2e fois d'entrer la valeur du paramètre
"formulaires!cherche!cherche". Aurais-tu une solution à ce problème? Il me
semble que la valeur entrée dans le menu que j'ai défini n'est pas stockée et
alors access me demande de l'entrer à nouveau.

Merci encore!


Salut,

"CDoiron"
| J'ai essayé ton critère dans ma requête et j'ai toujours le même problème:
| je suis incapable de faire une recherche sur une partie de texte seulement.
| Exemple, si je cherche le mot "astuce", tous les champs contenant exactement
| "astuce" vont sortir dans ma requête. Cependant, si je tape "ast", ma requête
| va me renvoyer un champ vide. Aurais-tu une solution à ce problème?


tu as mis le "Comme" ?

Like "*" & Forms!Cherche!Cherche & "*"


--
A+
Pierre (3stone) Access MVP
Perso: http://users.skynet.be/accesshome/
Conseils MPFA: http://users.skynet.be/mpfa/
Email : http://www.cerbermail.com/?Xfg61Z3IQw






3stone
Le #5622521
Salut,

"CDoiron"
| Désolée de ne pas avoir été assez claire. Mon formulaire "cherche" est
| ouvert et je tape un mot dans le champ "cherche". Je clique sur le bouton
| "ok". Ensuite, au lieu de m'afficher l'état o'u sont habituellement affichés
| les résultats, Access m'affiche un menu (que je n'ai pas défini) me demandant
| d'entrer la valeur du paramètre "formulaires!cherche!cherche". Ce menu
| n'apparaissait pas auparavant. On dirait que la valeur que j'entre dans le
| menu (formulaire) que j'ai moi-même défini ("cherche") n'est pas enregistrée
| dans la requête alors Access me la demande.
|
| Je ne sais pas si je suis claire cette fois?

Mieux ;-)

S'il te demande la valeur du paramètre, c'est qu'il ne trouve pas la zone
de texte "Cherche" ou que tu as fait une erreur de saisie...

Je t'avais *déjà* conseillé de nommer plus clairement tes objets


--
A+
Pierre (3stone) Access MVP
Perso: http://users.skynet.be/accesshome/
Conseils MPFA: http://users.skynet.be/mpfa/
Email : http://www.cerbermail.com/?Xfg61Z3IQw
CDoiron
Le #5585921
Bonjour Pierre!

ça ne fonctionnait toujours pas alors j'ai complètement recommencé
l'exercice, avec cette fois des noms différents pour chacun des objets. Ça
fonctionne! Merci énormément pour ton aide :) Bonne journée!


Salut,

"CDoiron"
| Désolée de ne pas avoir été assez claire. Mon formulaire "cherche" est
| ouvert et je tape un mot dans le champ "cherche". Je clique sur le bouton
| "ok". Ensuite, au lieu de m'afficher l'état o'u sont habituellement affichés
| les résultats, Access m'affiche un menu (que je n'ai pas défini) me demandant
| d'entrer la valeur du paramètre "formulaires!cherche!cherche". Ce menu
| n'apparaissait pas auparavant. On dirait que la valeur que j'entre dans le
| menu (formulaire) que j'ai moi-même défini ("cherche") n'est pas enregistrée
| dans la requête alors Access me la demande.
|
| Je ne sais pas si je suis claire cette fois?

Mieux ;-)

S'il te demande la valeur du paramètre, c'est qu'il ne trouve pas la zone
de texte "Cherche" ou que tu as fait une erreur de saisie...

Je t'avais *déjà* conseillé de nommer plus clairement tes objets


--
A+
Pierre (3stone) Access MVP
Perso: http://users.skynet.be/accesshome/
Conseils MPFA: http://users.skynet.be/mpfa/
Email : http://www.cerbermail.com/?Xfg61Z3IQw




Publicité
Poster une réponse
Anonyme