Compile Debain/mplayer source ...

Le
Thierry
Bonjour,
J'essaie de compiler mplayer (source) sur ma debian.
Sans l'option gui, aucun pb, par contre, j'ai le son sans l'image
(embettant ;) )
Si je compile avec l'option gui j'ai :

Checking for inet6 yes
Checking for gethostbyname2 yes
Checking for GUI yes

Error: X11 support required for GUI compilation

Check "configure.log" if you do not understand why it failed.

Dans ce fameux fichier log, au niveau X11 j'ai :

Checking for X11 headers presence
Result is: not found (check if the dev(el) packages are installed)
##########################################

Checking for X11 libs presence
Result is: not found (check if the dev(el) packages are installed)
##########################################

Checking for X11
Result is: no
##########################################

Checking for DPMS
Result is: no
##########################################

Checking for Xv
Result is: no
##########################################

Checking for XvMC
Result is: no
##########################################

Checking for Xinerama
Result is: no
##########################################

Checking for Xxf86vm
Result is: no

De quel package parle t'il ? dev(el)

Sinon, existe t'il un autre moyen pour installer correctement mplayer ? Le
package mplayer n'existant plus sous debian.

Merci
Vos réponses
Trier par : date / pertinence
Vincent Ramos
Le #1102848

Dans ce fameux fichier log, au niveau X11 j'ai :

============ Checking for X11 headers presence =========== > Result is: not found (check if the dev(el) packages are installed)
##########################################


Peut-être quelque chose comme :
* XFree86-libs ;
* XFree86-devel ;
* XFree86-libs-data ;
* XFree86-libs ?

françois
Le #1478731
Thierry wrote:
Bonjour,
J'essaie de compiler mplayer (source) sur ma debian.
Sans l'option gui, aucun pb, par contre, j'ai le son sans l'image
(embettant ;) )


Bonjour,

Pour la vidéo que renvoie la commande :

mplayer -vo help ==>
liste les plugins vidéo installer (-ao pour le son )

pour le support du gui , il demande les header X11
accessible si les paquets dev sont installé :
x-window-system-dev est un metapackages qui installe
les fichiers dev de X11 à essayer ... (??)

Publicité
Poster une réponse
Anonyme