compter le nombre de couple

Le
bxman
bonjour
j'aimerai pouvoir compter le nombre de couple de valeur
sachant que les valeurs sont contenues dans deux colonnes
differentes

Merci
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas B.
Le #1275669
Salut,

Si tu veux chercher le nombre de lignes pour lesquelles il y a deux valeurs
(une en col A et une en B) :
=SOMMEPROD((A2:A10<>"")*(B2:B10<>""))


A+
--
Nicolas B.


bonjour
j'aimerai pouvoir compter le nombre de couple de valeur
sachant que les valeurs sont contenues dans deux colonnes
differentes

Merci


bxman
Le #1275659
ok cela fonctionne bien
Seul bemol,
quand je tape la formule suivante
=SOMMEPROD((Tb_fichier_demande!J2:J1575="15489")*
(Tb_fichier_demande!Q2:Q1575="50"))
avec les valeur en dur, cela fonctionne nickel, par contre
quand je remplace les valeurs "15489" et "50" par A4 et B2
qui contiennent respectivement les valeurs 15489 et 50.
cela ne fonctionne pas
je precise que j'execute le fonction a partir d'une
seconde feuille de calcul

Merci encore pour le coup de main

-----Message d'origine-----
Salut,

Si tu veux chercher le nombre de lignes pour lesquelles
il y a deux valeurs

(une en col A et une en B) :
=SOMMEPROD((A2:A10<>"")*(B2:B10<>""))


A+
--
Nicolas B.


bonjour
j'aimerai pouvoir compter le nombre de couple de valeur
sachant que les valeurs sont contenues dans deux
colonnes


differentes

Merci



.




Nicolas B.
Le #1275650
=SOMMEPROD((Tb_fichier_demande!J2:J1575="15489")*
(Tb_fichier_demande!Q2:Q1575="50"))


Si tes nombres sont au format Texte, il faut aussi que les cellules A4 et B2
le soient.
Ou alors, tu peux aussi convertir dans la formule les données en numérique :
=sommeprod((cnum(Tb_fichier_demande!J2:J1575)=cnum(a4))*...)

Le problème ne semble par comtre pas venir des données sur l'autre feuille
ou classeur.


A+
--
Nicolas B.


ok cela fonctionne bien
Seul bemol,
quand je tape la formule suivante
=SOMMEPROD((Tb_fichier_demande!J2:J1575="15489")*
(Tb_fichier_demande!Q2:Q1575="50"))
avec les valeur en dur, cela fonctionne nickel, par contre
quand je remplace les valeurs "15489" et "50" par A4 et B2
qui contiennent respectivement les valeurs 15489 et 50.
cela ne fonctionne pas
je precise que j'execute le fonction a partir d'une
seconde feuille de calcul

Merci encore pour le coup de main

-----Message d'origine-----
Salut,

Si tu veux chercher le nombre de lignes pour lesquelles il y a deux
valeurs (une en col A et une en B) :
=SOMMEPROD((A2:A10<>"")*(B2:B10<>""))


A+
--
Nicolas B.


bonjour
j'aimerai pouvoir compter le nombre de couple de valeur
sachant que les valeurs sont contenues dans deux colonnes
differentes

Merci



.





Publicité
Poster une réponse
Anonyme