Configuration de samba

Le
Informatique CARPIMKO
Bonjour,
j'ai installé une red hat (RHEL4-U2-i386-ES-disc1.iso) sur un serveur dell
(poweredge 2800). J'ai ajouté ma machine dans mon domaine NT4 (elle est
visible dans le Voisinage réseau des machines windows); j'arrive à pinger
l'adresse ip (reseau correct) et le nom de la machine (wins correct). J'ai
créé un partage sur la machine avec accès libre pour tous mais impossible
d'y accéder :-( Je veux juste un simple accès à un répertoire de ma machine.
J'ai redémarré les services smb et winbind à chaque modification.
Voici le fichier smb.conf où je ne vois pas ce qui pose problème:

#== Global Settings =
[global]
workgroup = courrier
server string = Samba Server (serv-rh1)
security = DOMAIN
null passwords = yes
obey pam restrictions = yes
pam password change = yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*password* %n
log level = 1
log file = /var/log/samba/%m.log
max log size = 1000
name resolve order = lmhosts host wins bcast
socket options = TCP_NODELAY SO_SNDBUF92 SO_RCVBUF92
add user script = /usr/sbin/useradd %u
delete user script = /usr/sbin/userdel %u
preferred master = no
domain master = no
wins server = 192.90.249.11
ldap ssl = no
idmap uid = 10000-20000
idmap gid = 10000-20000
template shell = /bin/bash
winbind cache time = 10
writeable = yes
create mask = 0777
directory mask = 0777
guest ok = yes
password server = serv-10
printing = cups

[StockDoc]
comment = Stockage Ged Production
path = /var/lib/samba/StockDoc
browseable = yes
writeable = yes
guest ok = yes



Yannick
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
oli-cla
Le #4178041
Bonjour,
j'ai installé une red hat (RHEL4-U2-i386-ES-disc1.iso) sur un serveur dell
(poweredge 2800). J'ai ajouté ma machine dans mon domaine NT4 (elle est
visible dans le Voisinage réseau des machines windows); j'arrive à pinger
l'adresse ip (reseau correct) et le nom de la machine (wins correct). J'ai
créé un partage sur la machine avec accès libre pour tous mais impossible
d'y accéder :-( Je veux juste un simple accès à un répertoire de ma machine.
J'ai redémarré les services smb et winbind à chaque modification.
Voici le fichier smb.conf où je ne vois pas ce qui pose problème:

#======================= Global Settings ============================== > [global]
workgroup = courrier
server string = Samba Server (serv-rh1)
security = DOMAIN
null passwords = yes
obey pam restrictions = yes
pam password change = yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*password* %n
log level = 1
log file = /var/log/samba/%m.log
max log size = 1000
name resolve order = lmhosts host wins bcast
socket options = TCP_NODELAY SO_SNDBUF92 SO_RCVBUF92
add user script = /usr/sbin/useradd %u
delete user script = /usr/sbin/userdel %u
preferred master = no
domain master = no
wins server = 192.90.249.11
ldap ssl = no
idmap uid = 10000-20000
idmap gid = 10000-20000
template shell = /bin/bash
winbind cache time = 10
writeable = yes
create mask = 0777
directory mask = 0777
guest ok = yes
password server = serv-10
printing = cups

[StockDoc]
comment = Stockage Ged Production
path = /var/lib/samba/StockDoc
browseable = yes
writeable = yes
guest ok = yes



Yannick


Salut,


dans les propriétés gloables je mettrai:

netbios name= le_nom_de_ta_machine
interfaces= (les adrresses IP des machine autorisées) exemple :
192.168.1.2 192.168.1.20
local master=yes
encrypt passwords=no
share modes=yes

puis remplace :

security = DOMAIN par
security=share

dans [StocDoc] ajoute
public=yes

puis commenter eventuellement
#pam password change=yes
#passwd program = /usr/bin/passwd %u
# passwd chat = *New*password* %n



Salut,

Publicité
Poster une réponse
Anonyme