Configuration réseau, après, j'arrête, promis !

Le
Nicolas FRANCOIS
--Sig_/kI=J8LBG1PdEHO8yR.Ypld4
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Salut.

Bon, comme je le disais, openvpn fonctionne correctement par systemd.
Le seul soucis qui me reste (en dehors des problèmes de ports que je
laisse de coté, ils ne me déragent pas tant que ça), c'est q=
ue quand le
vpn est "on", j'ai des soucis de connexion aux serveurs mail de Free
(pop et smtp). C'est bizarre, parce que mes connexions vers d'autres
serveurs ne posent pas de problème (club-internet, la-poste).

Les routes sont correctement définies, je l'ai vérifié avec =
traceroute.
Donc j'accède sans vpn à pop.free.fr et smtp.free.fr, mais la con=
nexion
échoue, puis sans prévenir, après 90s, un deuxième essa=
i est tenté et
réussi tout de suite

Je me dis donc qu'il doit y avoir un truc pas catholique au niveau de
la connexion aux serveurs de Free. Une autre chose bizarre : avec
une configuration identique, je n'avais pas de problème sur ma Debian
8 Même route, pas de soucis

Lorsque j'envoie des messages, j'ai une trace avec journalctl, qui fait
mention de gcr-prompter, ça doit venir du fait que je signe mes
messages avec gpg, peut-être y a-t-il un accès à un serveur =
à ce moment
là. Par contre, quand je récupère mes mails, je n'ai aucune =
trace :-(

Si l'un d'entre vous à une idée pour résoudre le problè=
me, je suis
preneur, ça commence à me faire tourner en bourrique, ce truc :-(

bye

--

Nicolas FRANCOIS | /
http://nicolas.francois.free.fr | |__|
X--/\
We are the Micro$oft. __V
Resistance is futile.
You will be assimilated. darthvader penguin

--Sig_/kI=J8LBG1PdEHO8yR.Ypld4
Content-Type: application/pgp-signature
Content-Description: Signature digitale OpenPGP

--BEGIN PGP SIGNATURE--

iQEzBAEBCAAdFiEE7s3+BtBEQX/Kgdk7xYgnps2M/gEFAllo8+AACgkQxYgnps2M
/gF+Pwf+IXb/uQfPTtUzkzmpW2/ZP/WEMdecURKu4rZuxiMFHoyqJgwIMOni/XP8
bqBaeAjhQ7ptQ6FJbK8CQEUFHI642FewAGk0IVvYLOqkZvVUjOzR0AxGwIcfnbv1
Tgj4L3l4b0RX0fqynA+4Mug6CFHuR4Bp3ajsK/NLD0Eo5HTRLtL9KK2TzsyP1qPB
OtZrkWdpOJxSPJZIxTG1wLEsd8jkH2mq9uGOAG6IpS9MKoBct+dMALVVl78pMdQ1
F6hwQR00SBTK0UewF+M8NZO3nQ+gh1wc3vPqkF/rduRibMYKTuA84tIfejDS84Ux
zCrVtx0hVT4m4tekB5JcawlZQ2La1w==
=8/+J
--END PGP SIGNATURE--

--Sig_/kI=J8LBG1PdEHO8yR.Ypld4--
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas FRANCOIS
Le #26438407
--Sig_/5TE9wwjVe+diR2kQh7Jz8wY
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable
Au fait, j'ai oublié de préciser, mais ça ne devrait pas avo ir une
grande importance, j'utilise Claws Mail !
bye
--
Nicolas FRANCOIS | /
http://nicolas.francois.free.fr | |__|
X--/\
We are the Micro$oft. __V
Resistance is futile.
You will be assimilated. darthvader penguin
--Sig_/5TE9wwjVe+diR2kQh7Jz8wY
Content-Type: application/pgp-signature
Content-Description: Signature digitale OpenPGP
-----BEGIN PGP SIGNATURE-----
iQEzBAEBCAAdFiEE7s3+BtBEQX/Kgdk7xYgnps2M/gEFAllo9FoACgkQxYgnps2M
/gEoOAf9FbQYpM2YBg76sTmlvGGCcgK0ibZVXm/SKekNtEvKHZj0nGgw8A6Vlj3u
Thnu/PUS/6GAJE+a74GugU19mdm1aWEhGIvYw1tDHu7qZD4wHuB7Jdf1MtJiw/2f
NRsYWkfvBPMq7rdbgyMtCw/osNRhi4shtiVjTgo70B/LzYT3cvrgV69qXEvciR7H
BOKZ9/TcJW05CNF1Vd5vkS/zPSlS5B7/WV7tpbtAdsTGD6Bo+hn0Gx0n/k6+lidk
lZLEO/Q1cKw9uST7ysc/259InfOtuSBQ5j38FHEYbRq5QXXaCl5V/6wh0M3poSqk
zaDWEOCPBNz8RBmA8Eew1ZN/eQ6FAw= =VYed
-----END PGP SIGNATURE-----
--Sig_/5TE9wwjVe+diR2kQh7Jz8wY--
Christophe
Le #26438413
Hello,
Le 14/07/2017 à 18:40, Nicolas FRANCOIS a écrit :
Les routes sont correctement définies, je l'ai vérifié avec traceroute.
Donc j'accède sans vpn à pop.free.fr et smtp.free.fr, mais la connexion
échoue, puis sans prévenir, après 90s, un deuxième essai est tenté et
réussi tout de suite...

J'ai constaté le même soucis en utilisant smtp.free.fr avec une ligne
ADSL chez Bouygues Telecom.
Donc ton soucis n'en est peut être pas un (il y a peut être un soucis
chez Free).
@+
Christophe.
Pascal Hambourg
Le #26438416
Le 14/07/2017 à 18:40, Nicolas FRANCOIS a écrit :
Les routes sont correctement définies, je l'ai vérifié avec traceroute.
Donc j'accède sans vpn à pop.free.fr et smtp.free.fr, mais la connexion
échoue, puis sans prévenir, après 90s, un deuxième essai est tenté et
réussi tout de suite...

Tu as testé la connexion à ces serveurs avec telnet ?
telnet smtp.free.fr submission
telnet pop.free.fr pop3
Si l'un d'entre vous à une idée pour résoudre le problème

Tu as vérifié les hypothèses de mon message précédent ?
Pascal Hambourg
Le #26438446
Le 14/07/2017 à 22:07, Nicolas FRANCOIS a écrit :
Le Fri, 14 Jul 2017 19:38:58 +0200,
Pascal Hambourg
Tu as testé la connexion à ces serveurs avec telnet ?
telnet smtp.free.fr submission
telnet pop.free.fr pop3

Je crois que ces tests mettent le doigt sur le problème :

C'était un peu le but.
Saloperie d'IPv6 !!!

Dis plutôt saloperie de VPN qui annonce de l'IPv6 moisi.
J'ai rien demandé, j'en veux pas, moi, de l'IPv6,

Vraiment ? Il n'y a pas une option de la configuration de ton client VPN
qui dit de configurer l'IPv6 si le serveur le propose ?
Bon, si je comprends bien, il faut que je double toutes les routes de
ma table de routage :-P

Marchera pas car d'après le résultat du telnet sans VPN qui utilise
directement IPv4, tu n'as pas de connectivité IPv6 globale via ton LAN.
Par contre tu peux "nullrouter" ces adresses IPv6 pour les déclarer
injoignables.
Merci, en tout cas, j'en étais réduit à fouiller les paquets avec
wireshark...

Cela aurait aussi pu te mettre sur la piste en voyant les paquets TCP
SYN en IPv6 rester sans réponse.
Si l'un d'entre vous à une idée pour résoudre le problème



J'en ai plein (oui, j'ai lu ton message suivant mais je propose des
alternatives) :
Activer l'IPv6 sur la freebox et sur ton LAN avec une connectivité globale.
Désactiver l'IPv6 sur la machine (mais je suis contre).
Désactiver l'IPv6 sur le VPN.
Bloquer le trafic IPv6 sur l'interface VPN avec ip6tables (sale).
Créer des nullroutes pour les adresses IPv6 des serveurs.
Mettre les adresses IPv4 des serveurs en dur dans le client mail.
Mettre les adresses IPv4 et noms des serveurs en dur dans /etc/hosts (ça
ne marchera plus si Free change les adresses de ses serveurs, mais c'est
déjà le cas avec les routes additionnelles).
Cependant toutes les solutions spécifiques aux adresses des serveurs
(dont celle que tu as choisie) ne règlent pas le problème général de
connectivité IPv6 que tu risques d'avoir avec tout autre service qui a
une adresse IPv6, notamment les sites web.
Tu as vérifié les hypothèses de mon message précédent ?

Je ne les avais pas comprises

Tu aurais pu demander des éclaircissements si ce n'était pas assez clair.
Publicité
Poster une réponse
Anonyme