Connexion automatique =c3=a0 une cible iSCSI

Le
BERTRAND Jo=c3=abl
Bonjour à tous.

Je suis en train de monter un système de sauvegarde avec un NAS QNAP et
Bacula pour remplacer un antique système de sauvegarde tournant déjà
avec Bacula, mais adossé à une baie de vingt disques U320

J'avoue avoir été bluffé par ces petits NAS. J'ai désactivé sur le NAS
tous les protocoles sauf iSCSI. Je l'ai configuré et j'ai configuré côté
Linux l'initiateur.

J'arrive à me connecter et à utiliser LUN sur le NAS. Cependant,
j'aimerais automatiser le montage du NAS au boot du système et je n'y
arrive pas. Pourtant, j'utilisais le montage automatique par le passé
sans problème. Ne faisant pas cela tous les jours, je suppose que j'ai
raté quelque chose, mais je n'ai pas trouvé de solution efficace.

Mon fichier de configuration :

iscsid.startup = /sbin/iscsid
iscsid.safe_logout = Yes
node.startup = automatic
node.leading_login = No
node.session.auth.authmethod = None
discovery.sendtargets.auth.authmethod = None
node.session.timeo.replacement_timeout = 120
node.conn[0].timeo.login_timeout = 15
node.conn[0].timeo.logout_timeout = 15
node.conn[0].timeo.noop_out_interval = 5
node.conn[0].timeo.noop_out_timeout = 5
node.session.err_timeo.abort_timeout = 15
node.session.err_timeo.lu_reset_timeout = 30
node.session.err_timeo.tgt_reset_timeout = 30
node.session.initial_login_retry_max = 8
node.session.cmds_max = 128
node.session.queue_depth = 32
node.session.xmit_thread_priority = -20
node.session.iscsi.InitialR2T = No
node.session.iscsi.ImmediateData = Yes
node.session.iscsi.FirstBurstLength = 262144
node.session.iscsi.MaxBurstLength = 16776192
node.conn[0].iscsi.MaxRecvDataSegmentLength = 262144
node.conn[0].iscsi.MaxXmitDataSegmentLength = 0
discovery.sendtargets.iscsi.MaxRecvDataSegmentLength = 32768
node.session.nr_sessions = 1
node.session.iscsi.FastAbort = Yes

Naturellement, j'ai bien effectué l'opération de découverte des LUN et
relancé iscsid. Rien n'y fait.

Une idée ?

JKB
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
BERTRAND Jo=c3=abl
Le #26473789
Felix Defrance a écrit :
Salut,
Que dit un "systemctl is-enabled open-iscsi.service" ?

enabled.
Mais le problème n'est pas là, pour l'instant, je lance iscsid à la main
(iscsid -f -d3).
Merci tout de même ;-)
Bien cordialement,
JKB
Publicité
Poster une réponse
Anonyme