[Cups]filter failed

Le
Grégory Bulot
Bonjour,

Avec une Debian/Jessie à jour (à priori)

Je n'arrive plus à imprimer des documents via cups mais les pages de
tests (via ihm web cups sur port 631) s'impriment !

j'ai ce problème :
- en imprimant n'importe quelle page web (firefox, chromium) (pour
info je test avec une page du site sephora cadeau de Noël !)
- en imprimant des pdf généré via firefox (imprimer vers un document)
- en imprimant des pdf (100% de me documents perso)


a force de chercher je suis tombé sur un script (fix_pdf.sh), qui
utilise gs pour utiliser des fonts 'standards' si je comprends bien :

> strace -e open $GS -q -dNOPAUSE -dBATCH -sDEVICE=pdfwrite
> -dCompatibilityLevel=1.3 -dAutoRotatePages=/None
> -dAutoFilterColorImageslse
> -dNOPLATFONTS -dPARANOIDSAFER -dColorImageFilter=/FlateEncode
> -dPDFSETTINGS=/printer -dColorConversionStrategy=/LeaveColorUnchanged
> -dDoNumCopies -r600 -dDEVICEWIDTHPOINTSY5
> -dDEVICEHEIGHTPOINTS2 -sOutputFile=$OUTFILE $INFILE


si je le lance :

> open("/usr/share/ghostscript/fonts/Sephora.pdf", O_RDONLY) = -1 ENOENT
> (No such file or directory)
> open("/usr/local/lib/ghostscript/fonts/Sephora.pdf", O_RDONLY) = -1
> ENOENT (No such file or directory)
> open("/usr/share/fonts/Sephora.pdf", O_RDONLY) = -1 ENOENT (No such
> file or directory) open("Sephora.pdf", O_RDONLY) = 4
> SIGSEGV {si_signo=SIGSEGV, si_code=SI_KERNEL, si_addr=0} +++
> killed by SIGSEGV +++ /home/gbulot/bin/fix_pdf.sh : ligne 15 : 23104
> Erreur de segmentation strace -e open $GS -q -dNOPAUSE -dBATCH
> -sDEVICE=pdfwrite -dCompatibilityLevel=1.3 -dAutoRotatePages=/None
> -dAutoFilterColorImageslse -dNOPLATFONTS -dPARANOIDSAFER
> -dColorImageFilter=/FlateEncode -dPDFSETTINGS=/printer
> -dColorConversionStrategy=/LeaveColorUnchanged -dDoNumCopies -r600
> -dDEVICEWIDTHPOINTSY5 -dDEVICEHEIGHTPOINTS2 -sOutputFile=$OUTFILE
> $INFILE

cups 1.7.5-11+deb8u1
ghostscript 9.06~dfsg-2+deb8u4

pdfinfo Sephora.pdf
Creator: cairo 1.9.5 (http://cairographics.org)
Producer: cairo 1.9.5 (http://cairographics.org)
Tagged: no
UserProperties: no
Suspects: no
Form: none
JavaScript: no
Pages: 1
Encrypted: no
Page size: 595.3 x 841.9 pts (A4)
Page rot: 0
File size: 264214 bytes
Optimized: no
PDF version: 1.5

Note un autre document (CP_TO11740867.pdf) pose le même problème

Producer: FOP 0.20.5
[]
File size: 1454031 bytes
Optimized: no
PDF version: 1.3


je ne sais plus quoi faire, avez-vous une idée ?
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
bernard schoenacker
Le #26421016
On Mon, 19 Dec 2016 15:31:34 +0100
Grégory Bulot
Bonjour,
Avec une Debian/Jessie à jour (à priori)
Je n'arrive plus à imprimer des documents via cups mais les pages de
tests (via ihm web cups sur port 631) s'impriment !
j'ai ce problème :
- en imprimant n'importe quelle page web (firefox, chromium) (pour
info je test avec une page du site sephora ...cadeau de Noël !)
- en imprimant des pdf généré via firefox (imprimer vers un
document)
- en imprimant des pdf (100% de me documents perso)
a force de chercher je suis tombé sur un script (fix_pdf.sh), qui
utilise gs pour utiliser des fonts 'standards' si je comprends bien :
strace -e open $GS -q -dNOPAUSE -dBATCH -sDEVICE=pdfwrite
-dCompatibilityLevel=1.3 -dAutoRotatePages=/None
-dAutoFilterColorImagesúlse
-dNOPLATFONTS -dPARANOIDSAFER -dColorImageFilter=/FlateEncode
-dPDFSETTINGS=/printer
-dColorConversionStrategy=/LeaveColorUnchanged -dDoNumCopies
-r600 -dDEVICEWIDTHPOINTSY5 -dDEVICEHEIGHTPOINTS„2 -sOutputFile > > $OUTFILE $INFILE

si je le lance :
open("/usr/share/ghostscript/fonts/Sephora.pdf", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/local/lib/ghostscript/fonts/Sephora.pdf", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/fonts/Sephora.pdf", O_RDONLY) = -1 ENOENT (No such
file or directory) open("Sephora.pdf", O_RDONLY) = 4 ---
SIGSEGV {si_signo=SIGSEGV, si_code=SI_KERNEL, si_addr=0} --- +++
killed by SIGSEGV +++ /home/gbulot/bin/fix_pdf.sh : ligne 15 : 23104
Erreur de segmentation strace -e open $GS -q -dNOPAUSE -dBATCH
-sDEVICE=pdfwrite -dCompatibilityLevel=1.3 -dAutoRotatePages=/None
-dAutoFilterColorImagesúlse -dNOPLATFONTS -dPARANOIDSAFER
-dColorImageFilter=/FlateEncode -dPDFSETTINGS=/printer
-dColorConversionStrategy=/LeaveColorUnchanged -dDoNumCopies -r600
-dDEVICEWIDTHPOINTSY5 -dDEVICEHEIGHTPOINTS„2 -sOutputFile > > $OUTFILE $INFILE

cups 1.7.5-11+deb8u1
ghostscript 9.06~dfsg-2+deb8u4
pdfinfo Sephora.pdf
Creator: cairo 1.9.5 (http://cairographics.org)
Producer: cairo 1.9.5 (http://cairographics.org)
Tagged: no
UserProperties: no
Suspects: no
Form: none
JavaScript: no
Pages: 1
Encrypted: no
Page size: 595.3 x 841.9 pts (A4)
Page rot: 0
File size: 264214 bytes
Optimized: no
PDF version: 1.5
Note un autre document (CP_TO11740867.pdf) pose le même problème
Producer: FOP 0.20.5
[...]
File size: 1454031 bytes
Optimized: no
PDF version: 1.3
je ne sais plus quoi faire, avez-vous une idée ?

bonjour,
comme c'est la "fête" :
apt-cache search cups-pdf
cups-pdf - PDF writer backend for CUPS (dummy transitional package)
printer-driver-cups-pdf - printer driver for PDF writing via CUPS
dpkg -l |awk '/cups-pdf/ {print $1 " "$2" "$3}'
ii cups-pdf 2.6.1-22
ii printer-driver-cups-pdf 2.6.1-22
apt-cache policy printer-driver-cups-pdf
printer-driver-cups-pdf:
Installé : 2.6.1-22
Candidat : 2.6.1-22
Table de version :
*** 2.6.1-22 500
500 http://httpredir.debian.org/debian sid/main amd64 Packages
500 http://httpredir.debian.org/debian stretch/main amd64
Packages 100 /var/lib/dpkg/status
2.6.1-15 500
500 http://httpredir.debian.org/debian jessie/main amd64
Packages

serait il possible de comparer avec l'existant ?
slt
bernard

--
bernard schoenacker
Grégory Bulot
Le #26421018
Bonjour,
Le Mon, 19 Dec 2016 16:07:28 +0100 "bernard schoenacker" à écrit
Avec une Debian/Jessie à jour (à priori)


bonjour,
comme c'est la "fête" :
apt-cache search cups-pdf
cups-pdf - PDF writer backend for CUPS (dummy transitional package)
printer-driver-cups-pdf - printer driver for PDF writing via CUPS
dpkg -l |awk '/cups-pdf/ {print $1 " "$2" "$3}'
ii cups-pdf 2.6.1-22
ii printer-driver-cups-pdf 2.6.1-22


2.6.1-22 : stretch
pour jessie j'ai :
ii cups-pdf 2.6.1-15
ii printer-driver-cups-pdf 2.6.1-15
apt-cache policy printer-driver-cups-pdf
printer-driver-cups-pdf:
Installé : 2.6.1-22
Candidat : 2.6.1-22
Table de version :
*** 2.6.1-22 500
500 http://httpredir.debian.org/debian sid/main amd64 Packages
500 http://httpredir.debian.org/debian stretch/main amd64
Packages 100 /var/lib/dpkg/status
2.6.1-15 500
500 http://httpredir.debian.org/debian jessie/main amd64
Packages


printer-driver-cups-pdf:
Installé : 2.6.1-15
Candidat : 2.6.1-15
Table de version :
*** 2.6.1-15 0
500 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages
100 /var/lib/dpkg/status
Publicité
Poster une réponse
Anonyme