(Debian 10) installer un pilote

Le
docanski
Bonjour,

Je possède une webcam Hercules Classic pour laquelle le fabricant
n'offre pas de pilote Linux.
Parmi ceux proposés par des développeurs indépendants, j'ai trouvé
ov511-1.65.tar.gz
La dernière mise Í  jour date de 2012/13 mais l'ancienneté du pilote
ne garantit pas une installation sͻre dans le noyau actuel de Debian 10.
En effet, un make install me donne le code suivant :
[code]
You must specify an appropriate install command for your kernel:
make install-2.2
make install-2.4
make install-2.4rh (for RedHat kernels 2.4.9-31 thru 2.4.18)
make install-2.5
[/code]
soit le choix d'un noyau qui est aujourd'hui largement dépassé.
Dès lors que faire ? Dois-je abandonner cette webcam pour éviter les
problèmes ?

Cordialement,
--
docanski

Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les cÍ´tes du nord de la Bretagne : http://docarmor.free.fr/
Forum boursier : http://docanski.free.fr/boursomania/
  • Partager ce contenu :
Vos réponses Page 1 / 3
Trier par : date / pertinence
Christophe PEREZ
Le #26566937
Le Wed, 03 Feb 2021 12:41:58 +0100, docanski a écrit :
Dès lors que faire ? Dois-je abandonner cette webcam pour éviter les
problèmes ?

Ou voir si l'un des modules déjÍ  contenus dans les noyaux actuels ne
feraient pas l'affaire.
La méthode sur les infos Í  récolter au sujet de la webcam et la
corrélation avec les modules du noyau est expliquée de très grands
nombres de fois sur internet.
docanski
Le #26566938
Christophe PEREZ a écrit le 3/02/21 Í  15:09 :
Le Wed, 03 Feb 2021 12:41:58 +0100, docanski a écrit :
Dès lors que faire ? Dois-je abandonner cette webcam pour éviter les
problèmes ?

Ou voir si l'un des modules déjÍ  contenus dans les noyaux actuels ne
feraient pas l'affaire.
La méthode sur les infos Í  récolter au sujet de la webcam et la
corrélation avec les modules du noyau est expliquée de très grands
nombres de fois sur internet.

La webcam n'est même pas reconnue lors de l'ouverture d'une cession :
aucun message, aucun affichage. Cela ne signifie-t'il pas que le noyau
ne contient aucun élément permettant d'envisager une installation ?
--
docanski
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les cÍ´tes du nord de la Bretagne : http://docarmor.free.fr/
Forum boursier : http://docanski.free.fr/boursomania/
yamo'
Le #26566943
Salut,
docanski a tapoté le 03/02/2021 12:41:
Je possède une webcam Hercules Classic pour laquelle le fabricant
n'offre pas de pilote Linux.


Trouvé sur --
Stéphane
Nicolas George
Le #26566942
docanski , dans le message
La webcam n'est même pas reconnue lors de l'ouverture d'une cession :
aucun message, aucun affichage. Cela ne signifie-t'il pas que le noyau
ne contient aucun élément permettant d'envisager une installation ?

Ça signifie que l'ouverture d'une session et la détection du matériel n'ont
strictement rien Í  voir ensemble.
Débranche la webcam. Lance dmesg -w, appuie sur entrée quelques fois pour
marquer l'endroit o͹ tu es. Branche la webcam.
Regarde les lignes qui apparaissent au branchement.
Christophe PEREZ
Le #26566996
Le Wed, 03 Feb 2021 19:49:54 +0100, yamo' a écrit :

Qui parle de http://ovcam.org/ov511/
Dont la dernière version date de 2006 pour noyau 2.6 ?
J'ai des doutes.
Christophe PEREZ
Le #26566995
Le Wed, 03 Feb 2021 17:33:33 +0100, docanski a écrit :
La webcam n'est même pas reconnue lors de l'ouverture d'une cession :
aucun message, aucun affichage.

Je ne sais même pas ce que veut dire "pas reconnue lors de l'ouverture
d'une cession" d'autant que tu ne précises pas une cession de quoi.
Cela ne signifie-t'il pas que le noyau
ne contient aucun élément permettant d'envisager une installation ?

Non, je ne pense pas. Tu n'as pas forcément une indication de tout ce que
fait le noyau, sinon tu passeras ton temps Í  ça.
Il faut aller chercher l'info, et au risque de me répéter, la méthode est
décrite sur internet de très nombreuses fois.
Nicolas t'en a donné un bout.
yamo'
Le #26566994
Salut,
Christophe PEREZ a tapoté le 04/02/2021 16:14:
Le Wed, 03 Feb 2021 19:49:54 +0100, yamo' a écrit :

Qui parle de http://ovcam.org/ov511/
Dont la dernière version date de 2006 pour noyau 2.6 ?
J'ai des doutes.

En effet...
Au besoin, les ressources nécessaires ont été archivées en 2009 :
Docanski aurait intérêt de suivre les conseils de Nicolas George dans
son message : --
Stéphane
docanski
Le #26566999
Nicolas George a écrit le 3/02/21 Í  19:50 :
Débranche la webcam. Lance dmesg -w, appuie sur entrée quelques fois pour
marquer l'endroit o͹ tu es. Branche la webcam.
Regarde les lignes qui apparaissent au branchement.

ça ne cesse de défiler ! pris au vol une partie du code :
Turbo EDCA =0xa42b
[ 3366.856074] RTW: Turbo EDCA =0x5ea42b
[ 3370.886584] RTW: rtw_set_ps_mode(wlxb44bd6240019) Enter 802.11 power
save - WIFI-TRAFFIC_IDLE
[ 3370.886589] RTW: rtl8821c_set_FwPwrMode_cmd(wlxb44bd6240019): HW port
id=0
[ 3370.886591] RTW: rtl8821c_set_FwPwrMode_cmd(wlxb44bd6240019): fw ps
mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
[ 3370.886593] RTW: rtl8821c_set_FwPwrMode_cmd=> psmode:02, smart_ps:02,
PowerState:00
[ 3370.888416] RTW: Turbo EDCA =0xa42b
[ 3370.888528] RTW: rtw_set_ps_mode(wlxb44bd6240019) Leave 802.11 power
save - WIFI-LPS_CTRL_PHYDM
[ 3370.888530] RTW: rtl8821c_set_FwPwrMode_cmd(wlxb44bd6240019): HW port
id=0
[ 3370.888532] RTW: rtl8821c_set_FwPwrMode_cmd(wlxb44bd6240019): fw ps
mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 2, allQueueUAPSD = 0
[ 3370.888534] RTW: rtl8821c_set_FwPwrMode_cmd=> psmode:00, smart_ps:02,
PowerState:0c
[ 3370.897139] RTW: rtw_set_ps_mode(wlxb44bd6240019) Enter 802.11 power
save - WIFI-LPS_CTRL_PHYDM
[ 3370.897143] RTW: rtl8821c_set_FwPwrMode_cmd(wlxb44bd6240019): HW port
id=0
[ 3370.897145] RTW: rtl8821c_set_FwPwrMode_cmd(wlxb44bd6240019): fw ps
mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
[ 3370.897146] RTW: rtl8821c_set_FwPwrMode_cmd=> psmode:02, smart_ps:02,
PowerState:00
[ 3372.902519] RTW: rtw_set_ps_mode(wlxb44bd6240019) Leave 802.11 power
save - WIFI-TRAFFIC_BUSY
[ 3372.902523] RTW: rtl8821c_set_FwPwrMode_cmd(wlxb44bd6240019): HW port
id=0
[ 3372.902525] RTW: rtl8821c_set_FwPwrMode_cmd(wlxb44bd6240019): fw ps
mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 2, allQueueUAPSD = 0
[ 3372.902527] RTW: rtl8821c_set_FwPwrMode_cmd=> psmode:00, smart_ps:02,
PowerState:0c

--
docanski
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les cÍ´tes du nord de la Bretagne : http://docarmor.free.fr/
Forum boursier : http://docanski.free.fr/boursomania/
Christophe PEREZ
Le #26567012
Le Thu, 04 Feb 2021 16:54:23 +0100, docanski a écrit :
pris au vol une partie du code

AMHA tu n'as pas pris la bonne partie.
Cherche les lignes qui correspondent Í  l'USB.
Par exemple, chez moi, au branchement de la webcam, j'ai :
[36716.284802] usb 1-11: USB disconnect, device number 4
[36719.497536] usb 1-11: new high-speed USB device number 5 using xhci_hcd
[36719.844583] uvcvideo: Found UVC 1.00 device <unnamed> (046d:081b)
[36719.958833] input: UVC Camera (046d:081b) as /devices/
pci0000:00/0000:00:14.0/usb1/1-11/1-11:1.0/input/input80
[36721.324412] usb 1-11: set resolution quirk: cval->res = 384
Nicolas George
Le #26567018
docanski , dans le message
ça ne cesse de défiler ! pris au vol une partie du code :

Bon, ben tu as un problème plus urgent Í  corriger.
[ 3370.886589] RTW: rtl8821c_set_FwPwrMode_cmd(wlxb44bd6240019): HW port

rtl8821c, c'est du wifi.
Bonne chance.
Poster une réponse
Anonyme