Debian Sarge: Crash du systeme lors d'une impression avec CUPS!

Le
Pascal C.
Je suis frustré Je viens d'installer une Debian Sarge
(noyau 2.6.9), et j'ai tenté d'installer ma HP 970cxi
d'abord par le port parallèle. Après avoir configuré
l'imprimante dans CUPS, j'imprime une page de test
et après 10% environ de la page, le PC reboote!

Les messages d'erreur semblent indiquer un problème
de gestion d'interruption. Port parallèle problématique?
Je la configure en USB. Là, freeze de KDE et terminé
(le PC ne répond plus, reboot avec le bouton reset).

Je tente alors de brancher l'imprimante sur mon PC
Windows 2000 et d'imprimer par samba. La page de test
s'imprime correctement, ouf! Mais quand j'essaye
d'imprimer depuis Firefox, l'application se crashe!
J'installe un LPD sous Windows, pareil! Je déinstalle
alors CUPS, et installe l'impression BSD LPR, et
j'arrive à imprimer via mon PC Windows. Mais je perds
les fonctionnalités CUPS. Je réinstalle CUPS, page
de test, et crash système à nouveau! Impossible
de rebooter, je boote alors en mode console root,
et apt-get remove cupsys et ensuite ça boote


La description de mon problème est certes un peu
longue, mais c'est pour dire que j'ai déjà essayé
pas mal de choses, et apparemment CUPS est buggé
chez moi. Le problème, c'est que sous KDE ou Gnome,
CUPS semble devenu incontournable. Je peux toujours
récupérer le printcap depuis une sauvegarde d'un
vieux PC Linux, mais je préfèrerais trouver une
solution avec CUPS (qui fonctionnait d'ailleurs
très bien depuis d'autres machines sous
Mandrake 10.1 et 9.1).

J'ai fait appel à Google pour trouver un problème
similaire, mais que dalle

C'est gênant pour moi de devoir faire imprimer mes
fichiers par Windows! D'autant que mis à part
cela, tout fonctionne parfaitement

Quelqu'un a-t-il une idée? Une suggestion?

Sinon, je reviendrai à LPR/LPD, mais bon
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Rakotomandimby (R12y) Mihamina
Le #1286007
( Wed, 02 Mar 2005 01:04:11 +0100 ) Pascal C. :

Quelqu'un a-t-il une idée? Une suggestion?


Fais voir la liste des paquetages CUPS que tu as ?

# dpkg -l | grep cups
# dpkg -l | grep hpijs

--
L'ASPO a pour but de démocratiser l'acces a l'informatique. Une de ses
activité est l'infogerance (http://aspo.rktmb.org/activites/infogerance)
Tél: + 33 2 38 04 26 04 ou + 33 6 33 26 13 14 (France)

Pascal C.
Le #1285980
Le Wed, 02 Mar 2005 07:40:57 +0100, Rakotomandimby (R12y) Mihamina a
écrit :

( Wed, 02 Mar 2005 01:04:11 +0100 ) Pascal C. :

Quelqu'un a-t-il une idée? Une suggestion?


Fais voir la liste des paquetages CUPS que tu as ?

# dpkg -l | grep cups
# dpkg -l | grep hpijs


J'ai viré cups provisoirement, car il me plante
ma machine si j'ai le malheur de lancer une
impression!

Mais j'avais fait une sauvegarde de ma liste de
paquetages:

cupsys install
cupsys-bsd install
cupsys-client install
cupsys-driver-gimpprint install
cupsys-driver-gimpprint-data install
gnome-cups-manager install
libcupsimage2 install
libcupsys2-gnutls10 install
libgnomecups1.0-1 install
libgnomecupsui1.0-1 install

foomatic-db-hpijs install
hpijs install

Ces pkg sont tous mis à jour à la dernière version
Debian Testing.

J'ai installé un noyau i686 pour mon Athlon, au lieu
du noyau k7. Mes recherches sur Internent tendent
à me faire penser que ça n'a pas d'importance, mais
qui sait?

Je n'ai jamais mis à jour un binaire du noyau
directement... J'ai juste à faire:
apt-get kernel-image-2.6.8-2-k7
Et GRUB et tout le reste sera mis à jour?

Mon problème m'obsède vraiment car ma Debian
fonctionne nickel... mis à part ça!

Si je ne trouve pas de solution, j'installerai
LPRng, qui a l'air de pouvoir répondre à mes
besoins... C'est surprenant quand même, CUPS
a toujours bien fonctionné chez moi, c'est la
première fois que j'ai une install qui me cause
des soucis!


Julien K.
Le #1237710
Pascal C. wrote:
Je suis frustré... Je viens d'installer une Debian Sarge (noyau 2.6.9),
et j'ai tenté d'installer ma HP 970cxi d'abord par le port parallèle.
Après avoir configuré l'imprimante dans CUPS, j'imprime une page de test
et après 10% environ de la page, le PC reboote!


Les messages d'erreur semblent indiquer un problème de gestion
d'interruption. Port parallèle problématique? Je la configure en USB. Là,
freeze de KDE et terminé (le PC ne répond plus, reboot avec le bouton
reset).


Ça marchait correctement avec un noyau 2.4.xx? J'ai un serveur Woody avec
Samba & CUPS qui viennent de Sarge et ça marche du tonnerre (imprimantes //
et USB) que ce soit en direct ou depuis les clients Win2k.

bye

JKr

--
I AM NOT THE REINCARNATION OF SAMMY DAVIS JR..
I AM NOT THE REINCARNATION OF SAMMY DAVIS JR..
I AM NOT THE REINCARNATION OF SAMMY DAVIS JR..
-+- Bart Simpson on chalkboard, episode #102

Pascal C.
Le #1238714
Le Thu, 03 Mar 2005 17:44:43 +0100, Julien K. a écrit :

Ça marchait correctement avec un noyau 2.4.xx? J'ai un serveur Woody avec
Samba & CUPS qui viennent de Sarge et ça marche du tonnerre (imprimantes //
et USB) que ce soit en direct ou depuis les clients Win2k.


Ben avant j'avais une Mandrake 9.1 avec un noyau 2.4.x,
et ça fonctionnait très bien avec l'imprimante soit
sur le PC Linux, soit sur le PC Windows, en imprimant
depuis l'un ou l'autre via Samba et/ou LPD.

Là, rien ne marche plus avec CUPS, ça crashe direct
et je dois faire un reset hardware, puis démarrer
en mode maintenance pour détruire le contenu
de /var/spool (sinon il relance l'impression au
démarrage du système et re-plante!).

Je viens de virer CUPS et de le remplacer par
LPRng, qui semble tout à fait suffisant pour mes
besoins. L'imprimante est branchée sous Windows,
et je peux imprimer en l'accédant directement par
LPR (donc en mode "raw"), mais impossible de
faire fonctionner la moindre file d'impression
(je ne sais pas ce qui foire, peut-être apsfilter...).
Rageant, d'autant plus que je n'ai jamais eu de
problème d'impression depuis mon premier Linux,
il y a bien 4 ou 5 ans!

Pascal C.
Le #1276032
Le Wed, 02 Mar 2005 01:04:11 +0100, Pascal C. a écrit :


Je suis frustré... Je viens d'installer une Debian Sarge
(noyau 2.6.9), et j'ai tenté d'installer ma HP 970cxi
d'abord par le port parallèle. Après avoir configuré
l'imprimante dans CUPS, j'imprime une page de test
et après 10% environ de la page, le PC reboote!


Bon, j'ai retiré une carte Firewire de mon
PC et depuis plus de plantages!

Ça imprimait depuis LPRng, alors j'ai fait
une bêtise: j'ai voulu rebasculer sur CUPS,
et depuis impossible de sortir la moindre page.
Apparemment, à force d'installer/bidouiller/
désinstaller, les fichiers de config sont devenus
n'importe quoi et je pense que CUPS ne retrouve
plus ses filtres. En revanche, le preview
et l'impression PDF fonctionnent bien.

Mais ceci est une autre histoire...
et un autre post à venir!

Je prépare une chronique de mes aventures
debianesques à mettre sur le web, j'espère
que ça aidera les gens tentés par Debian,
qui est une expérience assez intéressante!

Poster une réponse
Anonyme