[debian woody]2 ptits pb ( apt & fonts )

Le
Xavier Seneque
Salut,

quand je fait un "aptitude upgrade" ( ou que j'installe n'importe quoi
d'ailleurs à il me dis tout le temps "the following package have been
kept back" et "71 not upgraded" en gros, il a telecharger 71 .deb, et
veut pas me les installer

( y a du xfree, du gcc, du python, du libgnome, du emacs, du gdm, du
gimp )

( c'est depuis que je suis passé de stable à testing dans le sources.list )

pourquoi ?
comment les installer ?

deuxiemement concernant les fonts ( polices ), je trouve le texte
dans firebird, thunderbird, et dans les menus des applications enfin
un peu partout, les polices sont tres crenelées, ce qui fait que c pas
tres lisible

une idée sur comment résoudre ça ?
( les xfont-base et autres ont ete installée contrairement au
xfree-common et x-window-system-core lors du passage en testing )

merci d'avance !

--
Pour contacter l'équipe de modération : moderateurs-fcolm@efrei.fr
ATTENTION: Postez DIRECTEMENT vos articles dans le groupe, PAS dans
la liste de distribution des modérateurs.

  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Did0
Le #7145591
Xavier Seneque
quand je fait un "aptitude upgrade" ( ou que j'installe n'importe quoi
d'ailleurs à il me dis tout le temps "the following package have been
kept back" et "71 not upgraded"... en gros, il a telecharger 71 .deb,
et veut pas me les installer...
( y a du xfree, du gcc, du python, du libgnome, du emacs, du gdm, du
gimp... )
( c'est depuis que je suis passé de stable à testing dans le sources.list )
pourquoi ?
comment les installer ?


Il s'agit de paquets qui dépendent d'autres paquets non installés. Il
faut que tu fasses un "apt-get dist-upgrade" afin de permettre
l'installation de ces nouveaux paquets.

--
Dido

--
Pour contacter l'équipe de modération :
ATTENTION: Postez DIRECTEMENT vos articles dans le groupe, PAS dans
la liste de distribution des modérateurs.
NicoRoud
Le #7145501
Did0 a brillamment dit le 17.12.2003 15:05:
Xavier Seneque
quand je fait un "aptitude upgrade" ( ou que j'installe n'importe quoi
d'ailleurs à il me dis tout le temps "the following package have been
kept back" et "71 not upgraded"... en gros, il a telecharger 71 .deb,
et veut pas me les installer...
( y a du xfree, du gcc, du python, du libgnome, du emacs, du gdm, du
gimp... )
( c'est depuis que je suis passé de stable à testing dans le sources.list )
pourquoi ?
comment les installer ?



Il s'agit de paquets qui dépendent d'autres paquets non installés. Il
faut que tu fasses un "apt-get dist-upgrade" afin de permettre
l'installation de ces nouveaux paquets.



Moi je prefere la méthode dselect qui gère très bien les dépendances.

1/ Créer un ficheir /etc/apt/preferences qui contient :

Package: *
Pin: release a=testing
Pin-Priority: 600

Package: *
Pin: release a=unstable
Pin-Priority: 50

2/ taper :
# dselect update (met à jour la listes des paquets)
# dselect select (selectionne les paquets à installer/mettre à jour)
# dselect install (installe le tout)

--
Pour contacter l'équipe de modération :
ATTENTION: Postez DIRECTEMENT vos articles dans le groupe, PAS dans
la liste de distribution des modérateurs.
Publicité
Poster une réponse
Anonyme