Debugger NetBeans 3.6

Le
Bernard Koninckx
Bonjour à tous,

J'ai installé dernièrement la version 3.6 de NetBeans et souhaite travailler
avec celle-ci. J'ai cependant quelques problèmes en ce qui concerne le
debugging. En effet, lorsque je lance le debugger, NetBeans me signale
directement qu'il y a une erreur de configuration. J'ai beau chercher la
solution mais je ne la trouve pas. Quelqu'un aurait-il une idée ? Quelqu'un
aurait-il déjà rencontré ce problème et passer outre. Si oui comment
avez-vous fait ?

Merci à tous de votre collaboration, réponses, remarques, .

Bernard
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Samuel
Le #634238
Tu peux peut-être déjà balancer l'erreur...

Samos

"Bernard Koninckx" news:4084e4b9$0$11082$
Bonjour à tous,

J'ai installé dernièrement la version 3.6 de NetBeans et souhaite
travailler

avec celle-ci. J'ai cependant quelques problèmes en ce qui concerne le
debugging. En effet, lorsque je lance le debugger, NetBeans me signale
directement qu'il y a une erreur de configuration. J'ai beau chercher la
solution mais je ne la trouve pas. Quelqu'un aurait-il une idée ?
Quelqu'un

aurait-il déjà rencontré ce problème et passer outre. Si oui comment
avez-vous fait ?

Merci à tous de votre collaboration, réponses, remarques, ....

Bernard




Bernard Koninckx
Le #634237
J'y arrive pas, c'est une erreur de configuration du debugger ...
Y a certainement une option du compilateur ou autre chose a modifier pour
passer outre ce problème et utiliser le debugger NetBeans

Bernard

"Samuel" 4084ff9a$0$26438$
Tu peux peut-être déjà balancer l'erreur...

Samos

"Bernard Koninckx" news:4084e4b9$0$11082$
Bonjour à tous,

J'ai installé dernièrement la version 3.6 de NetBeans et souhaite
travailler

avec celle-ci. J'ai cependant quelques problèmes en ce qui concerne le
debugging. En effet, lorsque je lance le debugger, NetBeans me signale
directement qu'il y a une erreur de configuration. J'ai beau chercher la
solution mais je ne la trouve pas. Quelqu'un aurait-il une idée ?
Quelqu'un

aurait-il déjà rencontré ce problème et passer outre. Si oui comment
avez-vous fait ?

Merci à tous de votre collaboration, réponses, remarques, ....

Bernard








Bernard Koninckx
Le #634236
Ah oui, au cas où ça pourrait aider quelqu'un, ma configuration est la
suivante

JDK 1.2.4 04
NetBeans 3.6
(Ouin doze) Windows 98

Bernard

"Samuel" 4084ff9a$0$26438$
Tu peux peut-être déjà balancer l'erreur...

Samos

"Bernard Koninckx" news:4084e4b9$0$11082$
Bonjour à tous,

J'ai installé dernièrement la version 3.6 de NetBeans et souhaite
travailler

avec celle-ci. J'ai cependant quelques problèmes en ce qui concerne le
debugging. En effet, lorsque je lance le debugger, NetBeans me signale
directement qu'il y a une erreur de configuration. J'ai beau chercher la
solution mais je ne la trouve pas. Quelqu'un aurait-il une idée ?
Quelqu'un

aurait-il déjà rencontré ce problème et passer outre. Si oui comment
avez-vous fait ?

Merci à tous de votre collaboration, réponses, remarques, ....

Bernard








Vincent Brabant
Le #634231
Ah oui, au cas où ça pourrait aider quelqu'un, ma configuration est la
suivante

JDK 1.2.4 04
NetBeans 3.6
(Ouin doze) Windows 98

Bernard


Et il affiche quoi comme erreur ?


--
Vincent Brabant
----------------
http://www.netbeans.org/index_fr.html
http://vbrabant-fr.skynetblogs.be

Bernard Koninckx
Le #633976
Le debugger ne s'ouvre pas et le message suivant apparaît :


Incorrect Configuration
Exception while starting debugger :
Cannot start process c:j2sdk_nbj2sdk1.4.2binjava.exe
java.io.IOException: VM initialization failed


Dans l'onglet Process Output le message suivant apparaît:

FATAL ERROR in native method: No transports initialized
----------------------------------------------------------------------------
----
Ce qui se trouve dans l'onglet Debugger Console :

C:j2sdk_nbj2sdk1.4.2binjava.exe -Xdebug -Xnoagent -Xrunjdwp:transport=dt
_socket,address7.0.0.1:1323,suspend=y -Djava.compiler=NONE -classpath
"C:WINDOWS.netbeans3.6system;C:WINDOWS.netbeans3.6system;C:J2SDK_NB
NETBEANS3.6system;C:J2SDK_NBNETBEANS3.6modulesextAbsoluteLayout.jar;C
:J2SDK_NBNETBEANS3.6modulesextjunit-3.8.1.jar;C:J2SDK_NBNETBEANS3.6m
odulesextjunit-testrunner.jar;C:J2SDK_NBNETBEANS3.6modulesautoloadext
jsp-api-2.0.jar;C:J2SDK_NBNETBEANS3.6modulesautoloadextservlet-api-2.
4.jar;C:J2SDK_NBNETBEANS3.6beansTimerBean.jar;C:JavaProgsrc;C:j2sdk_n
bhibernate-2.1hibernate2.jar;C:j2sdk_nbhibernate-2.1libjboss-cache.jar
;C:j2sdk_nbhibernate-2.1libant-1.5.3.jar;C:j2sdk_nbhibernate-2.1liba
nt-optional-1.5.3.jar;C:j2sdk_nbhibernate-2.1libc3p0-0.8.3.jar;C:j2sdk_
nbhibernate-2.1libcglib-2.0-rc2.jar;C:j2sdk_nbhibernate-2.1libcommons
-collections-2.1.jar;C:j2sdk_nbhibernate-2.1libcommons-dbcp-1.1.jar;C:j
2sdk_nbhibernate-2.1libcommons-lang-1.0.1.jar;C:j2sdk_nbhibernate-2.1l
ibcommons-logging-1.0.3.jar;C:j2sdk_nbhibernate-2.1libcommons-pool-1.1.
jar;C:j2sdk_nbhibernate-2.1libconcurrent-1.3.2.jar;C:j2sdk_nbhibernate
-2.1libconnector.jar;C:j2sdk_nbhibernate-2.1libdom4j-1.4.jar;C:j2sdk_
nbhibernate-2.1libehcache-0.6.jar;C:j2sdk_nbhibernate-2.1libjaas.jar;
C:j2sdk_nbhibernate-2.1libjboss-common.jar;C:j2sdk_nbhibernate-2.1lib
jboss-jmx.jar;C:j2sdk_nbhibernate-2.1libjboss-system.jar;C:j2sdk_nbhi
bernate-2.1libjcs-1.0-dev.jar;C:j2sdk_nbhibernate-2.1libjdbc2_0-stdext
.jar;C:j2sdk_nbhibernate-2.1libjgroups-2.2.jar;C:j2sdk_nbhibernate-2.1
libjta.jar;C:j2sdk_nbhibernate-2.1libjunit-3.8.1.jar;C:j2sdk_nbhiber
nate-2.1liblog4j-1.2.8.jar;C:j2sdk_nbhibernate-2.1libodmg-3.0.jar;C:j
2sdk_nbhibernate-2.1liboscache-2.0.jar;C:j2sdk_nbhibernate-2.1libprox
ool-0.8.3.jar;C:j2sdk_nbhibernate-2.1libswarmcache-1.0rc2.jar;C:j2sdk_n
bhibernate-2.1libxalan-2.4.0.jar;C:j2sdk_nbhibernate-2.1libxerces-2.4
.0.jar;C:j2sdk_nbhibernate-2.1libxml-apis.jar;C:mysqlJDBCmysql-connec
tor-java-3.0.9-stablemysql-connector-java-3.0.9-stable-bin.jar;C:JavaProg
bin" com.jobsearch.application.JobSearch
err:: No such file or directory
Error [2] in gethostbyname() call!
Socket transport failed to init.
Transport dt_socket failed to initialize, rc = -1.

Comme ça je pense avoir été complet dans la description de problème

Bernard


"Vincent Brabant" news: 40851c4d$0$10885$
Ah oui, au cas où ça pourrait aider quelqu'un, ma configuration est la
suivante

JDK 1.2.4 04
NetBeans 3.6
(Ouin doze) Windows 98

Bernard


Et il affiche quoi comme erreur ?


--
Vincent Brabant
----------------
http://www.netbeans.org/index_fr.html
http://vbrabant-fr.skynetblogs.be




Vincent Brabant
Le #633972
Le debugger ne s'ouvre pas et le message suivant apparaît :


Incorrect Configuration
Exception while starting debugger :
Cannot start process c:j2sdk_nbj2sdk1.4.2binjava.exe
java.io.IOException: VM initialization failed


Dans l'onglet Process Output le message suivant apparaît:

FATAL ERROR in native method: No transports initialized
----------------------------------------------------------------------------
----
Ce qui se trouve dans l'onglet Debugger Console :


C:j2sdk_nbj2sdk1.4.2binjava.exe

-Xdebug
-Xnoagent
-Xrunjdwp:transport=dt_socket,address7.0.0.1:1323,suspend=y
-Djava.compiler=NONE
-classpath
"C:WINDOWS.netbeans3.6system;
C:WINDOWS.netbeans3.6system;
C:J2SDK_NBNETBEANS3.6system;
C:J2SDK_NBNETBEANS3.6modulesextAbsoluteLayout.jar;
C:J2SDK_NBNETBEANS3.6modulesextjunit-3.8.1.jar;
C:J2SDK_NBNETBEANS3.6modulesextjunit-testrunner.jar;
C:J2SDK_NBNETBEANS3.6modulesautoloadextjsp-api-2.0.jar;
C:J2SDK_NBNETBEANS3.6modulesautoloadextservlet-api-2.4.jar;
C:J2SDK_NBNETBEANS3.6beansTimerBean.jar;
C:JavaProgsrc;C:j2sdk_nbhibernate-2.1hibernate2.jar;
C:j2sdk_nbhibernate-2.1libjboss-cache.jar;
C:j2sdk_nbhibernate-2.1libant-1.5.3.jar;
C:j2sdk_nbhibernate-2.1libant-optional-1.5.3.jar;
C:j2sdk_nbhibernate-2.1libc3p0-0.8.3.jar;
C:j2sdk_nbhibernate-2.1libcglib-2.0-rc2.jar;
C:j2sdk_nbhibernate-2.1libcommons-collections-2.1.jar;
C:j2sdk_nbhibernate-2.1libcommons-dbcp-1.1.jar;
C:j2sdk_nbhibernate-2.1libcommons-lang-1.0.1.jar;
C:j2sdk_nbhibernate-2.1libcommons-logging-1.0.3.jar;
C:j2sdk_nbhibernate-2.1libcommons-pool-1.1.jar;
C:j2sdk_nbhibernate-2.1libconcurrent-1.3.2.jar;
C:j2sdk_nbhibernate-2.1libconnector.jar;
C:j2sdk_nbhibernate-2.1libdom4j-1.4.jar;
C:j2sdk_nbhibernate-2.1libehcache-0.6.jar;
C:j2sdk_nbhibernate-2.1libjaas.jar;
C:j2sdk_nbhibernate-2.1libjboss-common.jar;
C:j2sdk_nbhibernate-2.1libjboss-jmx.jar;
C:j2sdk_nbhibernate-2.1libjboss-system.jar;
C:j2sdk_nbhibernate-2.1libjcs-1.0-dev.jar;
C:j2sdk_nbhibernate-2.1libjdbc2_0-stdext..jar;
C:j2sdk_nbhibernate-2.1libjgroups-2.2.jar;
C:j2sdk_nbhibernate-2.1libjta.jar;
C:j2sdk_nbhibernate-2.1libjunit-3.8.1.jar;
C:j2sdk_nbhibernate-2.1liblog4j-1.2.8.jar;
C:j2sdk_nbhibernate-2.1libodmg-3.0.jar;
C:j2sdk_nbhibernate-2.1liboscache-2.0.jar;
C:j2sdk_nbhibernate-2.1libproxool-0.8.3.jar;
C:j2sdk_nbhibernate-2.1libswarmcache-1.0rc2.jar;
C:j2sdk_nbhibernate-2.1libxalan-2.4.0.jar;
C:j2sdk_nbhibernate-2.1libxerces-2.4..0.jar;
C:j2sdk_nbhibernate-2.1libxml-apis.jar;
C:mysqlJDBCmysql-connector-java-3.0.9-stablemysql-connector-java-3.0.9-stable-bin.jar;
C:JavaProgbin"
com.jobsearch.application.JobSearch
err:: No such file or directory


As tu vérifié que tous les fichiers et répertoire repris dans le
classpath ci-dessus existe bien ? Et qu'ils ont bien été introduit comme
il faut, sans faute ?
Je vois ici deux cas bizarres où il y a deux points qui apparaissent
l'un derrière l'autre:
C:j2sdk_nbhibernate-2.1libjdbc2_0-stdext..jar;
C:j2sdk_nbhibernate-2.1libxerces-2.4..0.jar;

Cela pourrait évidemment expliquer le message
"No such file or directory."


Error [2] in gethostbyname() call!
Socket transport failed to init.
Transport dt_socket failed to initialize, rc = -1.

Comme ça je pense avoir été complet dans la description de problème

Bernard


"Vincent Brabant" news: 40851c4d$0$10885$


Ah oui, au cas où ça pourrait aider quelqu'un, ma configuration est la
suivante

JDK 1.2.4 04
NetBeans 3.6
(Ouin doze) Windows 98

Bernard


Et il affiche quoi comme erreur ?


--
Vincent Brabant
----------------
http://www.netbeans.org/index_fr.html
http://vbrabant-fr.skynetblogs.be








--
Vincent Brabant
----------------
http://www.netbeans.org/index_fr.html
http://vbrabant-fr.skynetblogs.be



Pascal Pizeine
Le #633970
Sur le site de Sun où l'on peut télécharger la version 3.5.1 de NetBean
(http://java.sun.com/j2se/1.4.2/install_j2se142-nb351_windows.html) il n'y a
pas Windows 98 dans la liste des plateformes sur lesquelles ca marche, alors
pour une version encore plus récente ça risque de poser problème. Le
plantage viens peut être de la ?

Pascal

"Bernard Koninckx" news:40850167$0$11000$
Ah oui, au cas où ça pourrait aider quelqu'un, ma configuration est la
suivante

JDK 1.2.4 04
NetBeans 3.6
(Ouin doze) Windows 98

Bernard



Vincent Brabant
Le #633969
Sur le site de Sun où l'on peut télécharger la version 3.5.1 de NetBean
(http://java.sun.com/j2se/1.4.2/install_j2se142-nb351_windows.html) il n'y a
pas Windows 98 dans la liste des plateformes sur lesquelles ca marche, alors
pour une version encore plus récente ça risque de poser problème. Le
plantage viens peut être de la ?

Pascal
Ben non, car je tourne le 3.6 et même le 4.0(Preview) sous Win98. Et ce,

sans aucun problème.

La seule raison pour laquelle ils ne supportent pas officiellement Win98
est qu'ils ne possèdent plus de Win98 chez eux.
Donc
impossible de faire les tests sous Win98
de vérifier les problèmes que les utilisateurs Win98 remontent.
d'être sûr que la procédure d'installation fonctionne sous Win98.



"Bernard Koninckx" news:40850167$0$11000$

Ah oui, au cas où ça pourrait aider quelqu'un, ma configuration est la
suivante

JDK 1.2.4 04
NetBeans 3.6
(Ouin doze) Windows 98

Bernard








--
Vincent Brabant
----------------
http://www.netbeans.org/index_fr.html
http://vbrabant-fr.skynetblogs.be


Bernard Koninckx
Le #633968
La version 3.5.1 fonctionne correctement mais je préfère utiliser la 3.6

Bernard

"Pascal Pizeine" news: c63f4s$lus$
Sur le site de Sun où l'on peut télécharger la version 3.5.1 de NetBean
(http://java.sun.com/j2se/1.4.2/install_j2se142-nb351_windows.html) il n'y
a

pas Windows 98 dans la liste des plateformes sur lesquelles ca marche,
alors

pour une version encore plus récente ça risque de poser problème. Le
plantage viens peut être de la ?

Pascal

"Bernard Koninckx" news:40850167$0$11000$
Ah oui, au cas où ça pourrait aider quelqu'un, ma configuration est la
suivante

JDK 1.2.4 04
NetBeans 3.6
(Ouin doze) Windows 98

Bernard







Bernard Koninckx
Le #633748
Je vais déjà vérifier tout ça ...
Je reposterai si j'ai toujours le même problème.

Bernard

"Vincent Brabant" news: 4085302a$0$10887$
Le debugger ne s'ouvre pas et le message suivant apparaît :


Incorrect Configuration
Exception while starting debugger :
Cannot start process c:j2sdk_nbj2sdk1.4.2binjava.exe
java.io.IOException: VM initialization failed


Dans l'onglet Process Output le message suivant apparaît:

FATAL ERROR in native method: No transports initialized


--------------------------------------------------------------------------
--

----
Ce qui se trouve dans l'onglet Debugger Console :


C:j2sdk_nbj2sdk1.4.2binjava.exe

-Xdebug
-Xnoagent
-Xrunjdwp:transport=dt_socket,address7.0.0.1:1323,suspend=y
-Djava.compiler=NONE
-classpath
"C:WINDOWS.netbeans3.6system;
C:WINDOWS.netbeans3.6system;
C:J2SDK_NBNETBEANS3.6system;
C:J2SDK_NBNETBEANS3.6modulesextAbsoluteLayout.jar;
C:J2SDK_NBNETBEANS3.6modulesextjunit-3.8.1.jar;
C:J2SDK_NBNETBEANS3.6modulesextjunit-testrunner.jar;
C:J2SDK_NBNETBEANS3.6modulesautoloadextjsp-api-2.0.jar;
C:J2SDK_NBNETBEANS3.6modulesautoloadextservlet-api-2.4.jar;
C:J2SDK_NBNETBEANS3.6beansTimerBean.jar;
C:JavaProgsrc;C:j2sdk_nbhibernate-2.1hibernate2.jar;
C:j2sdk_nbhibernate-2.1libjboss-cache.jar;
C:j2sdk_nbhibernate-2.1libant-1.5.3.jar;
C:j2sdk_nbhibernate-2.1libant-optional-1.5.3.jar;
C:j2sdk_nbhibernate-2.1libc3p0-0.8.3.jar;
C:j2sdk_nbhibernate-2.1libcglib-2.0-rc2.jar;
C:j2sdk_nbhibernate-2.1libcommons-collections-2.1.jar;
C:j2sdk_nbhibernate-2.1libcommons-dbcp-1.1.jar;
C:j2sdk_nbhibernate-2.1libcommons-lang-1.0.1.jar;
C:j2sdk_nbhibernate-2.1libcommons-logging-1.0.3.jar;
C:j2sdk_nbhibernate-2.1libcommons-pool-1.1.jar;
C:j2sdk_nbhibernate-2.1libconcurrent-1.3.2.jar;
C:j2sdk_nbhibernate-2.1libconnector.jar;
C:j2sdk_nbhibernate-2.1libdom4j-1.4.jar;
C:j2sdk_nbhibernate-2.1libehcache-0.6.jar;
C:j2sdk_nbhibernate-2.1libjaas.jar;
C:j2sdk_nbhibernate-2.1libjboss-common.jar;
C:j2sdk_nbhibernate-2.1libjboss-jmx.jar;
C:j2sdk_nbhibernate-2.1libjboss-system.jar;
C:j2sdk_nbhibernate-2.1libjcs-1.0-dev.jar;
C:j2sdk_nbhibernate-2.1libjdbc2_0-stdext..jar;
C:j2sdk_nbhibernate-2.1libjgroups-2.2.jar;
C:j2sdk_nbhibernate-2.1libjta.jar;
C:j2sdk_nbhibernate-2.1libjunit-3.8.1.jar;
C:j2sdk_nbhibernate-2.1liblog4j-1.2.8.jar;
C:j2sdk_nbhibernate-2.1libodmg-3.0.jar;
C:j2sdk_nbhibernate-2.1liboscache-2.0.jar;
C:j2sdk_nbhibernate-2.1libproxool-0.8.3.jar;
C:j2sdk_nbhibernate-2.1libswarmcache-1.0rc2.jar;
C:j2sdk_nbhibernate-2.1libxalan-2.4.0.jar;
C:j2sdk_nbhibernate-2.1libxerces-2.4..0.jar;
C:j2sdk_nbhibernate-2.1libxml-apis.jar;

C:mysqlJDBCmysql-connector-java-3.0.9-stablemysql-connector-java-3.0.9-s

table-bin.jar;
C:JavaProgbin"
com.jobsearch.application.JobSearch
err:: No such file or directory


As tu vérifié que tous les fichiers et répertoire repris dans le
classpath ci-dessus existe bien ? Et qu'ils ont bien été introduit comme
il faut, sans faute ?
Je vois ici deux cas bizarres où il y a deux points qui apparaissent
l'un derrière l'autre:
C:j2sdk_nbhibernate-2.1libjdbc2_0-stdext..jar;
C:j2sdk_nbhibernate-2.1libxerces-2.4..0.jar;

Cela pourrait évidemment expliquer le message
"No such file or directory."


Error [2] in gethostbyname() call!
Socket transport failed to init.
Transport dt_socket failed to initialize, rc = -1.

Comme ça je pense avoir été complet dans la description de problème

Bernard


"Vincent Brabant" news: 40851c4d$0$10885$


Ah oui, au cas où ça pourrait aider quelqu'un, ma configuration est la
suivante

JDK 1.2.4 04
NetBeans 3.6
(Ouin doze) Windows 98

Bernard


Et il affiche quoi comme erreur ?


--
Vincent Brabant
----------------
http://www.netbeans.org/index_fr.html
http://vbrabant-fr.skynetblogs.be








--
Vincent Brabant
----------------
http://www.netbeans.org/index_fr.html
http://vbrabant-fr.skynetblogs.be






Publicité
Poster une réponse
Anonyme