Défaire une mise à jour sous Mint

Le
Lucas Levrel
Bonjour,

Je fais les mises à jour de façon très espacée. Je me suis récemment
aperçu qu'un programme, que j'utilise sporadiquement lui aussi, ne marche
plus.

Heureusement, entre la dernière utilisation réussie et le premier échec de
lancement du programme, je n'ai fait qu'une seule opération de mise à
jour, environ 80 paquets. Je voudrais essayer de revenir aux versions
antérieures pour vérifier que c'est bien l'origine de la panne, et ensuite
trouver le coupable par dichotomie.

Le problème est qu'avec synaptic, si je cherche à rétrograder un paquet
dont dépend un autre paquet, ça bloque. J'ai l'impression qu'il me
faudrait l'arbre des dépendances pour commencer par les feuilles, et
encore mais même comme ça, à la main 80 paquets ça fait beaucoup.

Quelle commande utiliser pour rétrograder d'un coup un ensemble de
paquets ? Créer un fichier d'entrée avec la liste des paquets et les
versions souhaitées dans un format kivabien ne me poserait pas de
problème.

--
LL
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Benoit Izac
Le #26553430
Bonjour,
Le 26/08/2020 à 19:16, Lucas Levrel a écrit dans le message
Je fais les mises à jour de façon très espacée. Je me suis récemment
aperçu qu'un programme, que j'utilise sporadiquement lui aussi, ne
marche plus.
Heureusement, entre la dernière utilisation réussie et le premier
échec de lancement du programme, je n'ai fait qu'une seule opération
de mise à jour, environ 80 paquets. Je voudrais essayer de revenir aux
versions antérieures pour vérifier que c'est bien l'origine de la
panne, et ensuite trouver le coupable par dichotomie.
Le problème est qu'avec synaptic, si je cherche à rétrograder un
paquet dont dépend un autre paquet, ça bloque. J'ai l'impression qu'il
me faudrait l'arbre des dépendances pour commencer par les feuilles,
et encore... mais même comme ça, à la main 80 paquets ça fait
beaucoup.
Quelle commande utiliser pour rétrograder d'un coup un ensemble de
paquets ? Créer un fichier d'entrée avec la liste des paquets et les
versions souhaitées dans un format kivabien ne me poserait pas de
problème.

Tu dois pouvoir t'en sortir en regardant dans /var/log/dpkg.log ce qui
a été mise à jour ce jour là. Un truc du genre :
apt-get install $(
awk '/^2020-08-25 [0-9:]{8} upgrade /{print $4"="$5}' /var/log/dpkg.log)
Pour revenir en arrière de ce qui a été mis à jour le 25/08/2020.
--
Benoit Izac
Lucas Levrel
Le #26553482
Le 26 août 2020, à 20:59, Benoit Izac a écrit :
Bonjour,
Le 26/08/2020 à 19:16, Lucas Levrel a écrit dans le message
Quelle commande utiliser pour rétrograder d'un coup un ensemble de
paquets ? Créer un fichier d'entrée avec la liste des paquets et les
versions souhaitées dans un format kivabien ne me poserait pas de
problème.

Tu dois pouvoir t'en sortir en regardant dans /var/log/dpkg.log ce qui
a été mise à jour ce jour là. Un truc du genre :
apt-get install $(
awk '/^2020-08-25 [0-9:]{8} upgrade /{print $4"="$5}' /var/log/dpkg.log)
Pour revenir en arrière de ce qui a été mis à jour le 25/08/2020.

Merci Benoît de m'avoir mâché le travail !
J'en déduis que la syntaxe est :
apt-get install paquet1=version1 paquet2=version2 ...
--
LL
Benoit Izac
Le #26553502
Bonjour,
Le 27/08/2020 à 15:23, Lucas Levrel a écrit dans le message
Quelle commande utiliser pour rétrograder d'un coup un ensemble de
paquets ? Créer un fichier d'entrée avec la liste des paquets et les
versions souhaitées dans un format kivabien ne me poserait pas de
problème.

Tu dois pouvoir t'en sortir en regardant dans /var/log/dpkg.log ce qui
a été mise à jour ce jour là. Un truc du genre :
apt-get install $(
awk '/^2020-08-25 [0-9:]{8} upgrade /{print $4"="$5}' /var/log/dpkg.log)
Pour revenir en arrière de ce qui a été mis à jour le 25/08/2020.

Merci Benoît de m'avoir mâché le travail !
J'en déduis que la syntaxe est :
apt-get install paquet1=version1 paquet2=version2 ...

Tout à fait.
--
Benoit Izac
Lulu
Le #26553565
Le 26-08-2020, Lucas Levrel
Bonjour,

Bonjour,
Je fais les mises à jour de façon très espacée. Je me suis récemment
aperçu qu'un programme, que j'utilise sporadiquement lui aussi, ne marche
plus.
Heureusement, entre la dernière utilisation réussie et le premier échec de
lancement du programme, je n'ai fait qu'une seule opération de mise à
jour, environ 80 paquets. Je voudrais essayer de revenir aux versions
antérieures pour vérifier que c'est bien l'origine de la panne, et ensuite
trouver le coupable par dichotomie.
Le problème est qu'avec synaptic, si je cherche à rétrograder un paquet
dont dépend un autre paquet, ça bloque. J'ai l'impression qu'il me
faudrait l'arbre des dépendances pour commencer par les feuilles, et
encore... mais même comme ça, à la main 80 paquets ça fait beaucoup.
Quelle commande utiliser pour rétrograder d'un coup un ensemble de
paquets ? Créer un fichier d'entrée avec la liste des paquets et les
versions souhaitées dans un format kivabien ne me poserait pas de
problème.

Linux Mint installe timeshisft par défaut (Administration/Timeshift) qui
effectue des "instantanés" du système régulièrement.
La solution serait donc de revenir à la dernière situation antérieure
connue où le problème ne se posait pas puis de restaurer la sauvegarde
de tes fichiers persos.
Évidemment timeshift n'a d'utilité que si tu disposes _par ailleurs_
d'une sauvegarde de tes fichiers persos (rsync roulaize).
Lucas Levrel
Le #26555496
Bonjour,
Je me colle enfin à ce problème dont je n'avais pas encore eu le temps de
m'occuper.
Le 26 août 2020, à 20:59, Benoit Izac a écrit :
Bonjour,
Le 26/08/2020 à 19:16, Lucas Levrel a écrit dans le message
Je fais les mises à jour de façon très espacée. Je me suis récemment
aperçu qu'un programme, que j'utilise sporadiquement lui aussi, ne
marche plus.
Heureusement, entre la dernière utilisation réussie et le premier
échec de lancement du programme, je n'ai fait qu'une seule opération
de mise à jour, environ 80 paquets. Je voudrais essayer de revenir aux
versions antérieures pour vérifier que c'est bien l'origine de la
panne, et ensuite trouver le coupable par dichotomie.
Le problème est qu'avec synaptic, si je cherche à rétrograder un
paquet dont dépend un autre paquet, ça bloque. J'ai l'impression qu'il
me faudrait l'arbre des dépendances pour commencer par les feuilles,
et encore... mais même comme ça, à la main 80 paquets ça fait
beaucoup.
Quelle commande utiliser pour rétrograder d'un coup un ensemble de
paquets ? Créer un fichier d'entrée avec la liste des paquets et les
versions souhaitées dans un format kivabien ne me poserait pas de
problème.

Tu dois pouvoir t'en sortir en regardant dans /var/log/dpkg.log ce qui
a été mise à jour ce jour là. Un truc du genre :
apt-get install $(
awk '/^2020-08-25 [0-9:]{8} upgrade /{print $4"="$5}' /var/log/dpkg.log)
Pour revenir en arrière de ce qui a été mis à jour le 25/08/2020.


Problème : les versions qui avaient été remplacées ont disparu des dépôts.
Si je comprends bien, c'étaient elles-mêmes des mises à jour, elles ont
été « superseded ». Exemple complètement au pif : libisccfg160 était en
version 1:9.11.3+dfsg-1ubuntu1.8, remplacée par la (...)1.11 (elle-même
remplacée, depuis, par la 1.13). Dans les dépôts on ne trouve que la
dernière version, et la toute première de la série, 1:9.11.3+dfsg-1ubuntu1 .
Existe-t-il un dépôt où sont conservées les versions intermédiaires ?
Depuis https://launchpad.net/ubuntu/bionic/amd64/libisccfg160/ (exemple)
je peux télécharger à la main le .deb qui va bien, mais le lien
(http://launchpadlibrarian.net/429354908/libisccfg160_9.11.3+dfsg-1ubuntu1.8_amd64.deb)
contient un hash donc pas moyen de scripter facilement le téléchargement,
depuis cette source, des 80 paquets que je veux rétrograder...
--
LL
Poster une réponse
Anonyme