Demarrage Debian 8 impossible suite mise à jour.

Le
elekaj 34
--001a11453266dcb458056335be00
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

Bonjour,

Je viens requêter votre aide, car mon installation Debian est bien mal=
ade.

Le contexte :
L'installation en question est un VM sur un Proxmox 3.2-4.
Comme de nombreuses fois par le passé, je fais un apt-get update suivi=
d'un
apt-get upgrade pour mettre à jour mon installation (mise à jour =
d'une VM,
pas du serveur Proxmox en lui-même).
Je reboote et là toujours pas d'accès SSH plusieurs minutes apr=
ès le boot.

Je décide donc d'aller dans l'interface Web de Proxmox, je lance la co=
nsole
de la VM malade est là j'ai plusieurs erreur :

[FAILED] Failed to start Load/Save Random Seed
See 'systemctl status systemd-random-seed.service' for details
[FAILED] Failed to start Various fixups to make systemd work better on
Debian
See 'systemctl status debian-fixup.service' for details

Ensuite pas mal de OK mais ensuite çà se gâte de nouveau :

[FAILED] Failed to listen on D-Bus System Message Bus Socket.
See 'systemctl status dbus.socket' for details
[DEPEND] Dependency failed for D-Bus System Message Bus

Puis les erreurs des services installés qui n'arrive pas à d=
marrer (comme
le serveur SSH par exemple).

Pour le problème du random seed, le fichier random-seed dans
/var/lib/systemd était bien présent mais j'ai par "précautio=
n" j'ai
supprimé le fichier et lancé la commande suivante :
systemctl start systemd-random-seed.service
Le fichier est toujours là :
-rw- 1 root root 512 janv. 20 13:57 random-seed

J'ai eu beau lire un tas de docs, je ne trouve pas le pourquoi du comment
de ce plantage au démarrage :(
Idem pour D-Bus :(

J'ai refait la procédure apt-get update suivi d'un apt-get upgrade et =

j'ai l'erreur suivante :
Vous pouvez lancer apt-get -f install pour corriger ces problèmes
Les paquets suivants contiennent des dépendances non satisfaites :
bind 9 : Dépend: libbind9-90 (= 1:9.9.5.dfsg-9+deb8u14) mais
1:9.9.5.dfsg-9+deb8u15 est installé
Dépend: libdns100 (= 1:9.9.5.dfsg-9+deb8u14) mais
1:9.9.5.dfsg-9+deb8u15 est installé
Dépend: libics95 (= 1:9.9.5.dfsg-9+deb8u14) mais
1:9.9.5.dfsg-9+deb8u15 est installé
Dépend: libisccc90 (= 1:9.9.5.dfsg-9+deb8u14) mais
1:9.9.5.dfsg-9+deb8u15 est installé
Dépend: libisccfg90 (= 1:9.9.5.dfsg-9+deb8u14) mais
1:9.9.5.dfsg-9+deb8u15 est installé
Dépend: liblwres90 (= 1:9.9.5.dfsg-9+deb8u14) mais
1:9.9.5.dfsg-9+deb8u15 est installé
Dépend: bind9utils (= 1:9.9.5.dfsg-9+deb8u14) mais
1:9.9.5.dfsg-9+deb8u15 est installé

Évidemment lors d'un apt-get -f install je me fait insulter :

Dépaquetage de bind9 (1:9.9.5.dfsg-9+deb8u15) sur (1:9.9.5.dfsg-9+deb8=
u14)

dpkg: erreur de traitement de l'archive
/var/cache/apt/archives/bind9-1%3a9.9.5.dfsg-9+deb8u15_amd64.deb (--unppack=
)
tentative de remplacement de /var/run, qui appartient aussi au paquet
base-files 8+deb8u10
dpkg-deb : erreur : le sous-processus coller a été tué par l=
e signal Relais
brisé (pipe)
Des erreurs ont été rencontrées pendant l'éxécutio=
n :
/var/cache/apt/archives/bind9-1%3a9.9.5.dfsg-9+deb8u15_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Des idées pouvant m'aider à résoudre mon soucis ?

PS : Désolé pour la longueur j'ai essayé d'être le plus=
exhaustif possible
malgré les nombreuses manip et lecture a droite à gauche !

Alain

--001a11453266dcb458056335be00
Content-Type: text/html; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

<div dir="ltr"><div><div><div><div><div><div><div><div>Bonjour,<br><br></=
div>Je viens requêter votre aide, car mon installation Debian est bien=
malade.<br><br></div>Le contexte :</div><div>L&#39;installation en questio=
n est un VM sur un Proxmox 3.2-4.<br></div>Comme de nombreuses fois par le =
passé, je fais un apt-get update suivi d&#39;un apt-get upgrade pour m=
ettre à jour mon installation (mise à jour d&#39;une VM, pas du s=
erveur Proxmox en lui-même).<br></div>Je reboote et là toujours p=
as d&#39;accès SSH plusieurs minutes après le boot.<br><br></div>=
Je décide donc d&#39;aller dans l&#39;interface Web de Proxmox, je lan=
ce la console de la VM malade est là j&#39;ai plusieurs erreur :<br></=
div><br></div><div>[FAILED] Failed to start Load/Save Random Seed<br></div>=
See &#39;systemctl status systemd-random-seed.service&#39; for details<br><=
/div>[FAILED] Failed to start Various fixups to make systemd work better on=
Debian<br>See &#39;systemctl status debian-fixup.service&#39; for details<=
br><div><div><div><br></div><div>Ensuite pas mal de OK mais ensuite ç=
à se gâte de nouveau : <br></div><div><br></div><div>[FAILED] Fai=
led to listen on D-Bus System Message Bus Socket.</div><div>See &#39;system=
ctl status dbus.socket&#39; for details<br><div>[DEPEND] Dependency failed =
for D-Bus System Message Bus</div><div><br></div><div>Puis les erreurs des =
services installés qui n&#39;arrive pas à démarrer (comme le=
serveur SSH par exemple).</div><div><br></div>Pour le problème du ran=
dom seed, le fichier random-seed dans /var/lib/systemd était bien pr=
ésent mais j&#39;ai par &quot;précaution&quot; j&#39;ai supprim=
é le fichier et lancé la commande suivante : <br></div><div>syste=
mctl start systemd-random-seed.service</div><div>Le fichier est toujours l=
à :<br></div><div><div>-rw- 1 root root  512 janv. 20 13:57=
random-seed</div><div><br></div></div><div>J&#39;ai eu beau lire un tas de=
docs, je ne trouve pas le pourquoi du comment de ce plantage au démar=
rage :( <br></div><div>Idem pour D-Bus :(</div><div><br></div><div>J&#39;ai=
refait la procédure apt-get update suivi d&#39;un apt-get upgrade et =
là j&#39;ai l&#39;erreur suivante : <br></div><div>Vous pouvez lancer =
apt-get -f install pour corriger ces problèmes</div><div>Les paquets s=
uivants contiennent des dépendances non satisfaites :</div><div> =
bind 9 : Dépend: libbind9-90 (= 1:9.9.5.dfsg-9+deb8u14) mais 1:9.9.5=
.dfsg-9+deb8u15 est installé</div><div>     =
        Dépend: libdns100 (= 1:9.=
9.5.dfsg-9+deb8u14) mais 1:9.9.5.dfsg-9+deb8u15 est installé <br></div=
><div><div>          =
  Dépend: libics95 (= 1:9.9.5.dfsg-9+deb8u14) mais 1:9.9.5.d=
fsg-9+deb8u15 est installé <br></div><div><div>   =
         Dépend: libisccc90=
(= 1:9.9.5.dfsg-9+deb8u14) mais 1:9.9.5.dfsg-9+deb8u15 est installé=
<br></div><div><div>         =
    Dépend: libisccfg90 (= 1:9.9.5.dfsg-9+deb8u14) ma=
is 1:9.9.5.dfsg-9+deb8u15 est installé <br></div><div><div> =
           Dépend=
: liblwres90 (= 1:9.9.5.dfsg-9+deb8u14) mais 1:9.9.5.dfsg-9+deb8u15 est i=
nstallé <br></div><div><div>       =
      Dépend: bind9utils (= 1:9.9.5.dfsg-9+=
deb8u14) mais 1:9.9.5.dfsg-9+deb8u15 est installé <br></div><div><br><=
/div></div></div></div></div></div><div>Évidemment lors d&#39;un apt-g=
et -f install je me fait insulter : <br></div><div><br></div><div>Dépa=
quetage de bind9 (1:9.9.5.dfsg-9+deb8u15<span class="gmail-">) </span>sur=
(1:9.9.5.dfsg-9+deb8u14) </div><div>dpkg: erreur de traitement de l&#39=
;archive /var/cache/apt/archives/bind9-1%3a9.9.5.dfsg-9+deb8u15_amd64.deb (=
--unppack)</div><div>tentative de remplacement de /var/run, qui appartient =
aussi au paquet base-files 8+deb8u10</div><div>dpkg-deb : erreur : le sous-=
processus coller a été tué par le signal Relais brisé (=
pipe)</div><div>Des erreurs ont été rencontrées pendant l&#3=
9;éxécution :</div><div> /var/cache/apt/archives/bind9-1%3a9.9.5.=
dfsg-9+deb8u15_amd64.deb</div><div>E: Sub-process /usr/bin/dpkg returned an=
error code (1)</div><div><br></div><div><br></div><div></div><div>Des id=
ées pouvant m&#39;aider à résoudre mon soucis ?<br></div><di=
v><div><div><br></div><div>PS : Désolé pour la longueur j&#39;ai =
essayé d&#39;être le plus exhaustif possible malgré les nomb=
reuses manip et lecture a droite à gauche !</div><div><br clear="all=
"></div><div><div><div><div><div><div><div class="gmail_signature"><div s=
tyle="margin:0px"><p style="margin:0px 0px 0cm"><font face="Arial, sa=
ns-serif">Alain</font></p><p style="margin:0px 0px 0cm"><font face="Ari=
al, sans-serif"><br></font></p></div><div style="margin:0px;font-family:a=
rial,helvetica,sans-serif;font-size:16px"></div></div></div>
</div></div></div></div></div></div></div></div></div></div>

--001a11453266dcb458056335be00--
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
hamster
Le #26460589
Le 21/01/2018 à 09:56, elekaj 34 a écrit :
Oui aucune partition n'est saturée et l'espace disque est largement
bon (36% d'utilisation pour le /home, partition la plus "utilisée")

Il y a un problème récurrent que j'ai rencontré sous ubuntu. D'habitude
débian le fait pas mais tu perds rien a essayer. La partition racine
semble ne pas etre pleine, et en effet elle ne l'est pas en termes
d'octets, par contre elle l'est en terme d'inodes. C'est les différentes
versions des noyaux qui bouffent tous les inodes disponibles.
Le diagnostic se fait avec df -i
Le curatif se fait en supprimant les anciennes versions des noyaux sauf
les deux dernières et ca remarche pour un certain nombre de mises a jour
jusqu'a ce ca replante. J'avais donc fait un script qui fait le ménage
automatiquement tout les mois pour régler le problème de facon définitive.
http://www.suna.fdn.fr/liens/menage-noyaux
Alban Vidal
Le #26460685
Bonjour,
On 01/21/2018 04:51 PM, hamster wrote:
Le diagnostic se fait avec df -i

Oui c'est vrai, vérifier les inodes c'est pas mal aussi.
On 01/21/2018 09:56 AM, elekaj 34 wrote:
Mais au boot j'ai toujours les messages relatif à random-seed et
various-fixup !

Les fichiers suivants existent-ils ?
ls -l /dev/random
ls -l /dev/urandom
Et quel est le statu actuel du service « systemd-random-seed.service »
systemctl status systemd-random-seed.service
Et les logs du même service :
journalctl -b -u systemd-random-seed.service
Cordialement,
Alban
Publicité
Poster une réponse
Anonyme