Déploiement package MSI via GPO

Le
Zylwee
Bonjour,

j'ai écrit un programme en Visual C# (Visual Studio Net 2005).
j'ai créé, toujours sous VS.Net, un package MSI d'installation de mon
programme.

j'ai sur un serveur de domaine créé le package MSI d'installation
administrative (msiexec -a monprog.msi).

j'ai créé, dans les GPOs une règle de déploiement du package créé.

j'ai (chance ou pas) 3 domaines :
D1 : 1 serveur contrôleur de domaine 2003
D2 : 2 serveurs contrôleurs de domaine 2003
D3 : 2 serveurs contrôleurs de domaine 2000

sur D1 : l'installation se déroule sans problème
sur D2 et sur D3 :
quand l'ordinateur démarre, le PC tente d'installer mon PACK MSI
(donc les GPOs sont trouvées correctement), mais :

l'installation se déroule correctement si et seulement si,
quand l'ordinateur démarre, le partage (et donc mon pack MSI) se
trouve sur le contrôleur contacté par la machine pour se connecter. Si
ce n'est pas le cas, dans les fichiers évènement de l'ordinateur, un
entrée est créée comme quoi la source n'a pu être trouvée.

quelqu'un aurait-il une idée ?

Merci,

Zylwee
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
nospheratus
Le #477431
Salut,

Dans ta stratégie, as-tu bien mis le chemin complet d'accès au package ?
\serveurpartagefichier.msi ?

--
NosPHeratus
http://www.nosland.com
"Zylwee" news:%
Bonjour,

j'ai écrit un programme en Visual C# (Visual Studio Net 2005).
j'ai créé, toujours sous VS.Net, un package MSI d'installation de mon
programme.

j'ai sur un serveur de domaine créé le package MSI d'installation
administrative (msiexec -a monprog.msi).

j'ai créé, dans les GPOs une règle de déploiement du package créé.

j'ai (chance ou pas) 3 domaines :
D1 : 1 serveur contrôleur de domaine 2003
D2 : 2 serveurs contrôleurs de domaine 2003
D3 : 2 serveurs contrôleurs de domaine 2000

sur D1 : l'installation se déroule sans problème
sur D2 et sur D3 :
quand l'ordinateur démarre, le PC tente d'installer mon PACK MSI
(donc les GPOs sont trouvées correctement), mais :

l'installation se déroule correctement si et seulement si,
quand l'ordinateur démarre, le partage (et donc mon pack MSI) se
trouve sur le contrôleur contacté par la machine pour se connecter. Si
ce n'est pas le cas, dans les fichiers évènement de l'ordinateur, un
entrée est créée comme quoi la source n'a pu être trouvée.

quelqu'un aurait-il une idée ?

Merci,

Zylwee


Zylwee
Le #477427
Bonjour,

Salut,

Dans ta stratégie, as-tu bien mis le chemin complet d'accès au package ?
\serveurpartagefichier.msi ?

tout à fait. (j'ai même essayé une variante style

\mon.adresse.ip.serveurPartagefichier.msi)

j'ai vérifié les droits (NTFS & partage)

y'aurait-il une piste à chercher du coté des rôles des serveurs ?

Merci,

Zylwee

nospheratus
Le #477426
"Zylwee" news:e$
Bonjour,

Salut,

Dans ta stratégie, as-tu bien mis le chemin complet d'accès au package
?


\serveurpartagefichier.msi ?

tout à fait. (j'ai même essayé une variante style

\mon.adresse.ip.serveurPartagefichier.msi)

j'ai vérifié les droits (NTFS & partage)

y'aurait-il une piste à chercher du coté des rôles des serveurs ?

Merci,

Zylwee


Oui jepense car je ne vois pas trop pourqyuoi ça passerait surle D1 et pas
sur les autres. Tes relations d'abbrobations sont ptre pas correctement
paramètrer. J'ai franchement pas bcp d'idée sur le pourquoi du comment là.
Désolé.
--
NosPHeratus
http://www.nosland.com


Zylwee
Le #477425
Re-

Oui jepense car je ne vois pas trop pourqyuoi ça passerait surle D1 et pas
sur les autres. Tes relations d'abbrobations sont ptre pas correctement
paramètrer.


les relations d'approbations ne devraient pas intervenir,
ce sont des domaines indépendants, et je créée un point d'installation
différent pour chaque domaine.


J'ai franchement pas bcp d'idée sur le pourquoi du comment là.
Désolé.
pas de quoi, merci d'avoir réfléchi à la question.


Cordialement,

Zylwee

Publicité
Poster une réponse
Anonyme