Twitter iPhone pliant OnePlus 11 PS5 Disney+ Orange Livebox Windows 11

difficultes pour faire marcher une carte wifi BCM43142 802.11b/g/n

9 réponses
Avatar
hamster
Salut a tous.

Je suis entrain d'installer debian 11 et j'ai des soucis pour faire
marcher la carte wifi.

J'ai suivi cette page :
https://debian-facile.org/doc:materiel:wifi:detecter

J'ai fait :
apt install firmware-brcm80211
apt-get install linux-image-$(uname -r|sed 's,[^-]*-[^-]*-,,')
linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') broadcom-sta-dkms
broadcom-sta-source
modprobe -r b44 b43 b43legacy ssb brcmsmac bcma
modprobe wl

# lspci -nnkd ::0280
05:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries
BCM43142 802.11b/g/n [14e4:4365] (rev 01)
    Subsystem: XAVi Technologies Corp. BCM43142 802.11b/g/n [1b9a:3002]
    Kernel driver in use: wl
    Kernel modules: wl

--> selon la page citée ca existe que le pilote est present, j'ai
vérifié que cette carte graphique est bien supportée par wl
https://wiki.debian.org/wl

# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast
state UP group default qlen 1000
    link/ether 00:8c:fa:88:5a:88 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.3/24 brd 192.168.0.255 scope global dynamic
noprefixroute enp1s0
       valid_lft 257803sec preferred_lft 257803sec
    inet6 fe80::28c:faff:fe88:5a88/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
3: wlp5s0: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc
pfifo_fast state DORMANT group default qlen 1000
    link/ether 4c:bb:58:43:86:73 brd ff:ff:ff:ff:ff:ff

--> toujours selon cette page, ca indique que le firmware est présent,
mais j'ai du mal a etre sur que c'est le bon

Il me reste quand meme des messages d'erreur dans dmesg :
[   16.774536] bluetooth hci0: firmware: failed to load
brcm/BCM43142A0-0930-0225.hcd (-2)
[   16.774633] firmware_class: See https://wiki.debian.org/Firmware for
information about missing firmware
[   16.774772] bluetooth hci0: firmware: failed to load
brcm/BCM-0930-0225.hcd (-2)
[   16.774840] Bluetooth: hci0: BCM: firmware Patch file not found, tried:
[   16.774898] Bluetooth: hci0: BCM: 'brcm/BCM43142A0-0930-0225.hcd'
[   16.774953] Bluetooth: hci0: BCM: 'brcm/BCM-0930-0225.hcd'

Je n'ai pas réussi a trouver le firmware BCM-0930 dans la doc de debian.

La carte wifi ne marche toujours pas. J'ai vérifié qu'il n'y ait pas
d'interrupteur materiel interdisant son fonctionnement, qu'elle n'est
pas désactivée dans le BIOS et que le mode avion n'est pas activé.

J'ai pas mal cherché sur le web, je n'ai pas trouvé d'indications
meilleures que sur la page citée plus haut.

Ne sachant plus quoi faire, je me tourne vers vous. Merci pour vos lumières.

9 réponses

Avatar
steve
Salut,
Tu installes sur quelle machine ?
Il semble me souvenir qu'il y a une histoire de secure-boot qui
bloquerait le wifi sur certaines machines DELL. A voir dans le BIOS pour
désactiver cette «Â fonctionnalité ».
Peut-être une piste…
Avatar
Frederic Zulian
--0000000000000a270e05db4d9d23
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
Hmm, peut-̓ªtre devrais-tu tenter cette page-l̓  :
https://wiki.debian.org/fr/bcm43xx
Essay̓© et approuv̓©, mais j'y ai pass̓© pas mal de temps.
Fr̓©d̓©ric ZULIAN
--
Pour la sant̓© de votre ordinateur, pr̓©f̓©rez les logiciels libres.
https://www.april.org/
Le lun. 28 mars 2022 ̓  22:29, hamster a ̓©crit :
Salut a tous.
Je suis entrain d'installer debian 11 et j'ai des soucis pour faire
marcher la carte wifi.
J'ai suivi cette page :
https://debian-facile.org/doc:materiel:wifi:detecter
J'ai fait :
apt install firmware-brcm80211
apt-get install linux-image-$(uname -r|sed 's,[^-]*-[^-]*-,,')
linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') broadcom-sta-dkms
broadcom-sta-source
modprobe -r b44 b43 b43legacy ssb brcmsmac bcma
modprobe wl
# lspci -nnkd ::0280
05:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries
BCM43142 802.11b/g/n [14e4:4365] (rev 01)
Subsystem: XAVi Technologies Corp. BCM43142 802.11b/g/n [1b9a:3002]
Kernel driver in use: wl
Kernel modules: wl
--> selon la page cit̓©e ca existe que le pilote est present, j'ai
v̓©rifi̓© que cette carte graphique est bien support̓©e par wl
https://wiki.debian.org/wl
# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast
state UP group default qlen 1000
link/ether 00:8c:fa:88:5a:88 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.3/24 brd 192.168.0.255 scope global dynamic
noprefixroute enp1s0
valid_lft 257803sec preferred_lft 257803sec
inet6 fe80::28c:faff:fe88:5a88/64 scope link noprefixroute
valid_lft forever preferred_lft forever
3: wlp5s0: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc
pfifo_fast state DORMANT group default qlen 1000
link/ether 4c:bb:58:43:86:73 brd ff:ff:ff:ff:ff:ff
--> toujours selon cette page, ca indique que le firmware est pr̓©sent,
mais j'ai du mal a etre sur que c'est le bon
Il me reste quand meme des messages d'erreur dans dmesg :
[ 16.774536] bluetooth hci0: firmware: failed to load
brcm/BCM43142A0-0930-0225.hcd (-2)
[ 16.774633] firmware_class: See https://wiki.debian.org/Firmware for
information about missing firmware
[ 16.774772] bluetooth hci0: firmware: failed to load
brcm/BCM-0930-0225.hcd (-2)
[ 16.774840] Bluetooth: hci0: BCM: firmware Patch file not found, tried:
[ 16.774898] Bluetooth: hci0: BCM: 'brcm/BCM43142A0-0930-0225.hcd'
[ 16.774953] Bluetooth: hci0: BCM: 'brcm/BCM-0930-0225.hcd'
Je n'ai pas r̓©ussi a trouver le firmware BCM-0930 dans la doc de debian.
La carte wifi ne marche toujours pas. J'ai v̓©rifi̓© qu'il n'y ait pas
d'interrupteur materiel interdisant son fonctionnement, qu'elle n'est
pas d̓©sactiv̓©e dans le BIOS et que le mode avion n'est pas activ̓©.
J'ai pas mal cherch̓© sur le web, je n'ai pas trouv̓© d'indications
meilleures que sur la page cit̓©e plus haut.
Ne sachant plus quoi faire, je me tourne vers vous. Merci pour vos
lumi̓¨res.

--0000000000000a270e05db4d9d23
Content-Type: text/html; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
<div dir="ltr"><div class="gmail_default" style="font-size:small">Hmm, peut-̓ªtre devrais-tu tenter cette page-l̓  :<br></div><div class="gmail_default" style="font-size:small"><br></div><div class="gmail_default" style="font-size:small"><a href="https://wiki.debian.org/fr/bcm43xx">https://wiki.debian.org/fr/bcm43xx</a></div><div class="gmail_default" style="font-size:small"><br></div><div class="gmail_default" style="font-size:small">Essay̓© et approuv̓©, mais j&#39;y ai pass̓© pas mal de temps.<br></div><div class="gmail_default" style="font-size:small"><br></div><div class="gmail_default" style="font-size:small"><br clear="all"></div><div><div dir="ltr" class="gmail_signature" data-smartmail="gmail_signature"><div dir="ltr"><div><div dir="ltr"><div>Fr̓©d̓©ric ZULIAN<br></div><div>--</div><div>Pour la sant̓© de votre ordinateur, pr̓©f̓©rez les logiciels libres.</div><div><a href="https://www.april.org/" target="_blank">https://www.april.org/</a><br><br></div></div></div></div></div></div><br></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">Le͂ lun. 28 mars 2022 ̓ ͂ 22:29, hamster &lt;<a href="mailto:"></a>&gt; a ̓©crit͂ :<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">Salut a tous.<br>
<br>
Je suis entrain d&#39;installer debian 11 et j&#39;ai des soucis pour faire <br>
marcher la carte wifi.<br>
<br>
J&#39;ai suivi cette page :<br>
<a href="https://debian-facile.org/doc:materiel:wifi:detecter" rel="noreferrer" target="_blank">https://debian-facile.org/doc:materiel:wifi:detecter</a><br>
<br>
J&#39;ai fait :<br>
apt install firmware-brcm80211<br>
apt-get install linux-image-$(uname -r|sed &#39;s,[^-]*-[^-]*-,,&#39;) <br>
linux-headers-$(uname -r|sed &#39;s,[^-]*-[^-]*-,,&#39;) broadcom-sta-dkms <br>
broadcom-sta-source<br>
modprobe -r b44 b43 b43legacy ssb brcmsmac bcma<br>
modprobe wl<br>
<br>
# lspci -nnkd ::0280<br>
05:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries <br>
BCM43142 802.11b/g/n [14e4:4365] (rev 01)<br>
͂ ͂ ͂  ͂ Subsystem: XAVi Technologies Corp. BCM43142 802.11b/g/n [1b9a:3002]<br>
͂ ͂ ͂  ͂ Kernel driver in use: wl<br>
͂ ͂ ͂  ͂ Kernel modules: wl<br>
<br>
--&gt; selon la page cit̓©e ca existe que le pilote est present, j&#39;ai <br>
v̓©rifi̓© que cette carte graphique est bien support̓©e par wl<br>
<a href="https://wiki.debian.org/wl" rel="noreferrer" target="_blank">https://wiki.debian.org/wl</a><br>
<br>
# ip a<br>
1: lo: &lt;LOOPBACK,UP,LOWER_UP&gt; mtu 65536 qdisc noqueue state UNKNOWN <br>
group default qlen 1000<br>
͂ ͂ ͂ ͂  link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00<br>
͂ ͂ ͂ ͂  inet <a href="http://127.0.0.1/8&quot; rel="noreferrer" target="_blank">127.0.0.1/8</a> scope host lo<br>
͂ ͂ ͂ ͂ ͂ ͂ ͂  valid_lft forever preferred_lft forever<br>
͂ ͂ ͂ ͂  inet6 ::1/128 scope host<br>
͂ ͂ ͂ ͂ ͂ ͂ ͂  valid_lft forever preferred_lft forever<br>
2: enp1s0: &lt;BROADCAST,MULTICAST,UP,LOWER_UP&gt; mtu 1500 qdisc pfifo_fast <br>
state UP group default qlen 1000<br>
͂ ͂ ͂ ͂  link/ether 00:8c:fa:88:5a:88 brd ff:ff:ff:ff:ff:ff<br>
͂ ͂ ͂ ͂  inet <a href="http://192.168.0.3/24&quot; rel="noreferrer" target="_blank">192.168.0.3/24</a> brd 192.168.0.255 scope global dynamic <br>
noprefixroute enp1s0<br>
͂ ͂ ͂ ͂ ͂ ͂ ͂  valid_lft 257803sec preferred_lft 257803sec<br>
͂ ͂ ͂ ͂  inet6 fe80::28c:faff:fe88:5a88/64 scope link noprefixroute<br>
͂ ͂ ͂ ͂ ͂ ͂ ͂  valid_lft forever preferred_lft forever<br>
3: wlp5s0: &lt;NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP&gt; mtu 1500 qdisc <br>
pfifo_fast state DORMANT group default qlen 1000<br>
͂ ͂ ͂ ͂  link/ether 4c:bb:58:43:86:73 brd ff:ff:ff:ff:ff:ff<br>
<br>
--&gt; toujours selon cette page, ca indique que le firmware est pr̓©sent, <br>
mais j&#39;ai du mal a etre sur que c&#39;est le bon<br>
<br>
Il me reste quand meme des messages d&#39;erreur dans dmesg :<br>
[͂ ͂  16.774536] bluetooth hci0: firmware: failed to load <br>
brcm/BCM43142A0-0930-0225.hcd (-2)<br>
[͂ ͂  16.774633] firmware_class: See <a href="https://wiki.debian.org/Firmware" rel="noreferrer" target="_blank">https://wiki.debian.org/Firmware</a> for <br>
information about missing firmware<br>
[͂ ͂  16.774772] bluetooth hci0: firmware: failed to load <br>
brcm/BCM-0930-0225.hcd (-2)<br>
[͂ ͂  16.774840] Bluetooth: hci0: BCM: firmware Patch file not found, tried:<br>
[͂ ͂  16.774898] Bluetooth: hci0: BCM: &#39;brcm/BCM43142A0-0930-0225.hcd&#39;<br>
[͂ ͂  16.774953] Bluetooth: hci0: BCM: &#39;brcm/BCM-0930-0225.hcd&#39;<br>
<br>
Je n&#39;ai pas r̓©ussi a trouver le firmware BCM-0930 dans la doc de debian.<br>
<br>
La carte wifi ne marche toujours pas. J&#39;ai v̓©rifi̓© qu&#39;il n&#39;y ait pas <br>
d&#39;interrupteur materiel interdisant son fonctionnement, qu&#39;elle n&#39;est <br>
pas d̓©sactiv̓©e dans le BIOS et que le mode avion n&#39;est pas activ̓©.<br>
<br>
J&#39;ai pas mal cherch̓© sur le web, je n&#39;ai pas trouv̓© d&#39;indications <br>
meilleures que sur la page cit̓©e plus haut.<br>
<br>
Ne sachant plus quoi faire, je me tourne vers vous. Merci pour vos lumi̓¨res.<br>
<br>
</div>
--0000000000000a270e05db4d9d23--
Avatar
didier gaumet
Je ne sais pas trop pourquoi ta carte wifi ne marche pas mais au cas
o͹:
- tu peux désinstaller broadcom-sta-source: sa présence ne fait que
causer un risque de conflit de pilotes si tu construis le module par
accident (c'est un moyen de construire le module du pilote mais
manuellement Í  chaque changement de version de noyau, tandis que
broadcom-sta-dkms automatise la construction du module Í  chaque
changement de version de noyau)
- tu peux probablement désinstaller les firmwares broadcom que tu as
installés: je suppose que les firmwares nécessaires sont installés par
broadcom-sta-dkms vu qu'il s'agit du pilote propriétaire WL de
Broadcom? Du coup installer des firmwares pourrait (au conditionnel)
écraser des firmwares nécessaires et installés par broadcom-sta-dkms.
La procédure d'installation de firmwares que tu as suivie est bénéfique
dans le cas de pilotes libres (ne comprenant pas de firmwares).
- du coup une petite réinstallation de broadcom-sta-dkms pourrait être
utile
Avatar
David Martin
--0000000000002f15a405db5a4bea
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
Salut,
Tu as test̓© avec NDISwrapper ?
̓  l'ancienne quoi
Le lun. 28 mars 2022 ̓  22:29, hamster a ̓©crit :
Salut a tous.
Je suis entrain d'installer debian 11 et j'ai des soucis pour faire
marcher la carte wifi.
J'ai suivi cette page :
https://debian-facile.org/doc:materiel:wifi:detecter
J'ai fait :
apt install firmware-brcm80211
apt-get install linux-image-$(uname -r|sed 's,[^-]*-[^-]*-,,')
linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') broadcom-sta-dkms
broadcom-sta-source
modprobe -r b44 b43 b43legacy ssb brcmsmac bcma
modprobe wl
# lspci -nnkd ::0280
05:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries
BCM43142 802.11b/g/n [14e4:4365] (rev 01)
Subsystem: XAVi Technologies Corp. BCM43142 802.11b/g/n [1b9a:3002]
Kernel driver in use: wl
Kernel modules: wl
--> selon la page cit̓©e ca existe que le pilote est present, j'ai
v̓©rifi̓© que cette carte graphique est bien support̓©e par wl
https://wiki.debian.org/wl
# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast
state UP group default qlen 1000
link/ether 00:8c:fa:88:5a:88 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.3/24 brd 192.168.0.255 scope global dynamic
noprefixroute enp1s0
valid_lft 257803sec preferred_lft 257803sec
inet6 fe80::28c:faff:fe88:5a88/64 scope link noprefixroute
valid_lft forever preferred_lft forever
3: wlp5s0: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc
pfifo_fast state DORMANT group default qlen 1000
link/ether 4c:bb:58:43:86:73 brd ff:ff:ff:ff:ff:ff
--> toujours selon cette page, ca indique que le firmware est pr̓©sent,
mais j'ai du mal a etre sur que c'est le bon
Il me reste quand meme des messages d'erreur dans dmesg :
[ 16.774536] bluetooth hci0: firmware: failed to load
brcm/BCM43142A0-0930-0225.hcd (-2)
[ 16.774633] firmware_class: See https://wiki.debian.org/Firmware for
information about missing firmware
[ 16.774772] bluetooth hci0: firmware: failed to load
brcm/BCM-0930-0225.hcd (-2)
[ 16.774840] Bluetooth: hci0: BCM: firmware Patch file not found, tried:
[ 16.774898] Bluetooth: hci0: BCM: 'brcm/BCM43142A0-0930-0225.hcd'
[ 16.774953] Bluetooth: hci0: BCM: 'brcm/BCM-0930-0225.hcd'
Je n'ai pas r̓©ussi a trouver le firmware BCM-0930 dans la doc de debian.
La carte wifi ne marche toujours pas. J'ai v̓©rifi̓© qu'il n'y ait pas
d'interrupteur materiel interdisant son fonctionnement, qu'elle n'est
pas d̓©sactiv̓©e dans le BIOS et que le mode avion n'est pas activ̓©.
J'ai pas mal cherch̓© sur le web, je n'ai pas trouv̓© d'indications
meilleures que sur la page cit̓©e plus haut.
Ne sachant plus quoi faire, je me tourne vers vous. Merci pour vos
lumi̓¨res.

--
david martin
--0000000000002f15a405db5a4bea
Content-Type: text/html; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
<div dir="ltr">Salut,<div><br></div><div>Tu as test̓© avec NDISwrapper ?</div><div>̓  l&#39;ancienne quoi</div><div><br></div></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">Le͂ lun. 28 mars 2022 ̓ ͂ 22:29, hamster &lt;<a href="mailto:"></a>&gt; a ̓©crit͂ :<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">Salut a tous.<br>
<br>
Je suis entrain d&#39;installer debian 11 et j&#39;ai des soucis pour faire <br>
marcher la carte wifi.<br>
<br>
J&#39;ai suivi cette page :<br>
<a href="https://debian-facile.org/doc:materiel:wifi:detecter" rel="noreferrer" target="_blank">https://debian-facile.org/doc:materiel:wifi:detecter</a><br>
<br>
J&#39;ai fait :<br>
apt install firmware-brcm80211<br>
apt-get install linux-image-$(uname -r|sed &#39;s,[^-]*-[^-]*-,,&#39;) <br>
linux-headers-$(uname -r|sed &#39;s,[^-]*-[^-]*-,,&#39;) broadcom-sta-dkms <br>
broadcom-sta-source<br>
modprobe -r b44 b43 b43legacy ssb brcmsmac bcma<br>
modprobe wl<br>
<br>
# lspci -nnkd ::0280<br>
05:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries <br>
BCM43142 802.11b/g/n [14e4:4365] (rev 01)<br>
͂ ͂ ͂  ͂ Subsystem: XAVi Technologies Corp. BCM43142 802.11b/g/n [1b9a:3002]<br>
͂ ͂ ͂  ͂ Kernel driver in use: wl<br>
͂ ͂ ͂  ͂ Kernel modules: wl<br>
<br>
--&gt; selon la page cit̓©e ca existe que le pilote est present, j&#39;ai <br>
v̓©rifi̓© que cette carte graphique est bien support̓©e par wl<br>
<a href="https://wiki.debian.org/wl" rel="noreferrer" target="_blank">https://wiki.debian.org/wl</a><br>
<br>
# ip a<br>
1: lo: &lt;LOOPBACK,UP,LOWER_UP&gt; mtu 65536 qdisc noqueue state UNKNOWN <br>
group default qlen 1000<br>
͂ ͂ ͂ ͂  link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00<br>
͂ ͂ ͂ ͂  inet <a href="http://127.0.0.1/8&quot; rel="noreferrer" target="_blank">127.0.0.1/8</a> scope host lo<br>
͂ ͂ ͂ ͂ ͂ ͂ ͂  valid_lft forever preferred_lft forever<br>
͂ ͂ ͂ ͂  inet6 ::1/128 scope host<br>
͂ ͂ ͂ ͂ ͂ ͂ ͂  valid_lft forever preferred_lft forever<br>
2: enp1s0: &lt;BROADCAST,MULTICAST,UP,LOWER_UP&gt; mtu 1500 qdisc pfifo_fast <br>
state UP group default qlen 1000<br>
͂ ͂ ͂ ͂  link/ether 00:8c:fa:88:5a:88 brd ff:ff:ff:ff:ff:ff<br>
͂ ͂ ͂ ͂  inet <a href="http://192.168.0.3/24&quot; rel="noreferrer" target="_blank">192.168.0.3/24</a> brd 192.168.0.255 scope global dynamic <br>
noprefixroute enp1s0<br>
͂ ͂ ͂ ͂ ͂ ͂ ͂  valid_lft 257803sec preferred_lft 257803sec<br>
͂ ͂ ͂ ͂  inet6 fe80::28c:faff:fe88:5a88/64 scope link noprefixroute<br>
͂ ͂ ͂ ͂ ͂ ͂ ͂  valid_lft forever preferred_lft forever<br>
3: wlp5s0: &lt;NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP&gt; mtu 1500 qdisc <br>
pfifo_fast state DORMANT group default qlen 1000<br>
͂ ͂ ͂ ͂  link/ether 4c:bb:58:43:86:73 brd ff:ff:ff:ff:ff:ff<br>
<br>
--&gt; toujours selon cette page, ca indique que le firmware est pr̓©sent, <br>
mais j&#39;ai du mal a etre sur que c&#39;est le bon<br>
<br>
Il me reste quand meme des messages d&#39;erreur dans dmesg :<br>
[͂ ͂  16.774536] bluetooth hci0: firmware: failed to load <br>
brcm/BCM43142A0-0930-0225.hcd (-2)<br>
[͂ ͂  16.774633] firmware_class: See <a href="https://wiki.debian.org/Firmware" rel="noreferrer" target="_blank">https://wiki.debian.org/Firmware</a> for <br>
information about missing firmware<br>
[͂ ͂  16.774772] bluetooth hci0: firmware: failed to load <br>
brcm/BCM-0930-0225.hcd (-2)<br>
[͂ ͂  16.774840] Bluetooth: hci0: BCM: firmware Patch file not found, tried:<br>
[͂ ͂  16.774898] Bluetooth: hci0: BCM: &#39;brcm/BCM43142A0-0930-0225.hcd&#39;<br>
[͂ ͂  16.774953] Bluetooth: hci0: BCM: &#39;brcm/BCM-0930-0225.hcd&#39;<br>
<br>
Je n&#39;ai pas r̓©ussi a trouver le firmware BCM-0930 dans la doc de debian.<br>
<br>
La carte wifi ne marche toujours pas. J&#39;ai v̓©rifi̓© qu&#39;il n&#39;y ait pas <br>
d&#39;interrupteur materiel interdisant son fonctionnement, qu&#39;elle n&#39;est <br>
pas d̓©sactiv̓©e dans le BIOS et que le mode avion n&#39;est pas activ̓©.<br>
<br>
J&#39;ai pas mal cherch̓© sur le web, je n&#39;ai pas trouv̓© d&#39;indications <br>
meilleures que sur la page cit̓©e plus haut.<br>
<br>
Ne sachant plus quoi faire, je me tourne vers vous. Merci pour vos lumi̓¨res.<br>
<br>
</div><br clear="all"><div><br></div>-- <br><div dir="ltr" class="gmail_signature"><div dir="ltr">david martin<div><br></div></div></div>
--0000000000002f15a405db5a4bea--
Avatar
hamster
Le 29/03/2022 Í  10:55, didier gaumet a écrit :
Je ne sais pas trop pourquoi ta carte wifi ne marche pas mais au cas
o͹:
- tu peux désinstaller broadcom-sta-source: sa présence ne fait que
causer un risque de conflit de pilotes si tu construis le module par
accident (c'est un moyen de construire le module du pilote mais
manuellement Í  chaque changement de version de noyau, tandis que
broadcom-sta-dkms automatise la construction du module Í  chaque
changement de version de noyau)
- tu peux probablement désinstaller les firmwares broadcom que tu as
installés: je suppose que les firmwares nécessaires sont installés par
broadcom-sta-dkms vu qu'il s'agit du pilote propriétaire WL de
Broadcom? Du coup installer des firmwares pourrait (au conditionnel)
écraser des firmwares nécessaires et installés par broadcom-sta-dkms.
La procédure d'installation de firmwares que tu as suivie est bénéfique
dans le cas de pilotes libres (ne comprenant pas de firmwares).
- du coup une petite réinstallation de broadcom-sta-dkms pourrait être
utile

C'est essayé, mais ca n'améliore pas.
Avatar
hamster
Le 28/03/2022 Í  23:05, steve a écrit :
Salut,
Tu installes sur quelle machine ?
Il semble me souvenir qu'il y a une histoire de secure-boot qui
bloquerait le wifi sur certaines machines DELL. A voir dans le BIOS pour
désactiver cette «Â fonctionnalité ».

C'est un ordi toshiba et j'ai déjÍ  désactivé le secure boot.
Avatar
hamster
Le 28/03/2022 Í  23:01, Frederic Zulian a écrit :
Hmm, peut-être devrais-tu tenter cette page-lÍ  :
https://wiki.debian.org/fr/bcm43xx <https://wiki.debian.org/fr/bcm43xx>

J'ai déjÍ  vu cette page, j'ai regardé les differents pilotes dont elle
parle et j'ai vu que la carte qui me pose problème est supportée par wl.
J'ai donc suivi les indications dans la page dédiée a wl, que j'ai déjÍ 
citée.
Avatar
hamster
Le 29/03/2022 Í  14:08, David Martin a écrit :
Salut,
Tu as testé avec NDISwrapper ?
Í  l'ancienne quoi

NDISwrapper n'est plus disponible dans debian 11.
PS : le propriétaire de l'ordi m'a dit "tant pis pour la carte wifi". Je
lui rend donc sa machine avec debian fonctionnel mais la wifi dans les
choux. On saura pas ce qui aurait pu marcher…
Avatar
David Martin
--000000000000f7e58605db5bccb4
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
Salut,
Compile-le toi m̓ªme en partant des sources.
Le mar. 29 mars 2022 ̓  15:05, hamster a ̓©crit :
Le 29/03/2022 ̓  14:08, David Martin a ̓©crit :
Salut,
Tu as test̓© avec NDISwrapper ?
̓  l'ancienne quoi

NDISwrapper n'est plus disponible dans debian 11.
PS : le propri̓©taire de l'ordi m'a dit "tant pis pour la carte wifi". Je
lui rend donc sa machine avec debian fonctionnel mais la wifi dans les
choux. On saura pas ce qui aurait pu marcherÍ¢€¦

--
david martin
--000000000000f7e58605db5bccb4
Content-Type: text/html; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
<div dir="ltr">Salut,<div><br></div><div>Compile-le toi m̓ªme en partant des sources.</div><div><br></div><div><br></div><div><br></div></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">Le͂ mar. 29 mars 2022 ̓ ͂ 15:05, hamster &lt;<a href="mailto:"></a>&gt; a ̓©crit͂ :<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">Le 29/03/2022 ̓  14:08, David Martin a ̓©crit͂ :<br>
&gt; Salut,<br>
&gt; <br>
&gt; Tu as test̓© avec NDISwrapper ?<br>
&gt; ̓  l&#39;ancienne quoi<br>
<br>
NDISwrapper n&#39;est plus disponible dans debian 11.<br>
<br>
PS͂ : le propri̓©taire de l&#39;ordi m&#39;a dit &quot;tant pis pour la carte wifi&quot;. Je <br>
lui rend donc sa machine avec debian fonctionnel mais la wifi dans les <br>
choux. On saura pas ce qui aurait pu marcherÍ¢€¦<br>
<br>
</div><br clear="all"><div><br></div>-- <br><div dir="ltr" class="gmail_signature"><div dir="ltr">david martin<div><br></div></div></div>
--000000000000f7e58605db5bccb4--