Diplômes

Le
Didier
Bonjour,
J'utilise des données Excel pour éditer des dipômes sportifs,au moyen
d'un fusion dans Word.
Savez vous si je peux fusionner cette base excel vers un diplôme sans
utiliser Word, pour une question de simplicité, en restant sous Excel ?
Merci
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Boursicot
Le #1237952
Bonjour,

Tu peux, si tu le souhaites te créer un diplome sur une feuille excel et
utiliser tes données pour remplir les cases variables de ton diplome.
Une simple fonction recherchev te permet en fonction d'un indice de faire
varier les données. Après si tu veux automatiser tu te fais une petite macro
pour lancer les differentes feuilles les unes après les autres.

Est-ce que celà répond à ta question ?

Cordialement.


"Didier" news:
Bonjour,
J'utilise des données Excel pour éditer des dipômes sportifs,au moyen
d'un fusion dans Word.
Savez vous si je peux fusionner cette base excel vers un diplôme sans
utiliser Word, pour une question de simplicité, en restant sous Excel ?
Merci



Didier
Le #1237950
Si j'ai bien compris, il faut créer x diplomes en fonction d'un ordre
d'arrivée, et placer des formules "index Equiv " qui iront chercher les
infos au fur et à mesure des arrivée. cela oblige donc à créer autant de
pages que de coureurs! ne peut on pas automatiser la création des
diplomes au fur et à mesure ?
Merci

Boursicot a écrit:
Bonjour,

Tu peux, si tu le souhaites te créer un diplome sur une feuille excel et
utiliser tes données pour remplir les cases variables de ton diplome.
Une simple fonction recherchev te permet en fonction d'un indice de faire
varier les données. Après si tu veux automatiser tu te fais une petite macro
pour lancer les differentes feuilles les unes après les autres.

Est-ce que celà répond à ta question ?

Cordialement.


"Didier" news:

Bonjour,
J'utilise des données Excel pour éditer des dipômes sportifs,au moyen
d'un fusion dans Word.
Savez vous si je peux fusionner cette base excel vers un diplôme sans
utiliser Word, pour une question de simplicité, en restant sous Excel ?
Merci








Nicolas B.
Le #1282467
Salut,

Voici un petit exemple :

Soient dans la feuille 'Feuil1' les numéros des candidats en A2:A20, les
noms en B2:B20 et en C2:C20 leur niveau.
C'est ta base de données.

Maintenant, sur une autre feuille tu prépare le diplôme tout en couleurs.
Dans une des cellules (par exemple B1) du diplôme tu note le numéro d'un
candidat.
Pour obtenir le nom tu peux alors utiliser la formule :
=RECHERCHEV($B$1;Feuil1!$A$1:$C$20;2;0)
et pour le niveau :
=RECHERCHEV($B$1;Feuil1!$A$1:$C$20;3;0)

En faisant varier la valeur de B1, tu auras donc les différents diplômes
(avec une seule feuille de diplôme).

Si tu veux tous les imprimer, tu peux faire une petite macro comme celle-ci
:

Sub Imprimer_Diplomes()
For Each cel In Range([A2], Sheets("Feuil1").Range("A1").End(xlDown))
With Sheets("Diplôme")
.Range("B1") = cel
.PrintOut
End With
Next
End Sub


A+
--
Nicolas B.


Si j'ai bien compris, il faut créer x diplomes en fonction d'un ordre
d'arrivée, et placer des formules "index Equiv " qui iront chercher
les
infos au fur et à mesure des arrivée. cela oblige donc à créer autant
de pages que de coureurs! ne peut on pas automatiser la création des
diplomes au fur et à mesure ?
Merci

Boursicot a écrit:
Bonjour,

Tu peux, si tu le souhaites te créer un diplome sur une feuille
excel et utiliser tes données pour remplir les cases variables de
ton diplome.
Une simple fonction recherchev te permet en fonction d'un indice de
faire varier les données. Après si tu veux automatiser tu te fais
une petite macro pour lancer les differentes feuilles les unes après
les autres.

Est-ce que celà répond à ta question ?

Cordialement.


"Didier" news:

Bonjour,
J'utilise des données Excel pour éditer des dipômes sportifs,au
moyen
d'un fusion dans Word.
Savez vous si je peux fusionner cette base excel vers un diplôme
sans utiliser Word, pour une question de simplicité, en restant
sous Excel ? Merci






Jean-François Aubert
Le #1282466
Salut Didier,

- Sur la Feuil1 tu crées un diplome type.
tu nommes les champs à remplir : nom, quoi
- Sur la Feuil2, tu as quelque chose du genre:
en col A, les noms des diplomés
en col B, des trucs comme "1 er de la course sur les mains"

sub RemplirlesDiplomes()
sheets("feuil1").activate
for i = 1 to sheets("feuil2").range("A65536").end(xlup).row
sheets("feuil1").[nom]=sheets("feuil2").cells(i,1)
sheets("feuil1").[quoi]=sheets("feuil2").cells(i,2)
ActiveWindow.SelectedSheets.PrintOut Copies:=1, Collate:=True
next
end sub

--
Amicalement

Jean-François Aubert
{Vaudois de la Côte Lémanique}


"Didier"
Si j'ai bien compris, il faut créer x diplomes en fonction d'un ordre
d'arrivée, et placer des formules "index Equiv " qui iront chercher les
infos au fur et à mesure des arrivée. cela oblige donc à créer autant de
pages que de coureurs! ne peut on pas automatiser la création des
diplomes au fur et à mesure ?
Merci

Boursicot a écrit:
Bonjour,

Tu peux, si tu le souhaites te créer un diplome sur une feuille excel et
utiliser tes données pour remplir les cases variables de ton diplome.
Une simple fonction recherchev te permet en fonction d'un indice de faire
varier les données. Après si tu veux automatiser tu te fais une petite macro
pour lancer les differentes feuilles les unes après les autres.

Est-ce que celà répond à ta question ?

Cordialement.


"Didier" news:

Bonjour,
J'utilise des données Excel pour éditer des dipômes sportifs,au moyen
d'un fusion dans Word.
Savez vous si je peux fusionner cette base excel vers un diplôme sans
utiliser Word, pour une question de simplicité, en restant sous Excel ?
Merci











Didier
Le #1282457
merci à tous, je teste

Didier a écrit:
Bonjour,
J'utilise des données Excel pour éditer des dipômes sportifs,au moyen
d'un fusion dans Word.
Savez vous si je peux fusionner cette base excel vers un diplôme sans
utiliser Word, pour une question de simplicité, en restant sous Excel ?
Merci



Publicité
Poster une réponse
Anonyme